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Warehouse Connector Configuration Guide 
Overview
This guide provides an overview of Warehouse Connector and also provides detailed instructions 
on how to configure Warehouse Connector in your network.

 

 

Topics

 l Warehouse Connector Overview

 l Install Warehouse Connector Service on a Log Decoder or Decoder

 l Configure Warehouse Connector

 l Additional Procedures

 l References

 l Troubleshooting Warehouse Connector
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Warehouse Connector Overview
This topic provides an overview of the Warehouse Connector. Warehouse Connector allows you 
to collect meta and events from Decoder and Log Decoder and write them in AVRO format into 
a Hadoop-based distributed computing system.

Implementation Options
You can set up Warehouse Connector as a service on your existing Log Decoder or Decoder 
hosts or it can be run as a virtual appliance in your virtual environment. The Warehouse 
Connector is available as an RPM package file and also as an Open Virtual Appliance (OVA) 
file.

 l Use the RPM package file to set up the Warehouse Connector as a service on your existing 
Log Decoder or Decoder hosts, see Install Warehouse Connector Service on a Log Decoder or 

Decoder.

 l Use the OVA file to set up the Warehouse Connector virtual appliance, see Virtual Host 
Setup Guide.

Components of Warehouse Connector
The Warehouse Connector contains the following components:

 l Data Source

 l Destination

 l Data Stream

Data Source

A data source is the service from which the Warehouse Connector collects data to store in the 
destination. The supported data sources are Log Decoder and Decoder services. The Log 
Decoder collects log events and the Decoder collects packet and meta exclusively.

Destination

Destination is the Hadoop-based distributed computing system that collects, manages, and 
enables analytics and reporting on security data. The following are the supported destinations:
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 l RSA Analytics Warehouse (MapR) deployments

 l RSA Analytics Warehouse (Pivotal) deployments

 l Any Hadoop-based distributed computing system that supports WebHDFS or NFS mounting 
of HDFS file systems.  

 l Example: Commercial MapR M5 Enterprise Edition for Apache Hadoop

Data Streams

A data stream is a logical connection between the data source and destination. You can have 
multiple streams for different subsets of data collected. You can setup streams to segregate data 
from multiple Decoder and Log Decoder services. You can create a stream with multiple data 
sources and a single destination or with a single data source and destination.

Features of Warehouse Connector

The following are the features provided by Warehouse Connector:

 l Aggregates session and raw log data from Decoders and Log Decoders.

 l Transfers the aggregated data into supported destinations like Hadoop based deployments.

 l Serializes the aggregated data that includes both schema and data into AVRO format.

Meta Filters
Meta filters in Warehouse Connector enable you to filter the metas that should be written into 
the Warehouse. For more information, see Specify Meta Filters.

Support for Multi-Valued Meta
RSA Analytics Warehouse supports multi-valued meta. The multi-valued meta is the meta field 
with the array type. You can use the meta library to determine the meta fields of type array and 
write Hive queries with the correct syntax for arrays. By default, the following metas are treated 
as multi-valued and are defined in the file, multivalue-bootstrap.xml located at 
/etc/netwitness/ng in the Warehouse Connector:

 l alias.host

 l action

 l username

 l alias.ip
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 l alias.ipv6

 l email

You can also define an existing meta or a custom meta to be treated as multi-valued meta by 
performing the following:

Caution: Defining an existing meta to be treated as multi-valued may change the data type of 
the meta and cause the associated reports to fail.

 1. Create a new file with the filename multivalue-users.xml in the /etc/netwitness/ng 
directory.

 2. Add the following entries: 

<?xml version="1.0" encoding="utf-8"?>

 

 <Netwitness>

     <MultiValueMetas>

 <Meta>NEWMETANAME</Meta>

     </MultiValueMetas>

 </Netwitness>

Where NEWMETANAME is the existing meta or a custom meta to be treated as multi-valued 
meta. 

Caution: Make sure that you do not add metas that are by default treated as non multi-
value.

 3. Reload the Warehouse Connector Stream. For more information, see Services Config View - 

Warehouse Connector.

Checksum Validation
Warehouse Connector enables you to validate the file integrity of the AVRO files that are 
transferred from the Warehouse Connector to the data destinations. You need to enable 
checksum validation while you configure the Warehouse Connector.

Lockbox Support
Lockbox provides an encrypted file that Warehouse Connector uses to store and protect sensitive 
data. You need to create the lockbox by providing a lockbox password while configuring the 
Warehouse Connector for the first time.
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Install Warehouse Connector Service on a Log 
Decoder or Decoder
This topic provides instructions on how to install the Warehouse Connector service on a Log 
Decoder or Decoder.

Prerequisites
Make sure that you have upgraded the Log Decoder or Decoder to Security Analytics version 
10.6.

Procedure

To install the Warehouse Connector service:

 1. Log on to the Log Decoder or Decoder host.

 2. Enter the following command:
yum install nwwarehouseconnector

The Warehouse Connector service is downloaded and installed on the host.

 3. Get the line number where the REJECT statement appears in the Iptable. Enter the following 
command:
NUM=$(iptables -L INPUT -n --line-numbers |grep 'reject-with' |awk ' 

{print $1}') 

Note: When you execute this command, ensure that the Iptables service is running.

Note: The ACCEPT statements that follow the REJECT statement in the Iptables will not take 
effect. You can incorporate the line number of the REJECT statement in the command to 
ensure that the ACCEPT statements preceed the REJECT statement.

 4. Add the firewall exception for the port 50120 to the Iptables. Enter the following command:
iptables -I INPUT $NUM -m state --state NEW -p tcp --dport 50120 -j 

ACCEPT

 5. Add the firewall exception for the port 50020 to the Iptables. Enter the following command:
iptables -I INPUT $NUM -m state --state NEW -p tcp --dport 50020 -j 

ACCEPT
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 6. Add the firewall exception for the port 56020 to the Iptables. Enter the following command:
iptables -I INPUT $NUM -m state --state NEW -p tcp --dport 56020 -j ACCEPT

 7. Save the Iptables. Enter the following command:
/etc/init.d/iptables save

 8. Restart the Iptables. Enter the following command:
/etc/init.d/iptables restart

 9. Verify that the firewall exceptions for the ports are added. Enter the following command:
Service iptables status | grep 50[01]20

The following output should be displayed: 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:50020

ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:50120

 10. Start the Warehouse Connector service. Enter the following command:
start nwwarehouseconnector

 11. Verify that the Warehouse Connector service is running. Enter the following command:
netstat -anp | grep 50[01]20

The following output should be displayed:
tcp    0   0 0.0.0.0:50120       0.0.0.0:*      LISTEN      2940/NwWarehouseCon

Result
The Warehouse Connector service is successfully installed on the Log Decoder or Decoder host.
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Configure Warehouse Connector
This topic provides high-level tasks to configure the Warehouse Connector.

Prerequisites
Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment.

 l Installed and configured Log Decoder and Decoder in your network environment.

Procedure

To configure Warehouse Connector:

Tasks Reference

 1. Add the Warehouse 
Connector service onto the 
host in your Security 
Analytics deployment.

Refer to Step 1. Add a Warehouse Connector Service

Note: If you want to use the Warehouse Connector 
service, you must start the service before you enable the 
Log Decoder, Decoder, Log Hybrid, and Packet 
Hybrid hosts.

 2. Create the Lockbox. For 
more information, see the 
topic "Lockbox Support" 
in Warehouse Connector 

Overview.

Refer to Step 2. Create the Lockbox.

 3. Configure the data source 
from which the Warehouse 
Connector service needs to 
collect data.

Refer to Step 3. Configure the Data Source.
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Tasks Reference

 4. Configure the destination to 
which the Warehouse 
Connector service writes 
the collected data.

The Warehouse Connector provides the following mech-

anisms to write the collected data to the following des-

tination: 

 l Network File System (NFS) - To write directly to the 
following deployments:  

 l RSA Analytics Warehouse (MapR) 

 l Commercial MapR M5 Enterprise Edition for Apache 
Hadoop

 For detailed instructions, refer to Step 4. Configure the 

Destination Using NFS.

 l Secure File Transfer Protocol (SFTP) - To write data into 
the staging folder on a remote server using SSH Key 
based access or Password based access. You can then 
manually move the data to any of the following 
deployments: 

 l RSA Analytics Warehouse (MapR)

 l RSA Analytics Warehouse (Pivotal)

 l Commercial MapR M5 Enterprise Edition for Apache 
Hadoop

 For detailed instructions, refer to Step 5. Configure the 

Destination Using SFTP.

 l WebHDFS - To write directly to a hadoop-based 
distributed computing system that supports WebHDFS.
 For detailed instructions, refer to Step 6. Configure the 

Destination Using WebHDFS.

 5. Configure the data stream to 
define the data source and 
destination combinations.

Refer to Step 7. Configure Streams
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Step 1. Add a Warehouse Connector Service
This topic provides the instructions on how to add the Warehouse Connector service onto the 
host.

Prerequisites

Ensure that you have added a Warehouse Connector host. Refer to the Add or Update a 
Host topic in the Hosts and Services Getting Started Guide for the procedure to add a host.

Procedure

To add the Warehouse Connector service:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select  > Warehouse Connector.

The Add Service dialog is displayed.

 3. Provide the following details:
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Field Description

Host Select the host where you want to add the service.

Name Type a name for the service.

Port Default port is 50020

SSL Select SSL if you want Security Analytics to communicate with the service 
using SSL. The security of data transmission is managed by encrypting 
information and providing authentication with SSL certificates.

Username Type the Username for the service.

Password Type the password for the service.

 4. Click Test Connection to determine if Security Analytics connects to the service.

 5. When the result is successful, click Save.

The added service is displayed in the Services panel.

Note: If the test is unsuccessful, edit the service information and retry.
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Step 2. Create the Lockbox
This topic provides instructions on how to create the Warehouse Connector Lockbox. A lockbox 
provides an encrypted file that Warehouse Connector uses to store and protect sensitive data. 
You need to create the lockbox by providing a lockbox password while configuring the 
Warehouse Connector for the first time.

Procedure

To set the Lockbox password:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service, and   > View 
> Config.

The Services Config view of Warehouse Connector is displayed.

 4. Click the Lockbox Settings tab.
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 5. In the Create New Lockbox section, perform the following:

 a. In the Lockbox Password field, enter the new lockbox password.

Note: The lockbox password must be at least eight characters in length and they must 
contain at least three of the following groups: one uppercase character [A-Z], one 
lowercase character [a-z], one numeral [0-9], and one special character.

 b. In the Confirm Lockbox Password field, enter the added lockbox password to confirm.

 c. Click Apply.

 

 

Topcs

 l Change the Lockbox Password

 l Refresh the Lockbox
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Change the Lockbox Password

This topic provides instructions on how to change the lockbox password in Warehouse 
Connector.

Procedure

To change the Lockbox password:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service, and  > View 

> Config.
The Services Config view of Warehouse Connector is displayed.
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 4. Click the Lockbox Settings tab.
 

 5. In the Change Lockbox Password section, perform the following: 

 a. In the Current Lockbox Password field, enter the current lockbox password.

 b. In the New Lockbox Password field, enter the new lockbox password. 

Note: The lockbox password must be at least eight characters in length and they must 
contain at least three of the following groups: one uppercase character [A-Z], one 
lowercase character [a-z], one numeral [0-9], and one special character.

 c. In the Confirm New Lockbox Password field, enter the new lockbox password to 
confirm.

 d. Click Apply.
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Refresh the Lockbox

This topic provides instructions on how to reset the Lockbox in the Warehouse Connector when 
the Lockbox is locked out.

Prerequisites

Make sure that you have the current lockbox password.

Procedure

To refresh the Lockbox:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service, and  > View 

> Config.
The Services Config view of Warehouse Connector is displayed.
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 4. Click the Lockbox Settings tab.
 

 5. In the Refresh Lockbox section, enter the current lockbox password in the Lockbox 
Password field.

 6. Click Apply.
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Step 3. Configure the Data Source
This topic describes the tasks to configure the data source from which the Warehouse Connector 
service needs to collect data.

Prerequisites

Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment. 

 l Added the Warehouse Connector service to Security Analytics. For more information, see the 
Add a Service to a Host topic in the Hosts and Services Getting Started Guide.

 l Installed and configured the required Log Decoders and Decoders.

 l Created the lockbox. For more information, see Step 2. Create the Lockbox.

Procedure

To configure the data source:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service, and  > View > 
Config.

The Services Config view of Warehouse Connector is displayed.
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 4. On the Sources and Destinations tab, in the Source Configuration section, click .
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 5. In the Available Services dialog, select the Log Decoder or Decoder services that you want 
to add as source to the Warehouse Connector service and click OK.

Result

The selected Log Decoder and Decoder services are listed in the Source Configuration 
section.
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Step 4. Configure the Destination Using NFS
This topic describes how to configure the destination to which the Warehouse Connector service 
needs to write the collected data.

 l RSA Analytics Warehouse (MapR) deployments

 l Commercial MapR M5 Enterprise Edition for Apache Hadoop deployments

Prerequisites

Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment.

 l Added the Warehouse Connector service  to Security Analytics. For more information, 
see the Add a Service to a Host topic in the Hosts and Services Getting Started Guide.

 l Set up NFS on Warehouse Connector. For more information on how to set up NFS on 
Warehouse Connector, see the Configure Warehouse Connector to Write to Warehouse 
topic in the RSA Analytics Warehouse (MapR) Configuration Guide.

Procedure

To configure the destination:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the Warehouse Connector service, and   > View > Config.

The Services Config View of Warehouse Connector is displayed.
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 4. On the Sources and Destinations tab, in the Destination Configuration section, click .

 5. In the Add Destination dialog, select NFS from the Type drop-down list.

 6. In the Name field, enter a unique symbolic name for the destination.

Note: The Name field does not support space or special characters except underscore (_).

 7. In the Local Mount Path field, enter the locally mounted directory for HDFS where you 
want the Warehouse Connector to write the data.
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For example:
If /saw is the local mount point for HDFS that you have configured while mounting the 
mapr NFS cluster on the host where you have installed the Warehouse Connector service to 
write to RSA Analytics Warehouse (MapR), create a directory 
named Ionsaw01 under /saw and the corresponding Local Mount Path for the destination 
would be /saw/Ionsaw01.

For more information, see the Mount the Warehouse on the Warehouse Connector topic 
in the RSA Analytics Warehouse (MapR) Configuration Guide.

The /saw mount point implies to / as the root path for HDFS. The Warehouse Connector 
writes the data to /Ionsaw01 in HDFS. 

 8. Click Save.

 9. (Optional) If you want to enable checksum validation, perform the following:

 a. In the Security Analytics menu, select Administration > Services.

 b. In the Services view, select the added Warehouse Connector service, and  > View 
> Explore.

The Explore view of Warehouse Connector is displayed.
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 c. In the options panel, navigate to warehouseconnector/destinations/nfs/config.

 d. Set the parameter isChecksumValidationRequired to 1.
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 e. Restart the respective stream.
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Step 5. Configure the Destination Using SFTP
This topic describes the tasks to configure Warehouse Connector to write to a remote destination 
using Secure File Transfer Protocol (SFTP). The remote destination can be a remote server that 
is NFS mounted to the MapR cluster or it can be a remote staging server. 

By default, in the remote destination the Warehouse Connector writes data in the following 
directory structure:

 l /<staging_

folder>/rsasoc/v1/sessions/data/<year>/<month>/<day>/<hour>/

 l /<staging_

folder>/rsasoc/v1/logs/data/<year>/<month>/<day>/<hour>/

Where <staging_folder> is the folder on the remote server where the Warehouse Connector 
writes the data.

If you are using a remote staging server as the remote destination, you need to manually copy or 
move the directory structure to any of the following deployments:

 l RSA Analytics Warehouse (MapR)

 l Commercial MapR M5 Enterprise Edition for Apache Hadoop

 l Pivotal HD

Caution:  To generate reports from the data written by Warehouse Connector, make sure that 
in your Hadoop deployment you maintain a similar directory structure that is created by 
Warehouse Connector in the remote destinations.

The following illustration describes how you can use SFTP to write data from Warehouse 
Connector to a remote destination.
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Prerequisites

Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment.

 l Added the Warehouse Connector service to Security Analytics. For more information, see the 
Add a Service to a Host. topic in the Hosts and Services Getting Started Guide.

 l For the SFTP destination type, the destination host should be listed in the /root/.ssh/known_
hosts file used by the ssh service (i.e. sshd) running on the Warehouse Connector.
To add the destination host to the /root/.ssh/known_hosts file, from the Warehouse 
Connector host, initiate a secure connection to the destination host. Perform the following 
steps: 
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 1. Login to the Warehouse Connector.

 2. Enter ssh root@<SAWIP> or ssh username@<SAWIP>.

 3. Select Yes and enter the password.

 4. Add the host key in the /root/.ssh/known_hosts file

Note: After you upgrade Warehouse Connector to 10.6, you must make sure that the 
destination host is listed in the /root/.ssh/known_hosts file used by the ssh service 
(i.e. sshd) running on the Warehouse Connector. If you do not perform this action, the 
streams configured with SFTP in Warehouse Connector will not start. 

 l If you want to use SFTP to write data into the destination using SSH key-based access, you 
need to configure SSH key-based access between the Warehouse Connector and the 
Warehouse host or hadoop node. For more information, see Configure SSH Keys below. 

Note: If you want to enable checksum validation to validate the integrity of the AVRO files 
that are transferred from the Warehouse Connector to the destinations, make sure that you 
generate the keys without setting the passphrase and do a key exchange between 
warehouse connector and the warehouse nodes.

Procedures

Configure Warehouse Connector to Write to a Remote Destination

To configure the destination:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service, and  > View 

> Config.
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The Services Config view of Warehouse Connector is displayed.

 4. On the Sources and Destinations tab, in the Destination Configuration section, click .

 5. In the Add Destination dialog, select SFTP from the Type drop-down list.

 

 6. In the Name field, enter a unique symbolic name for the destination. 

Note: The Name field does not support space or special characters except underscore (_).
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 7. In the Host field, enter the remote server IP address.

 8. In the Port field, retain the default port, 22.

 9. In the Username field, enter the SSH username. 

Note: In the case of Pivotal HD, ensure that the username is gpadmin and for password-
based access the password for gpadmin should be used or for passphrase-based access, the 
passphrase used to generate the keys for gpadmin user should be used.

 10. In the Password/Passphrase field, enter one of the following: 

 n SSH password, if you are using SFTP to write data into the destination using password-
based access.

 n SSH passphrase, if you are using SFTP to write data into the destination using SSH key-
based access.

 11. In the Remote Path field, enter the path of the directory present on the SFTP server.

 12. Click Save.

 13. (Optional) If you want to enable checksum validation, perform the following: 

 a. In the Security Analytics menu, select Administration > Services.

 b. In the Services view, select the added Warehouse Connector service, and  > View 

> Explore. 
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The Explore view of Warehouse Connector is displayed.

 c. In the options panel, navigate to warehouseconnector/destinations/sftp/config.
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 d. Set the parameter isChecksumValidationRequired to 1.

 e. Restart the respective stream.

Configure SSH Keys

Follow these steps to configure SSH key-based access between the Warehouse Connector 
and the Warehouse host or hadoop node.

 1. Generate SSH keys on the Warehouse Connector at the default location. Perform the 
following: 

 a. Log on to the Warehouse Connector.

 b. Type the following command and press ENTER: 

 $ ssh-keygen -t dsa

 c. The command prompts you to enter the file in which to save the generated key. 

 Enter file in which to save the key (/root/.ssh/id_dsa):

 d. Enter the file in which you want to save the key and press ENTER.
The command prompts you to enter and confirm the passphrase. 
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 Enter passphrase (empty for no passphrase):

 Enter same passphrase again:

The public key is generated and is saved in the location that you provided. 

Note: If you want to enable checksum validation to validate the integrity of the AVRO 
files that are transferred from the Warehouse Connector to the destinations, make sure 
that you do not set the passphrase.

 2. Append the generated public key to the remote Warehouse host or hadoop node's authorized 
keys list located at:~/.ssh/authorized_keys

Result

You can now securely communicate between Warehouse Connector and Warehouse nodes or 
hadoop nodes.

Configure Warehouse Connector 38



Warehouse Connector Configuration Guide

Step 6. Configure the Destination Using WebHDFS
This topic describes the tasks to configure the Warehouse Connector service to write the 
collected data to a hadoop-based distributed computing system that supports WebHDFS. 

Prerequisites

Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment.

 l Added the Warehouse Connector service to Security Analytics. For more information, see the 
Add a Service to a Host topic in the Hosts and Services Getting Started Guide.

 l Added the hostname (or FQDN) and IP address of the warehouse nodes and Warehouse 
Connector to the DNS server.  If the DNS server is not configured the add the hostname 
(or FQDN) and IP address of the warehouse nodes and Warehouse Connector to the file in 
the host on which the Warehouse Connector service is installed.

 l If you want Kerberos authentication between the warehouse connector and the 
warehouse cluster, make sure that you perform the following: 

 l Kerberos Key Distribution Center (KDC) Server is configured in your network 
environment and the Kerberos Keytab file is copied to the host on which you have installed 
Warehouse Connector.<kerberos&nbsp;authentication>

 l Kerberos authentication is enabled in the warehouse cluster. For instructions, see the 
Warehouse documentation.

 l If you want to enable checksum validation to validate the integrity of the AVRO files that are 
transferred from the Warehouse Connector to the destinations, make sure that you generate 
the keys without setting the passphrase and do a key exchange between warehouse connector 
and the warehouse nodes. You need to configure SSH key-based access between the 
Warehouse Connector and the Warehouse host or hadoop node. For more information, see 
Configure SSH Keys below.

Configure Warehouse Connector to Write to a Remote Destination

To configure the destination:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.
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 3. In the Services view, select the added Warehouse Connector service and  > View 

> Config.
The Services Config view of Warehouse Connector is displayed.
 

 4. On the Sources and Destinations tab, in the Destination Configuration section, click .

 5. In the Add Destination dialog, select WebHDFS from the drop-down list.
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 6. In the Name field, enter a unique symbolic name for the destination. 

Note: The Name field does not support space or special characters except underscore (_).

 7. In the Hadoop IP field, enter the namenode IP address of the warehouse cluster.

 8. In the Hadoop Port field, enter the base port that is used by the namenode web user 
interface.

 9. In the Username field, enter the owner of the directory in the warehouse to which 
Warehouse Connector should write the data.

 10. In the Hadoop Path field, enter the path of the directory in the warehouse to which 
Warehouse Connector should write the data.

 11. Select the Kerberos Authentication checkbox, if you want the warehouse connector to 
securely communicate with the warehouse using Kerberos authentication.

 

 Perform the following: 

 a. In the Kerberos Principal field, enter the KDC Principal used 
for Kerberos authentication.

 b. In the Kerberos Keytab File Path field, enter the path of the Kerberos Keytab file in 
the Warehouse Connector.

 12. Click Save.
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 13. (Optional) If you want to enable checksum validation, perform the following: 

 a. In the Security Analytics menu, select Administration > Services.

 b. In the Services view, select the added Warehouse Connector service and  > View 

> Explore.
The Explore view of Warehouse Connector is displayed.
 

 c. In the options panel, navigate to warehouseconnector/destinations/webhdfs/config.
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 d. Set the parameter isChecksumValidationRequired to 1.
 

 e. Restart the respective stream.

Configure SSH Keys

Follow these steps to configure SSH key-based access between the Warehouse Connector and 
the Warehouse host or hadoop node.

To configure SSH keys:

 1. Generate SSH keys on the Warehouse Connector at the default location. Perform the 
following:

 a. Log on to the Warehouse Connector.

 b. Type the following command and press ENTER:

$ ssh-keygen -t dsa

 c. The command prompts you to enter the file in which to save the generated key.

Enter file in which to save the key (/root/.ssh/id_dsa):

 d. Enter the file in which you want to save the key and press ENTER.
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The command prompts you to enter and confirm the passphrase.

Note: Make sure that you do not set the passphrase .

Enter passphrase (empty for no passphrase):

Enter same passphrase again:

The public key is generated and is saved in the location that you provided.

 2. Append the generated public key to the remote Warehouse host or hadoop node's authorized 
keys list located at: ~/.ssh/authorized_keys 

Note: Make sure that you copy the public keys to the hadoop node and while copying the 
public key ensure that you provide the login details of the user using which the WebHDFS 
destination would be added.

Result

You can now securely communicate between Warehouse Connector and Warehouse nodes or 
hadoop nodes.
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Step 7. Configure Streams
This topic describes the tasks to configure the data stream to define the data source and 
destination combinations.

Prerequisites

Make sure that you have:

 l Installed the Warehouse Connector service or virtual appliance in your network environment.

 l Added the Warehouse Connector service to Security Analytics. For more information, see the 
Add a Service to a Host topic in the Hosts and Services Getting Started Guide.

 l Configured the data source form which the Warehouse Connector service needs to collect 
data. For more information, see Step 3. Configure the Data Source.

 l Configured the destination to which the Warehouse Connector service needs to write the 
collected data. For more information, see Configure the Destination.

Procedure

To configure the stream:

Tasks References

1. Create a stream Refer to Create a Stream.

2. Finalize the stream Refer to Finalize the Stream.

3. Start the stream Refer to Start the Stream.

 

 

Topics

 l Create a Stream

 l Edit a Stream

 l Finalize the Stream

 l Start the Stream

45 Configure Warehouse Connector



Warehouse Connector Configuration Guide

Create a Stream

This topic covers the tasks to create a stream.

Procedure

To create a stream:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select the added Warehouse Connector service and  > View > 

Config.
The Services Config view of Warehouse Connector is displayed.

 3. Click the Streams tab.
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 4. On the Streams tab, click .

 

 5. In the Add Stream dialog, perform the following: 

 a. In the Stream Name field, enter a name for the stream. 

Note: The Stream Name field does not support space or special characters except 
underscore (_).

 b. In the Select Destination drop-down menu, select a destination from the list of 
destinations added to the Warehouse Connector.

 c. In the Select Source field, select sources from the list of sources displayed.

 d. In the Session ID column, enter the last session id.
If you provide any session id, the Warehouse Connector will start the aggregation from 
that session, whereas if this is left blank, the aggregation will start from the current 
session.

 e. Click Save.

Next Steps

Perform the following tasks:

 1. Finalize the stream. For more information, see Finalize the Stream.

 2. Start the stream. For more information, see Start the Stream.

47 Configure Warehouse Connector



Warehouse Connector Configuration Guide

Edit a Stream

This topic covers the tasks to edit a stream. You can edit a stream to perform the following:

 l Add more data sources to the stream.

 l Delete existing data sources from the stream.

Procedure

To edit a stream:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select the added Warehouse Connector service and  > View 

> Config.
The Services Config view of Warehouse Connector is displayed.
 

 3. On the Streams tab, click .

 4. In the Edit Stream dialog, you can perform the following:
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 l On the Available Sources tab, you can select the available data sources to add to the 
stream and click Save.
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 l On the Current Sources tab, you can delete an existing data source from the stream. 
Select the data source and click .
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Finalize the Stream

This topic covers the tasks to finalize a stream.

Prerequisites

Make sure that you have created a stream. For more information, see Create a Stream.

Procedure

To finalize the stream:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select the added Warehouse Connector service and  > View > 

Config.
The Services Config view of Warehouse Connector is displayed.

 3. On the Streams tab, select the stream that you have created.
 

 4. Click Finalize.
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Next Steps

Start the created stream. For more information, see Start the Stream.
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Start the Stream

This topic covers the tasks to start the created stream.

Prerequisites

Make sure that you have:

 l Created the stream. For more information, see Create a Stream.

 l Finalized the stream. For more information, see Finalize the Stream.

Note: If you have deployed a Warehouse Connector Virtual Appliance, make sure that you 
change the default value of the Maximum Message Hold Count parameter to 800000. For 
more information, see Services Config View - Warehouse Connector.

Procedure

To start the stream:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select the added Warehouse Connector service and  > View > 

Config.
The Services Config view of Warehouse Connector is displayed.
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 3. On the Streams tab, select the stream that you have created.
 

 4. Click Start.

Next Steps

To configure alert mechanisms related to the Warehouse Connector and its storage, click To 
configure the alert mechanisms related to the Archiver storage navigate here. For more 
information, see Configure Warehouse Connector Monitoring.
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Additional Procedures
This topic is a collection of individual procedures, which an Administrator may perform at any 
time and they are not required to complete the initial setup of Warehouse Connector. These 
procedures are presented in alphabetical order. Use this section when you are looking for 
instructions to perform a specific task after the initial setup of Warehouse Connector.

 

 

Topics

 l Configure Warehouse Connector Monitoring

 l Reload the Stream

 l Specify Meta Filters

 l Update the Port Number and SSL Settings of the Source
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Configure Warehouse Connector Monitoring
This topic provides instructions on how to configure the alert mechanisms related to the 
Warehouse Connector and its storage. Configuring Warehouse Connector monitoring enables 
you to automatically generate notifications when critical thresholds concerning Warehouse 
Connector and its storage have been met. 

Procedure

To configure archiver storage monitoring:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service and  > View 

> Config.
The Services Config view of Warehouse Connector is displayed.

 4. Click the Streams tab.
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 5. At the bottom of the Streams tab, click To configure the alert mechanisms related to the 
Warehouse Connector navigate here.
The Warehouse Connector Monitoring page is displayed.
 

Caution: This page is deprecated and will be removed in a future release. 

 6. In the Source or Destination Status section, select the number of minutes or hours in the 
Notify After Failing For field.

 7. You will receive a notification if the source or destination connection fails for the defined 
number of minutes or hours.

 8. In the Stream Status section, perform the following: 

 a. In the Notify Stopped For field, define the number of minutes or hours after which you 
would like to receive a notification when the stream goes offline.

 b. In the Disk Is field, define the limit on the percentage of disk usage after which you 
would like to receive a notification.
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 c. In the Source is Behind field, define the number the sessions, a notification is raised if 
the source goes behind the defined number of sessions. 

 d. In the Rejected Folder Size is field, define the limit on the percentage of folder usage 
after which would like to receive a notification.

 e. In the Number Of Files in Permanent Failure Folder field, define the limit on the 
number of files in the permanent failure folder after which you would like to receive a 
notification.

 9. In the Notification Type field, perform the following: 

 a. Click Configure email or distribution list to configure email so that you can receive 
notifications in Security Analytics. For more information, see the Configure Email 
Server and Notification Account topic in the System Configuration guide.

 b. Click Configure Syslog and SNMP Trap servers to configure audit logs. For more 
information, see the Configure Syslog and SNMP Settings topic  in the System 
Configuration guide.

 c. Select the following notification mechanisms as per your requirement: 

 l SA Console - To get notifications on the Security Analytics UI notification toolbar.

 l Email - To get email notifications.

 l Syslog Notification - To generate syslog events.

 l SNMP Trap Notifications - To get audit events as SNMP traps.
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Reload the Stream
This topic provides instructions on how to reload a stream. When you reload the stream, the 
Warehouse Connector updates the schema file for the stream. You should reload the stream 
whenever you add a new custom meta to the Log Decoder or Decoder.

Procedure

To reload the stream:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select the added Warehouse Connector service and  > View > 

Config.
The Services Config view of Warehouse Connector is displayed.

 3. On the Streams tab, select the stream that you want to reload.

 4. Click Reload.
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Specify Meta Filters
 

This topic provides instructions on how to specify meta filters in Warehouse Connector. You 
need to specify the filter for each stream in the export.session.meta.fields parameter in 
the Explore view of the Warehouse Connector.

The following table lists the values that you can provide as a filter:

Values Description

* All the collected metas are written to SAW.

*, meta1, meta2 All the metas except the defined metas are written to SAW.

 For example,

 Filter:*,ip.src

 All the metas except ip.src is written to SAW.

meta1, meta2, meta3 Only the defined metas are written to SAW.

Note: By default, the following metas are wriiten to Warehouse even if you specify them in 
the filter:
 - ng_source
 - unique_id
 - time

Procedure

To specify meta filters:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select a Warehouse Connector services and  > View > Explore.

The Explore view of the Warehouse Connector service is displayed.
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 3. In the options panel, select warehouseconnector > streams > <stream_name> > loader 
> config.
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 4. In the export.session.meta.fields parameter, enter the filter.
 

 5. Restart the stream.
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Update the Port Number and SSL Settings of the Source
This topic provides instructions on how to update port number or SSL settings details of the data 
source in Warehouse Connector.
 If there is change in the port number or SSL settings of the data sources used in the Warehouse 
Connector, you can directly update these details in Warehouse Connector, using the 
Explore view of the Warehouse Connector.

Prerequisites

Make sure that:

 l You have the updated port number or SSL settings of the data source.

 l You stop the streams related to the data source that you want to update the port number or 
SSL settings.

Procedure

To update the port number or SSL settings:

 1. Log on to Security Analytics.

 2. In the Security Analytics menu, select Administration > Services.

 3. In the Services view, select the added Warehouse Connector service and  > View 
> Explore.

The Service Explore view of Warehouse Connector is displayed.
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 4. Navigate to warehouseconnector/sources, right-click the source, and click Properties.
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 5. The Properties section of the source is displayed.
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 6. In the drop-down menu, select update. In the Parameters field, perform the following:

 l To update the port number of the source, enter port=<new_source_portnumber> and 
click Send.

 l To update the SSL settings of the source, enter ssl=<new_ssl_settings> and click 
Send.

Note: You can also update the port number and ssl settings simultaneous by adding 
space between the parameters.

 7. Restart the Warehouse Connector service.

 8. Start the streams.
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References
This topic is a collection of references, which describe the user interface for Warehouse 
Connector in Security Analytics. 

 

 

Topics

 l Services Config View - Warehouse Connector

 l Services System View - Warehouse Connector
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Services Config View - Warehouse Connector
This topic provides an overview of the Warehouse Connector Services Config view. The tabs for 
a Warehouse Connector in the Services Config view provide a way to manage basic service 
configuration, configure sources, configure destination, and configure streams.

The following are the tabs in the Warehouse Connector Services Config view:

 l Sources and Destinations

 l Streams

 l Lockbox Settings

 l General

 l Appliance Service Configuration

Sources and Destinations

The Sources and Destinations tab contains the following two sections:
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 l Source Configuration

 l Destination Configuration

Source Configuration

The Source Configuration section allows you to configure the data sources form which the 
Warehouse Connector service needs to collect data.

The following is an example of the Source Configuration section.

The Source Configuration section allows you to perform the following.

Features Description

Add the data source.

Delete the data source.

Destination Configuration

The Destination Configuration section allows you to configure the destination to which the 
Warehouse Connector service needs to write the collected data.

The Destination Configuration section allows you to perform the following.

Features Description

Add the destination.
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Features Description

Delete the destination.

Edit the destination. 

Note: You can only edit the SFTP destination 
type.

Streams

The Streams tab allows you to perform all of the tasks related to a stream.

The Streams tab allows you to perform the following.

Features Description

Add a stream.

Delete a stream.
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Features Description

Edit the stream.

Start the stream.

Stop the stream.

Finalize the stream.

Reload the stream.

 If you have added a new meta or if a new meta is added as part of content 

update to any of the sources, Log Decoder or Decoder, you need to reload the 

stream for the meta to be visible in the schema for the Reporting Engine. Reload-

ing a stream does not have any impact on the data but only the new meta list is 

fetched from the sources.

The Streams tab also lists all the created streams in a tabular format.

Column Name Description

Name Name of the stream.

Sources The sources associated with the stream.

Destination The destinations associated with the stream.

Status Status of the stream.

Stream Statistics

You can view the statistics of a configured stream. Click the  icon next to the name of the 
stream.

71 References



Warehouse Connector Configuration Guide

The following parameters are displayed in the Stream Statistics.

Section Parameter Description

Stream   

 Number of 

files in the 

permanent 

rejected 

folder

Determines the number of files in the permanent rejected folder 

(named, permfail) in the Warehouse Connector. The permanent 

rejected folder contains the files that Warehouse Connector 

failed to write to the destination.

 Rejected 

folder usage 

in per-

centage

Determines the disk usage of the rejected folder. 

 Session Rate Determines the rate at which the session is processed by the 

Warehouse Connector for the source.
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Section Parameter Description

Destination   

 Status Indicates the status of the destination.

Source   

 Status Indicate the status of the source. 

 Sessions 

Behind

Determines that number of sessions that needs to be processed 

by the Warehouse Connector.

 Last Session 

read

Determines the last session id processed by the Warehouse Con-

nector.

Change Stream Configuration

You can change configuration of a stream in runtime. In the Streams tab, click Change 
Configuration to change the configuration of the selected stream.
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You can change the following parameters of the Stream Configuration:

Note: If you change the value of any parameter in stream configuration, make sure that you 
restart the stream.

After upgrading, if the values of Maximum Message Hold Count, Maximum Message Hold 
Interval and Maximum Message Hold Size are 3000000, 60 and 128 respectively, ensure that 
you assign the following values to the streams:

Maximum Message Hold Count - 2400000

Maximum Message Hold Interval - 600

Maximum Message Hold Size - 512

You can assign these values by selecting Administration > Services > Select the Warehouse 
Connector service >  > View > Config > Streams tab > Select the existing Stream > 
Change Configuration.
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Section Parameter Description

Aggregation 

Configuration

  

 Aggregate max 

sessions

Determines the maximum number of sessions in a 

response for an aggregation request from the Warehouse 

Connector to the source .

 Aggregation 

Interval

Determines the time between the responses from the 

source.

Loader Set-

tings

  

 Compress files 

on disk

Enable to compress files on disk.

Supported values: 

 l deflate - Provides smaller compressed files and good 
performance while generating reports.

 l off
By default, the parameter is set to deflate.
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Section Parameter Description

 Export Rollup 

Interval

Determines the roll-up interval for export files and also 

the directory structure the Warehouse Connector writes to 

the destination. 

 For example: 

 If the parameter is set to: 

Value Directory Structure

hour /rsasoc/v1/[logs | sessions]/data/{year}/

{month}/{day}/{hour}

minute /rsasoc/v1/[logs | sessions]/data/{year}/

{month}/{day}/{hour}/{minute}

day /rsasoc/v1/[logs | sessions]/data/{year}/

{month}/{day}

If you change the value of the parameter, ensure that you 

restart the stream. 

Recommended value is hour.

 Maximum Mes-

sage Hold Count

Determines the maximum number of sessions to store in 

the memory before processing. 

Note: If you have deployed a Warehouse Connector 
Virtual Appliance, make sure that you change the 
default  value of the parameter to 800000.

 Maximum Mes-

sage Hold Inter-

val (Seconds)

Determines the maximum time (in seconds) to hold the 

sessions in memory before processing.

 Maximum Mes-

sage Hold Size

Determines the maximum size for the sessions to store in 

the memory before processing.
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Section Parameter Description

 Remote Export 

Path

Determines the  remote local mount point for HDFS 

(nfs://) and the location to export the data.

 Page Size

Stream Set-

tings

  

 Auto Startup Enable to automatically start the stream whenever the 

Warehouse connector process is restarted. By default, the 

parameter is set to off.

Lockbox Settings

The Lockbox Settings tab allows you can set, change, or refresh the lockbox password of the 
Warehouse Connector.

77 References



Warehouse Connector Configuration Guide

General

The General tab displays the system configuration parameters for the Warehouse Connector 
service.

When you add a Warehouse Connector service, default values are in effect. RSA designed the 
default values to accommodate most environments and recommends that you do not edit these 
values because it may adversely affect performance. The following table describes the System 
Configuration parameters.

Name Config Value

Compression Determines the minimum amount of bytes before a message is compressed. If 

set to zero, messages are not compressed.

Port Determines the port used by the service. 

Note: If you change the port number, ensure that you restart the service.

SSL If enabled, all the data transferred in the network will be encrypted using SSL.
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Name Config Value

Stat Update 

Interval

Determines how often (in milliseconds) statistic nodes are updated in the sys-

tem.

Threads Determines the number of threads in the thread pool to handle incoming 

requests.

Appliance Service Configuration

The Appliance Service Configuration tab displays the appliance configuration settings for 
Warehouse Connector service. For more information, see the Appliance Service Configuration 
topic in the Hosts and Services Getting Started Guide.

 

 

Related Topic

 l Add Stream Dialog
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Add Stream Dialog
This topic provides a description of the Add Stream dialog. In the Add Stream dialog, you can 
configure and add a stream to a Warehouse Connector.

To access this dialog:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select a Warehouse Connector service and select  > View > 

Config.

 3. In the Streams tab, click .

The Add Stream dialog is displayed.

 

For related procedures, refer to Create a Stream and Configure Warehouse Connector.

The following table describes the Add Stream dialog parameters.

Parameter Description

Stream 

Name

Type the name of the stream. The stream name may only contain alphanumeric 

characters and underscores. It cannot exceed 20 characters in length.
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Parameter Description

Select 

Destination

Select a destination from the drop-down list.

Select 

Source

Select a source from the grid at the bottom section of the dialog.

Name The name of the source.

Address The address of the source.

Port The port of the source.

Session ID The session ID of the source.
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Services System View - Warehouse Connector
This topic provides an overview of the Warehouse Connector Services System view. While 
information displayed in the Services System view is the same for all types of core services, 
several options in the toolbar are relevant only for Warehouse Connector.

You can access this view by doing the following:

 1. In the Security Analytics menu, select Administration > Services.

 2. In the Services view, select a Warehouse Connector and  > View > System.

The Systems view for the selected Warehouse Connector is displayed.

Toolbar Options

The following is an example of toolbar options for Warehouse Connectors.

Host Tasks, Shutdown Service, Shutdown Appliance Service or (Shutdown Appliance), and 
Reboot are common to all services and are described in the Services System View topic in the 
Hosts and Services Getting Started Guide.
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Troubleshooting Warehouse Connector
This topic provides information about possible issues that Security Analytics users may 
encounter when adding a Warehouse service to the Reporting Engine as a data source for 
reporting in Security Analytics. Look for explanations and solutions in this topic.

While adding a Warehouse service to the Reporting Engine as a data source for reporting, you 
may observe some of the errors listed in this document. Information is provided on how to 
troubleshoot the errors and add the data source successfully.

The following figure shows the New Service dialog.

For more information, see the Add Warehouse as a Data Source to Reporting Engine topic in 
the Reporting Engine Configuration Guide.

83 Troubleshooting Warehouse Connector



Warehouse Connector Configuration Guide

Error Possible Solutions

Could not open connection to HiveServer  l Ensure that the HiveServer2 is running on 
the Host.

 l Check if the port provided can be 
accessible from the Reporting Engine 
server.

No Schema found in HDFS path Ensure that meta avro data file(s) 
are available in the HDFS path
 (<HDFS Path>/rsasoc/v1/sessions/meta) 
mentioned.
 The following figure shows an example of 
the command to check the files in hdfs.

Could not open connection to HiveServer, 

GSS initiate failed

GSS initiate failed errors will be observed 

only in the case of Kerberos enabled Hive.

 Ensure that the proper keytab file is provided 

and it should have read options for the 

rsasoc user (user on which the Reporting 

Engine Server runs).

 Ensure that the system time is synchronized 

between KDC, Hadoop (Pivotal) server, and 

the Reporting Engine system.
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