
Log Collection Configuration Guide
for Version 11.1



Copyright © 1994-2018 Dell Inc. or its subsidiaries. All Rights Reserved.

Contact Information
RSA Link at https://community.rsa.com contains a knowledgebase that answers common 
questions and provides solutions to known problems, product documentation, community 
discussions, and case management.

Trademarks
For a list of RSA trademarks, go to www.emc.com/legal/emc-corporation-trademarks.htm#rsa.

License Agreement
This software and the associated documentation are proprietary and confidential to Dell, are 
furnished under license, and may be used and copied only in accordance with the terms of such 
license and with the inclusion of the copyright notice below. This software and the 
documentation, and any copies thereof, may not be provided or otherwise made available to any 
other person.

No title to or ownership of the software or documentation or any intellectual property rights 
thereto is hereby transferred. Any unauthorized use or reproduction of this software and the 
documentation may be subject to civil and/or criminal liability.

This software is subject to change without notice and should not be   construed as a commitment 
by Dell.

Third-Party Licenses
This product may include software developed by parties other than RSA. The text of the license 
agreements applicable to third-party software in this product may be viewed on the product 
documentation page on RSA Link. By using this product, a user of this product agrees to be fully 
bound by terms of the license agreements.

Note on Encryption Technologies
This product may contain encryption technology. Many countries prohibit or restrict the use, 
import, or export of encryption technologies, and current use, import, and export regulations 
should be followed when using, importing or exporting this product.

Distribution
Dell believes the information in this publication is accurate as of its publication date. The 
information is subject to change without notice.

May 2018

https://community.rsa.com/
http://www.emc.com/legal/emc-corporation-trademarks.htm#rsa


Contents

 

About Log Collection 7
Workflow 7

High-Level Procedures 8

Log Collection Architecture 10
How You Deploy Log Collection 10

Components of Log Collection 10

Local and Remote Collectors 11

Windows Legacy Remote Collector 12

Setup 14
Basic Implementation 14

Prerequisites 14

Roles of Local and Remote Collectors 14

Deploying and Configuring Log Collection 14

Adding Local Collector and Remote Collector to NetWitness Suite 16

Configuring Log Collection 16

Data Flow Diagram 16

Provision Local Collectors and Remote Collectors 17

Configure Local and Remote Collectors 19

Configure Failover Local Collector 24

Configure Replication 26

Configure Chain of Remote Collectors 29

Throttle Remote Collector        to Local Collector Bandwidth 32

Set Up a Lockbox 34

What Is a Lockbox 35

Set Up a Lockbox 35

Start Collection Services 36

Start a Collection Service 36

Enable Automatic Start of Collection Services 37

Verify That Log Collection Is Working 37

Configure Certificates 38

Add a Certificate 38



Log Collection Configuration Guide

Certificates Panel 38

Add Cert Dialog 39

Log Collection Basics 40
How Log Collection Works 40

Collection Protocols 40

Basic Procedure 42

Configure Collection in RSA NetWitness Suite 43

Start the Service for your Collection Method 44

Verify that Collection is working for your Event Source 44

Configure Event Filters for a Collector 44

Configure an Event Filter 44

Modify Filter Rules 49

Import, Export, Edit and Test Event Sources in Bulk 51

Import Event Sources in Bulk 51

Export Event Sources in Bulk 53

Edit Event Sources in Bulk 54

Test Event Source Connections in Bulk 55

See Also 56

Configure Collection Protocols and Event Sources 57
Configure AWS (CloudTrail) Event Sources in NetWitness Suite 59

How AWS Collection Works 59

Deployment Scenario 59

Configuration 60

AWS Parameters 61

Configure Azure Event Sources in NetWitness Suite 65

Configuration in NetWitness Suite 65

Azure Parameters 66

Configure Check Point Event Sources in NetWitness Suite 68

How Check Point Collection Works 69

Deployment Scenario 69

Configuration in NetWitness Suite 70

Check Point Parameters 71

Basic Parameters 71

Determine Advanced Parameter Values for Check Point Collection 72

Verify Check Point Collection is Working 74

4



Log Collection Configuration Guide

Configure File Event Sources in NetWitness Suite 75

Configure a File Event Source 75

Stop and Restart File Collection 76

File Collection Parameters 77

Configure Netflow Event Sources in NetWitness Suite 81

Configure a Netflow Event Source 81

Netflow Collection Parameters 83

ODBC 84

Configure ODBC Event Sources in NetWitness Suite 84

Configure a DSN 85

Add an Event Source Type 86

Configure Data Source Names (DSNs) 88

Create Custom Typespec for ODBC Collection 95

Troubleshoot ODBC Collection 100

Configure SDEE Event Sources in NetWitness Suite 101

Configure SNMP Event Sources in NetWitness Suite 104

Configure the SNMP Trap Event Source 104

(Optional) Configure SNMP Users 105

SNMP User Parameters 105

Configure Syslog Event Sources for Remote Collector 106

Configure a Syslog Event Source 106

Syslog Parameters 107

Configure VMware Event Sources in NetWitness Suite 110

Configure Windows Event Sources in NetWitness Suite 111

Windows Legacy and NetApp Collection Configuration 114

How Legacy Windows and NetApp Collection Works 114

Deployment Scenario 116

Set Up the Windows Legacy Collector 116

Configure Windows Legacy and NetApp Event Sources 117

Troubleshoot Windows Legacy and NetApp Collection 123

Windows Log Collection for Endpoint Agents 127

Add or Update Windows Log Collection Configuration to an existing Endpoint Agent 128

Verify Windows Log Collection 130

Enable log forwarding and Configure Log Decoder 131

5



Log Collection Configuration Guide

Reference 133
AWS Parameters 133

Azure Parameters 139

Check Point Parameters 142

Basic Parameters 143

Determine Advanced Parameter Values for Check Point Collection 144

File Parameters 147

Log Collection Service System View 153

ODBC Event Source Configuration Parameters 155

Access ODBC Configuration Parameters 155

Data Source Name (DSN) Parameters 156

Sources Panel 156

Toolbar 156

Add or Edit DSN Dialog 157

ODBC DSNs Event Source Configuration Parameters 160

Access ODBC Configuration Parameters 160

DSN Panel 161

Add or Edit DSN Dialog 162

Manage DSN Templates Dialog 162

Remote/Local Collectors Configuration Parameters 164

Remote Collectors Tab 165

Local Collector       Tab 166

Log Collection Tabs 167

Access Log Collection View 167

Available Tabs 167

Log Collection General Tab 169

Log Collection Event Destinations Tab 173

Log Collection Event Sources Tab 176

Log Collection SettingsTab 180

Troubleshoot Log Collection 182
Log Files 182

Health and Wellness Monitoring 182

Sample Troubleshooting Format 182

Troubleshooting - Windows log Collection using Endpoint Agent 183

Windows Log Configuration File Format Explained 183

Test Log - How to Read 184

6



About Log Collection
This guide describes the high-level steps and subtasks for setting up and configuring log 
collection for event sources that include:

 l What Log Collection does, how it works from a high level, and provides high-level 
deployment diagrams.

 l How to start collecting events.

 l Where to find instructions to set up more complex deployments.

 l How to start any collection protocol.

 l What the structure of the Log Collection Configuration User Interface is.

 l Which tools to use to troubleshoot Log Collection issues and lists global troubleshooting 
instructions.

 l How to fine tune and customize Log Collection in your environment.

 l How to configure  individual collection protocols. Instructions are in the individual Log 
Collection sections.

Workflow

This workflow depicts the basic tasks needed to start collecting events through Log 
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Collection.

High-Level Procedures
At a high level, these are the procedures you must follow for log collection:

 I. Add local and remote collectors to RSA NetWitness Suite.

Set up a Log Collector   locally on a Log Decoder (that is a Local Collector). You can also set 
up Log Collectors   in as many remote locations (that is Remote Collectors)  as you need for 
your enterprise. For details, see Basic Implementation.

 II. Download the latest content from Live. This is a task that you perform periodically, as the 
content provided on Live is updated regularly.

LIVE is the Content Management System for RSA NetWitness® Suite, from which you 
download the latest content.  The two resource types you use to download Log Collection 
content are:

 l RSA Log Collector - content enabling the collection of event source types.

 l RSA Log Device - the latest supported event source parsers.

You can also subscribe to content on Live. For details, see the Live Services Management 
Guide.

About Log Collection 8
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 III. Configure Settings: set up the lockbox and Certificates.

For details, see Set Up a Lockbox and Configure Certificates.

 IV. Configure Event Sources.

You configure all the event sources on your network to send their log information to 
RSA NetWitness Suite. Whenever you add new event sources, you need to perform this 
procedure as well. All event source configuration guides are found in the RSA Supported 
Event Sources space in RSA Link.

 V. Start and stop services for configured protocols. Occasionally, you may be required to stop 
and restart services, based on new event sources that you add to RSA NetWitness Suite.

 VI. Verify that Log Collection is working.

Whenever you set up a new event source or add a new collection protocol, you should verify 
that the correct logs are being sent to RSA NetWitness Suite.

9 About Log Collection
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Log Collection Architecture
This topic describes how NetWitness Suite performs log collection.

How You Deploy Log Collection
You can deploy Log Collection according to needs and preferences of your enterprise. This 
includes deploying Log Collection across multiple locations and collect data from varying sets of 
event sources. You do this by setting up a Local Collector with one or many Remote Collectors.

Components of Log Collection
The following figure shows all the components involved in event collection through the 
NetWitness Suite Log Collector.

Log Collection Architecture 10
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Local and Remote Collectors
The following figure illustrates how the Local and Remote Collectors interact to collect events 
from all of your locations.

In this scenario, log collection from various protocols like Windows, ODBC, and so on, is 
performed through both the Remote Collector and Log Collector service. If the log collection is 
done by the Local Collector, it is forwarded to the Log Decoder service, just like the local 
deployment scenario. If the log collection is done by a Remote Collector, there are two methods 
in which these are transferred to the Local Collector:

 l Pull Configuration - From a Local Collector, you select the Remote Collectors from which 
you want to pull events.

 l Push Configuration - From a Remote Collector, you select the Local Collector to which you 
want to push events.

Note: The typical use case is Push. Pull is available if you have a DMZ in your environment. 
Less secure network segments are not allowed to make connections to more secure network 
segments. With Pull, the Log Collector (or Virtual Log Collector) in the secure network 
initiates the connection to the VLC in the less secure network, and the logs are then 
transferred without breaking the connection rules.

You can configure one or more Remote Collectors to push event data to a Local Collector, or 
you can configure a Local Collector to pull event data from one or more Remote Collectors.

Additionally, you can set up a chain of Remote Collectors for which you can configure:

 l One or more Remote Collectors to push event data to a Remote Collector.

 l A Remote Collector to pull event data from one or more Remote Collectors.

11 Log Collection Architecture
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Windows Legacy Remote Collector
The RSA NetWitness® Suite Windows Legacy Collector is a Microsoft Windows based remote 
log collector (RC) which can be installed on a Windows domain.

It supports collection from:

 n Windows 2003 and earlier event sources

 n NetApp ONTAP host evt files

The following figure illustrates the deployment required to collect events from Windows Legacy 
event sources.
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Setup

Basic Implementation
This topic tells how to perform the initial setup of Local Collectors and Remote Collectors.

Prerequisites

Verify that the Log Decoder is set up:

 l is capturing data.

 l has the current content loaded.

 l is properly licensed.

Roles of Local and Remote Collectors

A Local Collector (LC) is a Log Collector   service running on a Log Decoder host. In a local 
deployment scenario, the Log Collector   service is deployed on a Log Decoder host, with the Log 
Decoder service. Log collection from various protocols like Windows, ODBC, and so on, is 
performed through the Log Collector   service, and events are forwarded to the Log Decoder 
service. The Local Collector sends all collected event data to the Log Decoder service.

You must have at least one Local Collector to collect non-Syslog events.

A Remote Collector (RC), also referred to as a Virtual Log Collector   (VLC), is a Log Collector   
service running on a stand-alone Virtual Machine. Remote Collectors are optional and they must 
send the events they collect to a Local Collector. Remote Collector deployment is ideal when 
you have to collect logs from remote locations. Remote Collectors compress and encrypt the logs 
before sending them to a Local Collector.

Deploying and Configuring Log Collection

The following figure illustrates the basic tasks you must complete to deploy and configure Log 
Collection. To deploy Log Collection, you need to set up a Local Collector. You can also deploy 
one or more Remote Collectors. After you deploy Log Collection, you need to configure the 
events sources in NetWitness Suite and on the events sources themselves. The following 
diagram shows the Local Collector with one Remote Collector that pushes events to the Local 
Collector.
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 Set up Local and Remote Collectors.

The Local Collector is the Log Collector   service running on the Log Decoder host.

A Remote Collector is the Log Collector   service running on a virtual machine or Windows 
server in a remote location.

 Configure event sources:

 l Configure collection protocols in C:\Temp\Malware Analysis Configuration Guide for 
Version 11.0.

 l Configure each event source to communicate with the NetWitness SuiteLog Collector.  
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Adding Local Collector and Remote Collector to NetWitness Suite

To add a Local Collector and Remote Collector to NetWitness Suite:

 1. Go to  ADMIN > Services.

 2. Click  and select Log Collector from the menu.

The Add Service dialog box is displayed.

 3. Define the details of the Log Collection service.

 4. Select Test Connection to ensure that your Local or Remote Collector is added.

Configuring Log Collection

You choose the Log Collector—that is a Local Collector (LC) or Remote Collector (RC)—for 
which you want to define parameters in the Services view. The following figure shows how to 
navigate to the Services view, select a Log Collector   service, and display the configuration 
parameter interface for that service.

 1. Go to ADMIN > Services.

 2. Select a Log Collection service.

 3. Click   under Actions and select View > Config to display the Log Collection 

configuration parameter tabs.

 4. Define global Log Collection parameters in the General tab.

 5. For a:

 l Local Collector, NetWitness Suite displays the Remote Collectors tab. Select the 
Remote Collectors from which the Local Collector pulls events in this tab.

 l Remote Collector, NetWitness Suite displays the Local Collectors. Select the Local 
Collectors to which the Remote Collector pushes events in this tab.

 6. Edit configuration files as text files in the Files tab.

 7. Define collection protocol parameters in the Event Sources tab.

 8. Define the lockbox, encryption keys, and certificates in the Settings tab.

 9. Define Appliance Service parameters in the Appliance Service Configuration tab.

Data Flow Diagram

You use the log data collected by the Log Collector   service to monitor the health of your 
enterprise and to conduct investigations. The following figure shows you how data flows through 
NetWitness Suite Log Collection to Investigation.
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Provision Local Collectors and Remote Collectors

The NetWitness Suite server verifies if an appliance has a Log Decoder service. If there is a 
Log Decoder service, it becomes a Local Collector. If a Log Decoder service is missing, it 
becomes a Remote Collector. A local Log Collector has an Event Destination and by default 
goes to the Local Log Decoder service. A Remote Collector does not have an Event Destination. 
The NW Server server identifies a Legacy Windows Collector as a Remote Collector.
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To edit a Local Collector or Remote Collector :

 1. Go to ADMIN > Services.

 2. In the Services view, select  in the toolbar.

The Edit Service dialog is displayed.

 3. In the Edit Service dialog, provide the following information.

Field Description

Service Select Log Collector as the service type.

Host Select a Log Decoder host.

Name Type name you want to assign to the service.

Port Default port is 50001 for clear text and 56001 for SSL encrypted.

SSL Select SSL if you want NetWitness Suite to communicate with the 
host using SSL. The security of data transmission is managed by 
encrypting information and providing authentication with SSL 
certificates.
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Field Description

(Optional) 
Username

Type the username of the Local Collector.

(Optional) Password Type the password of the Local Collector.

 4. Click Test Connection to determine if NetWitness Suite  connects to the service.

 5. When the result is successful, click Save.

If the test is unsuccessful, edit the service information and retry. 

Configure Local and Remote Collectors

This topic describes how to configure Local and Remote Collectors.

When you deploy Log Collection, you must configure the Log Collectors to collect the log events 
from various event sources, and to deliver these events reliably and securely to the Log Decoder 
service, where the events are parsed and stored for subsequent analysis.

You can configure one or more Remote Collectors to push event data to a Local Collector, or 
you can configure a Local Collector to pull event data from one or more Remote Collectors.

This topic describes how to:

 l Configure Local Collector to Pull Events from Remote Collector

If you want a Local Collector to pull events from Remote Collector, you set this up in the 
Remote Collectors tab of the Local Collector's Configuration view.

 l Configure Remote Collector to Push Events to Local Collectors

If you want a Remote Collector to push events to a Local Collector, you set this up in the 
Local Collector tab of the Remote Collector's Configuration view. In the Push configuration, 
you can also:

 l Configure Failover Local Collector for Remote Collector

You set up a destination made up of local collectors.  When the primary Local Collector is 
unreachable, the Remote Collector  attempts to connect to each Local Collector in this 
destination until it makes a successful connection.

 l Configure Replication

You set up multiple destination groups so that NetWitness replicates the event data in each 
group. If the connection to one of the destination groups fails, you can recover the required 
data because it is replicated in the other destination group.

 l Configure Log Routing for Specific Protocols
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You set up multiple destinations in a destination group to direct event data to specific 
locations according to protocol type.

 l Configure Chain of Remote Collectors

You can set up a chain of Remote Collectors to push event data to a Local Collector, or you 
can configure a Local Collector to pull event data from a chain of Remote Collectors. 

 l You can configure one or more Remote Collectors to push event data to a Remote 
Collector.

 l You can configure a Remote Collector to pull event data from one or more Remote 
Collectors.

Failover, Replication and Load Balancing

This section describes failover, replication, and load balancing work in how RSA NetWitness 
Suite.

The following figure illustrates a Remote Collector configured for load balancing, failover 
and replication.
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 l Failover is achieved by setting up multiple collectors in the same Destination. Destination 1 
has a primary Collector, and second, failover Collector. This is done in NetWitness Suite by 
adding multiple Log Collectors to the same Destination.

Since 10.101.214.8 is listed first, that becomes the primary collector, and 10.101.214.9 
becomes the failover. To make 10.101.214.9 the primary, use the up arrow to change the 
order.

Below, you can see the two collectors both listed for Destination 1. The primary 
(10.101.214.8) is in bold.

  

 l Replication is accomplished by having multiple Destination Groups: each group receive the 
entire set of message data.
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In the following screen, you can see that message data is sent to the collectors in Group 1 and 
Group 2.

 l Load balancing is achieved by setting up multiple Destinations within a Group.

In the following screen, you can see that Group 1 has two destinations, Destination 1 and 
Destination 2. The message data is divided up equally among the Destinations in the group.
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With two Destinations, each destination receives half the message data. With three 
Destinations, each would receive 1/3 of the total message data. Keep adding Destinations to 
further reduce the load on the collectors in each destination.

Note: You can also set up log routing so that event data for specific protocols is sent to 
specific destinations.

Configure a Local Collector or Remote Collector

You choose the Log Collector, that is a Local Collector (LC) or Remote Collector (RC), for 
which you want to define deployment parameters in the Services view. The following procedure 
shows you how to navigate to the Services view, select a Local or Remote Collector, and 
display the deployment parameter interface for that service.

To configure a Local Collector or Remote Collector:

 1. Go to ADMIN > Services. 

 2. Select a Local or Remote Log Collection service.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Depending on your selection in step 2:

 l If you selected a Local Collector, the Remote Collectors tab is displayed. Select the 
Remote Collectors from which the Local Collector pulls events in this tab.

 l If you selected a Remote Collector, the Local Collectors are displayed. Select the Local 
Collectors to which the Remote Collector pushes events in this tab.

Remote Collectors Tab

The following figure depicts the Remote Collectors tab for a Local Collector that is configured 
to pull events from a Remote Collector. NetWitness Suite displays this tab when you have 
selected a Local Collector in Admin > Services.
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Local Collectors Tab for a Remote Collector

The following figure depicts a Local Collectors tab for a Remote Collector that is configured to 
push events to a Local Collector or another Remote Collector.

The following figure depicts the Local Collectors tab for a Remote Collector that is configured 
to pull events from a Remote Collector. NetWitness Suite displays this tab when you have 
selected a Remote Collector in Admin > Services.

Parameters

 Remote/Local Collectors Configuration Parameters

Configure Failover Local Collector

This topic tells you how to set up a Failover Local or Remote Collector.

Set up a Failover Local Collector

You can set up a Failover Local Collector       that RSA NetWitness® Suite will fail over to if your 
primary Local Collector       stops operating for any reason.
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 1. Go to ADMIN> Services.

 2. In Services, select a Remote Collector service.

 3. Click   under Actions and select View > Config.

The Service Config view is displayed with the Log Collector    General tab open.

 4. Select the Local Collectors tab.

 5. In the Destination Groups panel section, select .

The Add Remote Destination dialog displays.

 6. Set up a Destination Group and select a primary Local Collector       (for example, LC-
PRIMARY).

 7. Select the Group (for example, Primary_Standby_LCs) in the Destination Groups panel 
and click  .

The Group you selected is displayed in the Local Collectors panel.

 8. Add the Failover Local Collector       (for example, LC-STANDBY).

The following examples show the newly added primary and failover Local Collectors 
showing the primary Local Collector       as Active and the Failover Local Collector       as Standby. 
The active Local Collector       is highlighted (for example, LC-PRIMARY).

 9. (Optional) Add, delete, and change the order of Local Collectors to each Remote 
Destination.

 a. Click   to add a Log Collector    as a failover Remote Destination.

 b. When connecting to a Remote Destination, the Remote Collector        will attempt to connect 
to each Local Collector       in this list in order, until it makes a successful connection.

 c. Select a Local Collector       and use the up ( ) and down ( ) arrow buttons to change the 

order of connection. 

 d. Select one or more Local Collectors and click   to remove them from the list.

The selected Local Collectors are added to the Log Collector    section. When the Remote 
Collector        starts collecting data, it pushes data to these Log Collectors.

Set up a Failover Remote Collector

You can set up a Failover Remote Collector        that RSA NetWitness® Suite  will fail over to if 
your primary Remote Collector stops operating for any reason.

 1. Go to  ADMIN > Services.

 2. In Services, select a Remote Collector service.
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 3. Click   under Actions and select View > Config.

The Service Config view is displayed with the Log Collector    General tab open.

 4. Select the Local Collectors tab.

 5. Select Sources in Select Configuration drop-down menu.

 6. Click  to display in Add Source dialog.

 7. Define the failover Remote Collector        and click OK.

Parameters

 Remote/Local Collectors Configuration Parameters

Configure Replication

This topic tells you how to replicate event data sent by a Remote Collector.

You can specify multiple Destination Groups so that the event data is replicated to each group.

To replicate event data to multiple Local Collectors:

 1. Go to ADMIN > Services.

 2. Select a Remote Log Collection service.

 3. Under Actions, select   > View > Config.

The Service Config view is displayed with the Log Collector    General tab open.

 4. Select the Local Collectors tab.

 5. In the Destination Groups panel section, click .

The Add Remote Destination dialog is displayed.
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 6. Set up a separate Destination for each Local Collector and designate the protocols for which 
you want to push event messages to that Local Collector. The following examples shows the 
addition of two Destination Local Collectors (Destination1 and Destination2) for the Check 
Point, File, Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection protocols:

27 Setup



Log Collection Configuration Guide

 a. Type the Destination Name.

 b. Type the Group Name. If you do not type a Group Name, the Destination Name is taken 
as the Group Name.

 c. Select the collection protocols in the drop-down list.

 d. Select a Local Collector (for example, LC1).

 e. Click OK.

 f. Select the new group (for example, DestinationGroup2) group in the Destination 
Groups panel and click  in the Local Collector panel.

 g. In the Local Collector panel, click  and complete the Add Remote Destination 
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dialog as illustrated in the following figure.

The Check Point, File, Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection 
protocols are sent to two Local Collectors (LC1 and LC2). Both Local Collectors are active and 
collecting event data.

Configure Chain of Remote Collectors

This topic describes how to chain Remote Collectors (also referred to as VLCs).

You can set up a chain of Remote Collectors to push event data to a Remote Collector, or you 
can configure a Remote Collector to pull event data from a chain of Remote Collectors.

 l Remote Collectors to push  data. Push data from a  Remote Collector to other  Remote 
Collectors or Local Collectors. 

 l Remote Collector to pull data.  Use a  Remote Collector to pull data from one or more  
Remote Collectors.
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Configure Remote Collector to Push Event Data to Remote Collector

You can configure a Remote Collector to push event data to a Remote Collector.

Configure a Remote Collector to Push Events to Specified Remote Collector

 1. Go to  ADMIN > Services.

 2. In Services, select a Remote Collector.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 
parameter tabs.

The Log Collector    Service Config view is displayed with the Log Collector    General tab 
open.

 4. Select the Local Collectors tab.

 5. Select Destinations in the Select Configurations drop-down menu.

 6. In the Destination Groups panel section, select .

The Add Remote Destination dialog is displayed.

 7. Set up a Destination Group:

 a. Enter a Destination Name.

 b. (Optional) Enter a Group Name. If you leave Group Name blank, NetWitness Suite   
sets it to the value that you specified in Destination Name.

 c. Select one or more collection protocols in the Collections drop-down list.
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 d. Under Log Collectors Addresses, click   to select a Remote Collector.

Note: If you do not select a collection protocol, the Remote Collector pushes all 
collection protocols to the Remote Collectors.

Configure Remote Collector to Pull Event Data from a Remote Collector

Configure the Selected Remote Collector to Pull Events from Specified Remote Collector

 1. Go to ADMIN > Services.

 2. In Services, select a Remote Collector.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 
parameter tabs.

The Service Config view is displayed with the Log Collector    General tab open.

 4. Select the Local Collectors tab.
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 5. Select Sources in the Select Configurations drop-down menu.

 6. In the Remote Collectors panel, select .

The Add Source dialog is displayed.

 7. In the Add Source dialog:

 a. Select one or more collection protocols.
If you do not select a collection protocol, the Remote Collector pulls all collection 
protocols from the Remote Collector.

 b. Click OK.

The Remote Collector is added to the Remote Collector section. When the Log Collector    
starts collecting data, it pulls event data from this Remote Collector.

Throttle Remote Collector        to Local Collector Bandwidth

To improve performance, you can throttle the bandwidth to control the rate that the Remote 
Collector        sends event data to Local Collector or between Message Brokers. To do this, you 
configure the Linux kernel's filtering and IPTable functionality.

This works for both push and pull Remote Collector        configurations. The set-shovel-transfer-
limit.sh shell script located on the /opt/netwitness/bin automates the configuration of the kernel 
filter and iptables related to this port.

This topic describes how to throttle Remote Collector        to Local Collector bandwidth using the 
set-shovel-transfer-limit.sh shell script. It contains the following sections:

 l The set-shovel-transfer-limit.sh shell script command line help.

Note: The filter value that you need to set depends on the rate at which remote log 
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collector is sending events to the Local Collector.

 l An example that sets the Filter to 4096 kilobits per second.

Command Line Help for Set Shovel Transfer Limit Script

Issue the –h command to display help for set-shovel-transfer-limit.sh shell script.

cd /opt/netwitness/bin
./set-shovel-transfer-limit.sh

Usage:

code>set-shovel-transfer-limit.sh -s|-c|-d|[-i interface] [-r 
rate]

where:

 l -c = clear existing

 l -d = display filter

 l -s = set new values

 l -i = interface is the name of the network interface. Default value is eth0

 l -r = rate is the bandwidth rate. Default value is 256kbps

Bandwidths and rates can be specified in:

 l nolimit: disables throttling

 l kbit: Kilobits per second

 l mbit: Megabits per second

 l kbps: Kilobytes per second

 l mbps: Megabytes per second

 l bps: Bytes per second

Set the Filter to 4096 Kilobits per Second

This example sets the Filter to 4096 kilobits per second.

[root@<hostname> bin]#./set-shovel-transfer-limit.sh -s -r 
4096kbit

RATE=4096kbit
 PORTNUMBER=5671
 DEVICE_INTERACE=eth0
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iptables: No chain/target/match by that name.
iptables: No chain/target/match by that name.
iptables: Saving firewall rules to /etc/sysconfig/iptables:[ OK 
]

Current/new values...

iptables -t mangle -n -v -L
 Chain PREROUTING (policy ACCEPT 2 packets, 161 bytes)
 pkts bytes target  prot opt in  out  source          
destination

Chain INPUT (policy ACCEPT 2 packets, 161 bytes)
 pkts bytes target prot opt in out   source           destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target prot opt in out   source           destination

Chain OUTPUT (policy ACCEPT 2 packets, 248 bytes)
 pkts bytes target prot opt in out   source           destination
      0    0 MARK   tcp -- *    eth0     0.0.0.0/0     0.0.0.0/0     
multiport dports 5671 MARK set 0xa
      0    0 MARK   tcp -- *    eth0     0.0.0.0/0      0.0.0.0/0    
multiport sports 5671 MARK set 0xa

Chain POSTROUTING (policy ACCEPT 2 packets, 248 bytes)
 pkts bytes target prot opt in out   source           destination

tc -s -d class show dev eth0
 class htb 1:1 root rate 10000Kbit ceil 10000Kbit burst 1600b/8 
mpu 0b overhead 0b cburst 1600b/8 mpu 0b overhead 0b level 7
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 rate 0bit 0pps backlog 0b 0p requeues 0
 lended: 0 borrowed: 0 giants: 0
 tokens: 20000 ctokens: 20000         

class htb 1:2 parent 1:1 prio 0 quantum 51200 rate 4096Kbit ceil 
4096Kbit burst 1599b/8 mpu 0b overhead 0b cburst 1599b/8 mpu 0b 
overhead 0b level 0
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 rate 0bit 0pps backlog 0b 0p requeues 0
 lended: 0 borrowed: 0 giants: 0
 tokens: 48828 ctokens: 48828         

Set Up a Lockbox
This topic tells you how to configure Lockbox Security Settings.
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What Is a Lockbox

A lockbox is an encrypted file that you use to store confidential information about an application. 
The NetWitness Suite Lockbox stores an encryption key for the Log Collector.

The encryption key is used to encrypt all event source passwords and the event broker password.

When you create the Lockbox, you need to define a password for the Lockbox.

TheLog Collector operates the Lockbox in a mode during data collection that does not require 
you to specify the password (theLog Collector uses the host system fingerprint instead).

These are the lockbox security settings.

Feature Description

Old 

Lockbox 

Password

When you set up a Lockbox for the first time, this field is blank.  NetWitness Suite 

populates this field after you enter a New Lockbox Password and click Apply.

New 

Lockbox 

Password

Initial or new lockbox password.  To maximize lockbox security, specify a 

password that is eight or more characters in length with at least one numeric 

character, uppercase character, and non-alphanumeric character such as # or ! 

Apply Click Apply to save the changes to the lockbox password.

Set Up a Lockbox

To set up a lockbox you need to set a password, as follows:

 1. Go to ADMIN > Services.

 2. Select a Log Collection service.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Settings tab.
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 5. In the options panel, select Lockbox to configure Lockbox settings.

 6. Under Lockbox Security Settings, enter a password in the New Lockbox Password field 
and click Apply.

Start Collection Services
If a collection service stops, you may need to start it again. You can also enable the automatic 
start of collection services.

Start a Collection Service

 1. Go to ADMIN > Services.

 2. Select a Log Collector service and click  under Actions.

 3. Click View > System.

 4. Click Collection > service (for example File) and click Start.
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Enable Automatic Start of Collection Services

 1. Go to Admin > Services.

 2. Select a Log Collector service and click  under Actions.

 3. Click View > Config.

The General tab is displayed.

 4. In the Collector Configuration panel, select Start Collection on Service Startup for the 
individual collection services that you want to start automatically. Alternatively, select 
Enable All to automatically start all collection services.

 5. Click Apply for your changes to take effect.

Verify That Log Collection Is Working
This topic tells you how to verify that you have set up Log Collection correctly.

The following methods verify that Log Collection is working.

 l Verify that there is event activity the Event Source Monitoring tab of the Administration 
> Health & Wellness  view.

 l Verify that there are parsers in the device.type field in the Details column in the 
Investigation > Events view for the collection protocol you configured.

Please refer to the topics for each Collection Protocol for steps on how to verify that the protocol 
is set up correctly.
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Configure Certificates
You manage certificates by creating trust stores on the Log Collector. The Log Collector refers 
to these trust stores to determine whether or not the event sources are trusted.

Add a Certificate

To add a certificate:

 1. Go to ADMIN >   Services.

 2. In the Services grid, select a Log Collector service.

 3. Click  under Actions and select View > Config.

 4. Click the Settings tab.

 5. In the options panel, select Certificates.

 6. Click  in the Certificates tool bar.

The Add Cert dialog is displayed.

 7. Click Browse and select a certificate (*.PEM) from your network.

 8. Specify a password (if required).

 9. Click Save.

Certificates Panel

The following table describe the buttons and columns available in the Certificates panel.

Field Description

Opens the Add Cert dialog in which you can add a certificate and 

password.

Deletes the selected certificates.

Selects certificates.

Trust Store Name Displays the name of the trust store.

Certificate 

Distinguished Name

For Check Point event source only, displays the distinguished name 

for the certificate.
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Field Description

Certificate Password 

Name

For Check Point event source only, displays the password name for 

the certificate.

Add Cert Dialog

The following table describes the parameters available in the Add Cert dialog.

Field Description

Trust Store Name Enter a trust store name.

File Click Browse to select a certificate (*.PEM file) file from your network

Password Specify the password for this certificate. 

Close Closes the dialog without adding a certificate.

Save Adds the certificate.
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How Log Collection Works
The Log Collector   service collects logs from event sources throughout the IT environment in an 
organization and forwards the logs to other NetWitness Suite components. The logs and the 
descriptive content are stored as meta data for use in investigations and reports.

Event sources are the assets on the network, such as servers, switches, routers, storage arrays, 
operating systems, and firewalls. In most cases, your Information Technology (IT) team 
configures event sources to send their logs to the Log Collector   service and the NetWitness 
Suite administrator configures the Log Collector   service to poll event sources and retrieve their 
logs. As a result, the Log Collector   receives all logs in their original form.

Collection Protocols
RSA NetWitness Suite can collect logs from a wide variety of event sources. When you are 
configuring log collection for a specific event source, you need to know, first and foremost, the 
protocol that is used to collect the logs.

Collection 
Protocol

Description

Check Point Collects events from Check Point event sources using OPSEC LEA. OPSEC 
LEA is the Check Point Operations Security Log Export API that facilitates the 
extraction of logs. For details, see Configure Check Point Event Sources in 
NetWitness Suite.

File Collects events from log files. Event sources generate log files that are 
transferred using a secure file transfer method to the Log Collector   service.

For details, see Configure File Event Sources in NetWitness Suite.

Netflow Accepts events from Netflow v5 and Netflow v9. For details, see Configure 
Netflow Event Sources in NetWitness Suite.

ODBC Collects events from event sources that store audit data in a database using the 
Open Database Connectivity (ODBC) software interface. For details, see 
Configure ODBC Event Sources in NetWitness Suite.
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Collection 
Protocol

Description

Plugins The Plugins collection is a generic collection framework for collecting events 
using external scripts written in other languages. RSA currently provides 
collection for  Amazon Web Services (AWS) CloudTrail and Microsoft Azure.

 l AWS: Collects events from Amazon Web Services (AWS) CloudTrail. 
Specifically CloudTrail records AWS API calls for an account. For details, 
see Configure AWS (CloudTrail) Event Sources in NetWitness Suite

 l Azure: Collects events from Microsoft Azure. For details, see Configure 

Azure Event Sources in NetWitness Suite.

Customers can use this framework to develop their own collection protocols.

SDEE Collects Intrusion Detection System (IDS) and Intrusion Prevention Service 
(IPS) messages.
For details, see Configure SDEE Event Sources in NetWitness Suite.

SNMP Trap Accepts SNMP traps. For details, see Configure SNMP Event Sources in 
NetWitness Suite.

Syslog Accepts messages from event sources that issue syslog messages. For details, 
see Configure Syslog Event Sources for Remote Collector.

Note: You do not configure Syslog Collection for Local Log Collectors. You 
only need to configure Syslog Collection for Remote Collectors.

VMware Collects events from a VMware virtual infrastructure. For details, see 
Configure VMware Event Sources in NetWitness Suite.

Windows Collects events from Windows machines that support the Microsoft Windows 
model. Windows 6.0 is an event logging and tracing framework included in the 
operating system beginning with Microsoft Windows Vista and Windows 
Server 2008. For details, see Configure Windows Event Sources in NetWitness 
Suite.
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Collection 
Protocol

Description

Windows 

Legacy

Collects events from:

 l Older Windows versions such as Windows 2000 and Window 2003 and 
collects from Windows event sources that are already configured for 
enVision collection without having to reconfigure them.

 l NetApp ONTAP appliance event source so that you can now collect and 
parse NetApp evt files.

 l For more information, see.Windows Legacy and NetApp Collection 

Configuration.

Note: You install the NetWitness Suite  Windows Legacy Collector on a 
physical or virtual Windows 2008 R2 SP1 64-Bit server using the 
SALegacyWindowsCollector-version-number.exe.

Basic Procedure
The basic procedure is the same for all of the supported Collection Protocols.

 1. Set up your Event Source for collection. Each supported event source has a configuration 
document available in the RSA Supported Event Sources space on RSA Link

 a. Navigate to the  RSA Supported Event Sources space on RSA Link.

 b. Find the Instructions for your Event Source.

The Overview page lists all of the currently supported Event Sources, as well as 
information about the collection method, device class, and supported versions.

 c. Download the configuration instructions for your event source, and follow them.

 2. Configure collection on RSA NetWitness Suite. The event source configuration guide 
contains these instructions. However, this guide also provides these instructions, based on 
the collection method used by your event source. See Collection Protocols for details.

 3. Start the Service for your Collection Method. Normally, you only need to do this for the 
first event source that uses this collection method. For example, the first time you configure 
an event source that uses File Collection, you may need to start the File Service in 
NetWitness Suite.

 4. Verify that Collection is working for your Event Source.

Log Collection Basics 42

https://community.rsa.com/community/products/netwitness/parser-network/event-sources


Log Collection Configuration Guide

The remainder of this topic discusses steps 2, 3, and 4 in more detail.

Configure Collection in RSA NetWitness Suite

The process to configure event sources is dependent upon the collection method they use. Note, 
however, that they are very similar. The following procedure is generic: more details for 
individual collection methods are available in topics that cover the details for each specific 
collection method.

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Log Collector Event Sources tab, select your collection method from the drop-down 
menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog box is displayed.

 7. Select an event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.
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 9. Enter values for the available parameters.

Refer to the Parameters section of the specific collection method that you are configuring.

 10. Click OK.

Start the Service for your Collection Method

To start the service for your collection method, do the following:

 1. Go to Admin > Services.

 2. Select a Log Collector and select  > View > System.

 3. Click Collection > protocol> Start

where protocol  is the protocol that you wish to start, for example Netflow.

Verify that Collection is working for your Event Source

You can verify that a collection method is working from the Admin > Health & Wellness > 
Event Source Monitoring tab.

To verify that collection is working for an event source:

 1. Go to ADMIN > Health & Wellness

 2. Click the Event Source Monitoring tab.

 3. In the grid, find the Log Decoder, Event Source, and Event Source Type.

 4. Look for activity in the Count column for an event source to verify that collection is 
accepting events.

Configure Event Filters for a Collector
This topics tells you how to create and maintain Event filters across all collection protocols.

Note: You cannot configure Syslog Collection for Local Log Collectors. You only need to 
configure Syslog Collection for Remote Collectors. See Configure Local and Remote Collectors   
for additional configuration information.

Configure an Event Filter

To configure an event source:

 1. Go to ADMIN > Services.

 2. Select a Log Collection service.
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 3. Under Actions, select View > Config to display the Log Collection configuration parameter 
tabs.

 4. Click the Event Sources tab.

 5. In the  Event Sources tab, select any collection method / Filter from the drop-down menus.

The following screen shows Syslog selected.

Note: Syslog configuration is only available on Remote Collectors: if you are working with 
a Local Collector service, Syslog is not available from the drop-down menu.

The Filters view displays the  filters that are configured for the selected collection method, if 
any.

 6. In the Filters panel toolbar, click .

The Add Filter dialog displays.

 7. Enter a name and description for the new filter and click Add.

The new filter displays in the Filter panel.

45 Log Collection Basics



Log Collection Configuration Guide

 8. Select the new filter in the Filters panel and click  in the Filter Rules panel toolbar.

The Add Filter Rule dialog is displayed.

 9. Click  under Rule Conditions.

 10. Add the parameters for this rule and click Update > OK.

NetWitness Suite updates the filter with the rule that you defined.

Note: Rules are processed in order from top down until an Action type aborts the processing, 
or the final  rule is checked.  Default behavior is to accept the rule if no matches are found.

The following tables describe the parameters for adding a filter rule.

Event Filter Rule "Key" Parameter

The values for the Key field depend on the Collection method to which the filter applies.
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Collection Method Values for the Key Field

Checkpoint, File, Netflow, Plugin,
 SDEE SNMP and VMware

 l All Data Fields

 l Event Source Type

 l Event Source Name

 l Source IP

 l Raw Event

ODBC  l All Data Fields

 l Event Source Type

 l Event Source Name

 l Source IP

 l Message ID

 l Message Level 

Syslog  l All Data Fields

 l Event Source Type

 l Event Source Name

 l Source IP

 l Syslog level

 l Raw Event
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Collection Method Values for the Key Field

Windows  l All Data Fields

 l Event Source Type

 l Event Source Name

 l Source IP

 l Event ID

 l Provider  

 l Channel  

 l Computer  

 l UserName

 l DomainName   

Windows Legacy  l All Data Fields

 l Event Source Type

 l Event Source Name

 l Source IP

 l Event ID

Other Event Filter Rule Parameters

The following table describes all the other available fields for creating an event filter rule.

Field Description

Operator Valid values are:

 l Contains

 l Equal

Use 

Regex

Optional. You can select this if you want to use regex.

Value Value depends on the key value you selected.

For example if you choose Syslog level for Key, the value will be a number that 
denotes the syslog level.
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Field Description

Ignore 

case

Optional. Select this to ignore the case sensitivity.

Action If there is a match you can choose an action to accept, drop, next condition or next 
rule:

 l Accept: events that match the IDs provided will be included in event logs, and 
will display in the Systems Analytics UI. 

 l Drop: events that match the IDs provided will not be included in event logs and 
will not display in the UI.  

 l Next condition: the filter will ignore events with IDs that match, and will move 
on to the next rule condition. 

 l Next rule: the filter will ignore events with IDs that match, and will move on to 
the next rule.

If there is no match, you can choose an action to accept, drop, next condition or 
next rule.

Modify Filter Rules

To modify an event source:

 1. Go to ADMIN > Services.

 2. Select a Log Collection service.

 3. Under Actions, select View > Config to display the Log Collection configuration parameter 
tabs.

 4. Click the Event Sources tab.

 5. In the  Event Sources tab, select any collection method / Filter from the drop-down menus.

The following screen shows Check Point selected.
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The Filters view displays the  filters that are configured for the selected collection method, if 
any.

 6. In the Filter Rules list, select a rule and click .

The Edit Filter Rule dialog is displayed.

 7. Select the rule condition that you want to modify.
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 8. Modify the condition parameters that require changes and click Update >  OK.

NetWitness Suite applies the condition parameter changes to the selected filter rule.

Import, Export, Edit and Test Event Sources in Bulk
This topic describes how to import, export, edit and test event sources in bulk.

You can use the bulk export option to export the event source details of your current set up and 
store it. This data can be imported in bulk when you face a problem with your current set up and 
require the event source data you had.

You can use the bulk edit feature when you have multiple event sources that need a specific 
modification. You can select all the sources and apply the edit option across them at a time and 
avoid applying the change one by one.

Import Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some 
data fields like numbers and dates can be re-formatted into the spreadsheet program’s native 
field types.  This can cause issues when re-importing this information, as some data fields may 
be garbled or formatted incorrectly.  This can be avoided by importing the CSV file into the 
spreadsheet program, and specifying all data fields as text values.

To import multiple event sources at once:

 1. Go to  Admin > Services.

 2. Select a Log Collection service.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 

parameter tabs.
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 4. Click the Event Sources tab.

 5. Select Check Point, File, Netflow, ODBC, Plugins, SDEE, (Syslog for Remote 
Collectors) only, VMware, Windows, or  Windows Legacy (SNMP does not have an 
Import function.).

 6. In the Sources panel toolbar, click Import Source.

The Bulk Add Option dialog is displayed.

 7. Select either Import CSV File or Paste CSV Content. If you select:

 l Import CSV File:

 a. Click Next.

The Import dialog is displayed.

 b. Click Add and select a .csv file from your network.

 c. Click Import.

The event sources are added to the Event Source list.

 l Paste CSV Content
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 a. Copy the contents of the .csv file and paste them into the dialog.

 b. Click Import.

The event sources are added to Event Source List.

Export Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some 
data fields like numbers and dates can be re-formatted into the spreadsheet program’s native 
field types.  This can cause issues when re-importing this information, as some data fields may 
be garbled or formatted incorrectly.  This can be avoided by importing the CSV file into the 
spreadsheet program, and specifying all data fields as text values.

 1. Go to Admin > Services.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. Select Check Point, File, Netflow, ODBC, Plugins, SDEE, (Syslog for Remote Collectors) 
only, VMware, Windows, or  Windows Legacy (SNMP does not have an Export function.).

 6. In the Sources panel, select one or multiple event sources and click Export Source.

The Bulk Export dialog is displayed.
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 7. Based on your selection:

 l All, NetWitness Suite   exports all event sources to a time-stamped CSV file.

 l Selected, NetWitness Suite   exports the event source or sources you selected to a time-
stamped CSV file.

 l Cancel, NetWitness Suite   cancels the export.

The following is an example of a time-stamped CSV file that gets created  with the event sources 
that you selected from the list.

Edit Event Sources in Bulk

To edit multiple event sources at once:

 1. On the Log Collector  Event Sources tab, select Check Point, File, Netflow, 
ODBC, Plugins, SDEE, Syslog, VMware, Windows, or Windows Legacy (SNMP does 
not have an Edit function.).

 2. In the Sources panel, select multiple event sources and click   (edit icon).

The appropriate Bulk Edit dialog for the selected event source is displayed. The following 
figure is an example of Bulk Edit Source dialog for File event source parameters.
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 3. Select the checkbox to the left of the fields that you want to modify (for example, Debug).

 4. Modify the selected parameters (for example, change Debug from Off to On).

 5. Click OK.

NetWitness Suiteapplies the same parameter value change to all of the selected event 
sources

Test Event Source Connections in Bulk

To test multiple event source connections at once:

 1. Go to Admin >   Services.

 2. In the Services grid, select a Log Collector service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Select the Event Sources tab, select Plugins, ODBC, or Windows (the other protocols do 
not have a bulk test connection function).

 5. Select one or more:

 l sources from the Sources panel for Plugins or ODBC

 l hosts from Hosts panel for Windows

The Test Connection button is enabled.
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 6. Click  .

The Bulk Test Connections dialog is displayed showing the current status of the test for 
each source. The status can be waiting, testing, passed or failed.

If you choose to close the testing before it is completed, the testing stops and the Bulk Test 
Connections dialog closes.

After the testing is complete, the results are displayed  in the Bulk Test Connections dialog.

See Also

You can use the  Event Sources module (Administration > Event Sources) to create groups of 
event sources, typically imported from a CMDB, and to monitor event sources based on those 
groups. For details, see the following topics in the Event Source Management Guide:

 l Import  Event Sources

 l Export Event Sources

 l Bulk Edit Event Source Attributes
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Configure Collection Protocols and Event 
Sources
This topic tells you how to configure collection protocols and the event sources using those 
protocols.

You configure the Log Collector  to collect event data from your event sources in the Event 
Sources tab of the Log Collection parameter view. 

To configure a collection protocol:

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. Select a collection protocol (for example, File) and select Config.

 6. Click  and select an event source.

 7. Select the newly added category and click .

 8. Specify the parameters for the event source. For details, see the individual collection 
protocol topics.
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The following guides provide detailed instructions on how to configure the collection protocols 
and their associated event sources in NetWitness Suite.  Each guide includes an index to 
configuration instructions for the event sources supported for that collection protocol.

To configure individual collection protocols, see the following topics:

 l Configure AWS (CloudTrail) Event Sources in NetWitness Suite

 l Configure Azure Event Sources in NetWitness Suite

 l Configure Check Point Event Sources in NetWitness Suite

 l Configure File Event Sources in NetWitness Suite

 l Configure Netflow Event Sources in NetWitness Suite

 l Configure ODBC Event Sources in NetWitness Suite

 l Configure Data Source Names (DSNs)

 l Create Custom Typespec for ODBC Collection

 l ODBC Event Source Configuration Parameters

 l ODBC DSNs Event Source Configuration Parameters

 l Configure SDEE Event Sources in NetWitness Suite

 l Configure SNMP Event Sources in NetWitness Suite

 l Configure Syslog Event Sources for Remote Collector

 l Configure VMware Event Sources in NetWitness Suite

 l Configure Windows Event Sources in NetWitness Suite

 l Windows Legacy and NetApp Collection Configuration

 l Set Up the Windows Legacy Collector

 l Configure Windows Legacy and NetApp Event Sources

 l Troubleshoot Windows Legacy and NetApp Collection
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This topic tells you how to configure the AWS collection protocol, which collects events from 
Amazon Web Services (AWS) CloudTrail.

Note: The AWS plugin is meant only for collecting from AWS CloudTrail logs, and not for 
collecting from arbitrary logs in S3 buckets (under arbitrary directories). The AWS CloudTrail 
logs are sent in JSON format, as detailed in the AWS documentation here: 
http://docs.aws.amazon.com/awscloudtrail/latest/userguide/cloudtrail-event-reference.html.

How AWS Collection Works

The Log Collector    service collects events from Amazon Web Services (AWS) 
CloudTrail. CloudTrail records AWS API calls for an account. The events contain the identity of 
the API caller, the time of the API call, the source IP address of the API caller, the request 
parameters, and the response elements returned by the AWS service. The AWS API call history 
provided by CloudTrail events enables security analysis, resource change tracking, and 
compliance auditing. CloudTrail uses Amazon S3 for log file storage and delivery. NetWitness 
Suite   copies the log files from the cloud (S3 bucket), and sends the events contained in the files 
to the Log Collector.

Deployment Scenario

The following figure illustrates how you deploy the AWS Collection Protocol in NetWitness 
Suite.
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Configuration

To configure an AWS (CloudTrail) Event Source:

 1. Go to ADMIN > Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.
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 4. Click the Event Sources tab.

 5. In the Event Sources tab, select Plugins/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  cloudtrail) and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Define parameter values. For details, see AWS Parameters below.

 10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the 
device or service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time 
limit, the test times out and the NetWitness Suite   displays an error message.

 11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

AWS Parameters

The following table describes the available configuration parameter for AWS collection.
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Parameter Description

Parameter Description

Basic

Name * Name of the event source.

Enabled Select the check box to enable the event source configuration to start 

collection. The check box is selected by default.

Account Id * Account Identification code of the S3 Bucket

S3 Bucket 

Name *

Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS 
(CloudTrail) region in which you create the bucket. You specify the name at 
the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for 
DNS-compliant bucket names are:

 l Bucket names must be at least three and no more than 63 characters long.

 l Bucket names must be a series of one or more labels. Adjacent labels are 
separated by a single period “.”. Bucket names can contain lowercase 
letters, numbers, and hyphens. Each label must start and end with a 
lowercase letter or a number.

 l Bucket names must not be formatted as an IP address (for example, 
192.168.5.4).

The following examples are valid bucket names:

 l myawsbucket

 l my.aws.bucket

 l myawsbucket.1

The following examples are invalid bucket names:

 l .myawsbucket  -   Do not start a Bucket Name with a period ".".

 l myawsbucket. - Do not end a Bucket Name with a period ".".

 l my..examplebucket - Only use one period between labels.
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Parameter Description

Access Key 

*

Key used to access the S3 bucket. Access Keys are used to make seure REST 
or Query protocol requests to any AWS service API.  Please refer to Manage 
User Credentials on the Amazon Web Services support site for more 
information on Access Keys.

Secret Key * Secret key used to access the S3 bucket.

Region * Region of the S3 bucket. us-east-1 is the default value.

Region 

Endpoint

Specifies the AWS CloudTrail hostname.

For example, for an AWS public cloud for us-east region, the Region Endpoint 
would be s3.amazonaws.com. More information can be found at 
http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region. This 
parameter is necessary to collect CloudTrail logs from AWS Government or 
Private clouds.

Use Proxy Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Proxy Server Enter the proxy name you want to connect to access the AWS server.

Proxy Port Enter the port number that connects to the proxy server to access the AWS

server.

Proxy User Enter the user name to authenticate with the proxy server.

Proxy 
Password

Enter the password to authenticate with proxy port.

Start Date * Starts AWS (CloudTrail) collection from the specified number of days in the 

past, measured from the current timestamp. The default value is 0, which starts

 from today. The range is 0–89 days. 

Log File 

Prefix

Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure 
to enter the same prefix in this parameter.

Advanced
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Parameter Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this 
problem. Enabling debugging will adversely affect the performance of the 
Log Collector.

Enables or disables debug logging for the event source.

Valid values are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).

Command 

Args

Arguments added to the script.

Polling 

Interval

Interval (amount of time in seconds) between each poll. The default value is 
60.

For example, if you specify 60, the collector schedules a polling of the event 
source every 60 seconds. If the previous polling cycle is still underway, it will 
wait for it to finish that cycle. If you have a large number of event sources that 
you are polling, it may take longer than 60 seconds for the polling to start 
because the threads are busy.

SSL Enabled Select the check box to communicate using SSL. The security of data 
transmission is managed by encrypting information and providing authentication 
with SSL certificates.

The check box is selected by default.
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Parameter Description

Test 

Connection

Validates the configuration parameters specified in this dialog are correct.  For 
example, this test validates that:

 l NetWitness can connect with the S3 Bucket in AWS using the credentials 
specified in this dialog.

 l NetWitness can download a log file from the bucket (test connection would 
fail if there were no log files for the entire bucket, but this would be 
extremely unlikely).

Cancel Closes the dialog without adding the AWS (CloudTrail).

OK Adds the current parameter values as a new AWS (CloudTrail).

Configure Azure Event Sources in NetWitness Suite
This topic tells you how to configure the Azure collection protocol. Microsoft Azure is a cloud 
computing platform and infrastructure for building, deploying, and managing applications and 
services through a global network of Microsoft-managed data centers.

Configuration in NetWitness Suite

For complete details about configuring Azure as an event source, see the Azure Event Source 
Configuration Guide, available on RSA Link.

To configure an Azure Event Source:

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.
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 4. Click the Event Sources tab.

 5. In the Event Sources tab, select Plugins/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  azureaudit) and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Define parameter values. For details, see Azure Parameters below.

 10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the 
device or service information and retry.

Log Collectortakes approximately 60 seconds to return the test results. If it exceeds the time 
limit, the test times out and the NetWitness Suite   displays an error message.

 11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Azure Parameters

This section describes the Azure  event source configuration parameters.

Note: Items that are followed by an asterisk (*) are required.
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Basic Parameters

Name Description

Name * Enter an alpha-numeric, descriptive name for the source. This value is only 
used for displaying the name on this screen.

Enabled Select the checkbox to enable the event source configuration to start 
collection. The checkbox is selected by default.

Client ID * The Client ID is found the Azure Application Configure tab. Scroll down until 
you see it.

Client Secret 
*

When you are configuring the event source, the client secret is displayed 
when you are creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it 
cannot be retrieved later.

API Resource 
Base URL *

Enter https://management.azure.com/. Be sure to include the 
trailing slash (/).

Federation 
Metadata 
Endpoint *

In your Azure application, click the View Endpoints button (near the bottom 
of the pane).

There are a lot of links that all begin with the same string. Compare the URLs 
and find the common string that begins most of them. This common string is 
the endpoint that you need to enter here.

Subscription 
ID *

You can find this in the Microsoft Azure dashboard: click on Subscriptions at 
the bottom of the list on the left.

Tenant 
Domain *

Go to the active directory and click on the directory. In the URL, the tenant 
domain is the string directly following manage.windowsazure.com/. The 
tenant domain is the string up to and including the .com.

Resource 
Group Names 
*

In Azure, select Resource groups from the left navigation pane, then select 
your group.

Start Date * Choose the date from which to start collecting. Default's to the current date.

Test 
Connection

Checks the configuration parameters specified in this dialog to make sure they 
are correct.

Advanced Parameters

Click  next to Advanced to view and edit the advanced parameters, if necessary.
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Name Description

Polling 
Interval

Interval (amount of time in seconds) between each poll. The default value is 180.
For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, the 
collector waits for that cycle to finish. If you have a large number of event 
sources that you are polling, it may take longer than 180 seconds for the polling to 
start because the threads are busy.

Max 
Duration 
Poll

Maximum duration, in seconds, of a polling cycle. A zero value indicates no 
limit.

Max 
Events 
Poll

The maximum number of events per polling cycle (how many events collected 
per polling cycle).

Max Idle 
Time Poll

Maximum duration, in seconds, of a polling cycle. A zero value indicates no 
limit.

Command 
Args

Optional arguments to be added to the script invocation.

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log Collector.

Caution: Enables or disables debug logging for the event source. Valid values 
are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. If you change this value, the change takes effect immediately (no restart 
required). The debug logging is verbose, so limit the number of event sources to 
minimize performance impact.

Configure Check Point Event Sources in NetWitness Suite
This topic tells you how to configure the Check Point collection protocol, which collects events 
from Check Point event sources.
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This protocol collects events from Check Point event sources using OPSEC LEA. OPSEC LEA 
is the Check Point Operations Security Log Export API that facilitates the extraction of logs.

How Check Point Collection Works

The Log Collector   service collects events from Check Point event sources using OPSEC LEA. 
OPSEC LEA is the Check Point Operations Security Log Export API that facilitates the 
extraction of logs.

Note: OPSEC LEA (Log Export API) supports extraction of logs from Check Point event 
sources configured with a SHA-256 or SHA-1 certificate.

Deployment Scenario

The following figure illustrates how you deploy the Check Point Collection Protocol in 
NetWitness Suite.
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Configuration in NetWitness Suite

To configure a Check Point Event Source:

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Event Sources tab, select Check Point/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  a check point event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Define parameter values. For details, see  Check Point Parameters below.

 10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the 
device or service information and retry.
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Log Collectortakes approximately 60 seconds to return the test results. If it exceeds the time 
limit, the test times out and the NetWitness Suite   displays an error message.

 11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Check Point Parameters

This section describes the Check Point event source configuration parameters.

Basic Parameters

Parameter Description

Name* Name of the event source.

Address* IP Address of the Check Point server.

Server 

Name*

Name of the Check Point server.

Certificate 

Name

Certificate name for secure connections to use when the transport mode is 
https. If set, the certificate must exist in the certificate trust store that you 
created using the Settings tab.

Select a certificate from the drop-down list. The file naming convention for 
Check Point event source certificates is checkpoint_name-of-event-source.

Client 

Distinguished

Enter the Client Distinguished Name from the Check Point server.

Client Entity 

Name

Enter the Client Entity Name from the Check Point server.

Server 

Distinguished

Enter the Server Distinguished Name from the Check Point server.

Enabled Select the check box to enable the event source configuration to start 
collection. The check box is selected by default.

Pull 

Certificate

Select the checkbox  to pull a certificate for first time.  Pulling a certificate 
makes it available from the trust store.
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Parameter Description

Certificate 

Server 

Address

IP Address of the server on which the certificate resides. Defaults to the event 
source address.

Password Only active when you select the Pull Certificate checkbox for first time. 
Password required to pull the certificate. The password is the activation key 
created when adding an OPSEC application to Check Point on the Check Point 
server.

Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to 
stay open for a specific time and specific event volume (transient connection). RSA NetWitness 
Suite  defaults to the following  connection parameters that establish a transient connection:

 l Polling Interval = 180 (3 minutes)

 l Max Duration Poll = 120 (2 minutes)

 l Max Events Poll = 5000 (5000 events per polling interval)

 l Max Idle Time Poll = 0

For very active Check Point event sources, it is a good practice to set up a connection that stays 
open until you stop collection (persistent connection). This ensures that Check Point collection 
maintains the pace of the events generated by these active event sources. The persistent 
connection avoids restart and connection delays and prevents Check Point collection from 
lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters 
to the following values:

 l Polling Interval = -1

 l Max Duration Poll = 0

 l Max Events Poll = 0

 l Max Idle Time Poll = 0

Parameter Description

Port Port on the Check Point server that Log Collector connects to. Default value is 

18184.
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Parameter Description

Collect Log 

Type

Type of logs that you want to collect:  Valid values are: 

 l Audit - collects audit events.

 l Security - collects security events.

If you want to collect both audit and security events, you must create a 
duplicate event source. For example, first you would create an event source 
with Audit selected pulling a certificate into the trust store for this event 
source. Next you would create another event source with the same values 
except that you would select Security for the Collect Log Type and you would 
select the same certificate in Certificate Name that you pulled when you set up 
the first set of parameters for this event source and you would make sure that 
Pull Certificate was not selected.

Collect Logs 

From

When you set up a Check Point event source, NetWitness collects events from 
the current log file. Valid values are: 

 l Now - Start collecting logs now (at this point in time in the current log file). 

 l Start of Log - Collect logs from the beginning of the current log file.

If you choose "Start of Log" for this parameter value, you may collect a very 
large amount of data depending on how long the current log file has been 
collecting events. Note that this option is effective only for the first collection 
session.

Polling 

Interval

Interval (amount of time in seconds) between each poll. The default value is 
180.

For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, it will 
wait for it to finish that cycle. If you have a large number of event sources that 
you are polling, it may take longer than 180 seconds for the polling to start 
because the threads are busy.

Max 

Duration 

Poll

The maximum duration of polling cycle (how long the cycle lasts) in seconds.

Max Events 

Poll

The maximum number of events per polling cycle (how many events collected 

per polling cycle).
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Parameter Description

Max Idle 

Time Poll

Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is 

the default value.

Forwarder Enables or disables the Check Point server as a forwarder. By default it is 

disabled.

Log Type 
(Name 
Value Pair)

Logs from the event source in Name Value format. By default it is disabled.

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if 
you have a problem with an event source and you need to investigate this 
problem. Enabling debugging will adversely affect the performance of the 
Log Collector.

Enables and disables debug logging for the event source.

Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).

Verify Check Point Collection is Working

The following procedure illustrates how you can verify that Check Point collection is working 
from the Administration > Health & Wellness > Event Source Monitoring tab.

 1. Access the Event Source Monitoring tab from the Administration > Health & Wellness 
view.

 2. Find checkpointfw1 in the Event   Source Type column.

 3. Look for activity in the Count column to verify that Check Point collection is accepting 
events.
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The following procedure illustrates how you can verify that Check Point collection is working 
from the Investigation > Events view.

 1. Access the Investigation > Events view.

 2. Select the Log Decoder (for example, LD1) collecting Check Point events in the Investigate 
a Device dialog.

 3. Look for a Check Point event source parser (for example, checkpointfw1) in the 
device.type field in the Details column to verify that Check Point collection is accepting 
events.

Note: If the logs from the VSX Checkpoint firewall server are collected by the Log Collector 
checkpoint service, to translate the VSX IP in the logs to ip.orig meta, you must add the VSX 
hostname and the VSX IP address to the /etc/hosts file in the Log Collector.

Configure File Event Sources in NetWitness Suite
This topic tells you how to configure the File collection protocol.

Configure a File Event Source

To configure a File Event Source:

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.
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 4. Click the Event Sources tab.

 5. In the Event Sources tab, select File/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  a file event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Add a File Directory name and modify any other parameters that require changes. For 
details, see File Collection Parameters below.

 10. To get the public key and enter it into the dialog box, do the following:

 a. Select and copy the public key from the Event Source by running: cat ~/.ssh/id_rsa.pub  

 b. Paste the public key in the Eventsource SSH Key field.

 11. Click OK.

You need to restart file collection for your changes to take effect.

Stop and Restart File Collection

After you add a new event source that uses file collection, you must stop and restart the 
NetWitness Suite   File Collection service. This is necessary to add the key to the new event 
source.
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File Collection Parameters

The following table provides descriptions of the File Collection source parameters.

Name Description

Basic

File 

Directory*

Collection directory (for example, Eur_London100) into which the File event 
source places its files. Valid value is a character string that is conforms to the 
following regular expression:

[_a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, 
letters, and underscores. Do not modify this parameter after you start collecting 
event data.

After you create the collection, the Log Collector creates the work, save, and 
error sub-directories under the collection directory.

Address* IP address of the event source. Valid value is an IPv4 address, IPv6 address, 

or a hostname including a fully-qualified domain name.

File Spec Regular expression. For example, ^.*$ = process everything.

File 

Encoding

Internationalization file encoding. Enter the File Encoding method, the following 
strings are examples of valid methods:

 l UTF-8 (default)

 l UCS-16LE

 l UCS-16BE

 l UCS-32LE

 l UCS-32BE

 l SHIFT-JIS

 l EBCDIC-US

Enabled Select the check box to enable the event source configuration to start collection. 

The check box is selected by default.

Advanced
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Name Description

Ignore 

Encoding

 Conversion 

Errors

Select the check box to ignore encoding conversion errors and ignore invalid 
data. The check box is selected by default.

Caution: This may cause parsing and transformation errors.

File Disk 

Quota

Determines when to stop saving files regardless of the Save On Error and  
Save On Success parameter settings. For example, a value of 10 indicates that 
when there is less than 10% available disk left, the Log Collector stops saving 
files to reserve enough space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection 
directory is mounted. If the Log Decoder server has a 10TB disk size and 
2TB is allocated to base collection directory, then setting this value to 10 
causes log collection to stop when less than 0.2TB (10% of 2TB) of space is 
left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential 

Processing

Sequential processing flag: 

 l Select the check box (default) to process event source files in collection 
order.

 l Do not select the checkbox to process event source files in parallel.

Save On 

Error

Save on error flag. Check the checkbox to retain the eventsource collection file 

when the Log Collector it encounters an error. The check box is selected by 

default.

Save On 

Success

Save eventsource collection file after processing flag. Check the checkbox to 

save the eventsource collection file after processing it. The check box is not 

selected by default.
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Name Description

Eventsource 

SSH Key

SSH public key used to upload files for this event source. Please refer to the 
Generate Key Pair on Event Source and Import Public Key to Log Collector 
section in the Install and Update the SFTP Agent Guide for instructions on 
generating keys.

Note: If File collection is stopped, NetWitness Suite does not update the 
authorized_keys file with the SSH public key that you add or modify in this 
parameter. You must restart File collection to update the public key.
You can add or modify the value of the public key in this parameter in 
multiple File event sources without File collection running, but NetWitness 
Suite will not update the authorized_keys file until File collection is 
restarted.

Manage 

Error Files

By default, the Log Collectoruses the File Disk Quota parameter to ensure that 
the disk does not fill up with error files. If you set this parameter to true, you 
can specify one of these: 

 l Maximum space allotted to error files in the Error Files Size parameter.

 l Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to 
reduce when the maximum is reached.

Select the check box to manage error files. The check box is not selected by 
default.

Error Files 

Size

Only valid if the Manage Error Files and Save On Error parameters are set 
to true.
Specifies to what extent NetWitness Suite saves error files. The value that you 
specify is the maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. You specify these 
values in either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the 
default. If you change this parameter, the change does not take effect until you 
restart collection or restart the Log Collector service.

Error Files 

Count

Only valid if the Manage Error Files and Save On Error parameters are set 
to true. Maximum number of error files allowed in the error directory. Valid 
value is a number in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.
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Name Description

Error Files 

Reduction 

%

Percent amount by size or count of the error files that the Log Collectorservice 
removes when the maximum size or count has been reached. The service 
removes the oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Manage 

Saved Files

Select the check box to manage saved files. The check box is not selected by 
default.
By default, the Log Collector uses the File Disk Quota parameter to ensure that 
the disk does not fill up with saved files. If check this check box, you can 
specify one of these: 

 l Maximum space allotted to saved files in the Saved Files Size parameter.

 l Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to 
reduce when the maximum is reached.

Saved Files 

Size

Only valid if the Manage Saved Files and Save On Success parameters are set 
to true.
Maximum total size of all the files in the save directory. Valid value is a 
number in the 0 to 281474976710655 range. You specify these values in either 
Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.

Saved Files 

Count

Only valid if the Manage Saved Files and Save On Success parameters are set 
to true. Maximum number of saved files in the save directory. Valid value is a 
number in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.

Saved File 

Reduction 

%

Percent amount by size or count of the saved files that the Log Collector service 
removes when the maximum size or count has been reached. The service 
removes the oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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Name Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log 
Collector.

Enables/disables debug logging for the event source.
Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).

Cancel Closes the dialog without making adding an event source type.

OK Adds the parameters for the event source.

 

Configure Netflow Event Sources in NetWitness Suite
This topic tells you how to configure the Netflow collection protocol.

Configure a Netflow Event Source

To configure a Netflow Event Source:

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.
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 4. Click the Event Sources tab.

 5. In the Event Sources tab, select Netflow/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  the netflow event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Enter a port number in the Port field, and ensure the Enabled box is checked.

Note: NetWitness Suite   opens the 2055, 4739, 6343, and 9995 ports on the firewall by 
default.  You can open other ports for Netflow if required.
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For details of other parameters, see Netflow Collection Parameters below.

 10. Click OK.

The new event source is displayed in the list.

Netflow Collection Parameters

The following table provides descriptions of the Netflow Collection source parameters.

Name Description

Basic

Port Specify the port number configured for the Netflow event source.

NetWitness Suite   opens the 2055, 4739, 6343, and 9995 ports for Netflow by 

default. You can open other ports for Netflow if required.

Enabled Select the check box to enable the event source configuration to start collection. 

The check box is selected by default.

Advanced

InFlight 

Publish 

Log 

Threshold

Establishes a threshold that, when reached, NetWitness Suite   generates a log 
message to help you resolve event flow issues. The Threshold is the size of the 
netflow event messages currently flowing from the event source to NetWitness 
Suite  .

Valid values are: 

 l 0 (default) - disables the log message.

 l 100-100000000 -  generates a log message when this Log Collector   has 
processed the specified number of netflow events.  For example, if you 
set this value to 100, NetWitness Suite   generates a log message when 
100 netflow events of the specific netflow version (v5 or v9) have been 
processed.
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Name Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log Collector  .

Enables or disables debug logging for the event source.

Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. The debug logging is verbose, so limit the number of event sources to 
minimize performance impact.
If you change this value, the change takes effect immediately (no restart required).

Cancel Closes the dialog without making adding an event source type.

OK Adds the parameters for the event source.

ODBC

Configure ODBC Event Sources in NetWitness Suite

This topic tells you how to configure ODBC collection protocol which collects events from 
event sources that store audit data in a database using the Open Database Connectivity (ODBC) 
software interface.

Deployment Scenario

The following figure illustrates how you deploy the ODBC Collection Protocol in NetWitness 
Suite.
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Configure an ODBC Event Source

To configure an ODBC event source, you need to configure an event source type, and also 
choose a DSN template.

Configure a DSN

The following procedure describes how to add a DSN from an existing DSN template. For other 
procedures related to DSNs, see Configure Data Source Names (DSNs).

Configure a DSN (Data Source Name):

 1. Go to  Administration > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click   under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
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 5. The DSNs panel is displayed with the existing DSNs, if any.

 6. Click  + to open the Add DSN dialog.

 7. Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use 
the name when you set up the ODBC event source type.) If required, click 

 to add or delete DSN templates.

 8. Fill in the parameters and click Save.

Add an Event Source Type

For details on parameters used in the following procedure, see ODBC Event Source Configuration 
Parameters.

To configure an ODBC Event Source Type:

 1. Go to ADMIN> Services.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Event Sources tab, select ODBC/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

86



Log Collection Configuration Guide

 7. Select an event source category (for example mssql and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select the new type in the Event Categories panel and click  in the Sources toolbar.

The Add Source dialog is displayed.

 9. Select a DSN from the drop down list, specify or modify the other parameters as required, 
and click OK.

 10. Click Test Connection.
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The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the 
DSN information and retry.

Note: Log Collectortakes approximately 60 seconds to return the test results. If it exceeds 
the time limit, the test times out and the NetWitness Suite   server displays an error 
message.

 11. If the test is successful, click OK.

The newly defined DSN is displayed in the Sources panel.

Configure Data Source Names (DSNs)

This topic tells you how to create and maintain DSNs for ODBC Collection.

Context

Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you 
need to define DSNs with their associate value pairs for ODBC event source configuration.

Navigate to the DSN Panel

To add or edit DSNs or DSN templates, first navigate to the appropriate screen.

To navigate to the DSN templates panel:

 1. Go to ADMIN >   Services.

 2. In the Services grid, select a Log Collector service.

 3. Click   under Actions and select View > Config.

 4. In the Log Collector   Event Sources tab, select ODBC/DSNs  from the drop-down menu.

The DSNs panel is displayed with the DSNs that are added, if any.

From this screen, you can perform the following actions:

 l Add a new DSN template

 l Add a DSN from an existing template
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 l Add a DSN by editing an existing DSN template

 l Remove a DSN or DSN template

Add a New DSN Template

If none of the predefined DSN templates fit your needs, use this procedure to add a 
DSN template.

 1. From the DSNs panel, click  .

The Manage DSN Templates dialog is displayed.

Note: RSA provides default templates on the left side panel that you can use while adding 
a new DSN.

 2. Click .

The right panel is activated.

 3. Specify a template name and click  on the right panel to add parameters.
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 4. Specify the parameters. Click Save.

The new DSN template is added in the Manage DSN Templates list.

Add a DSN from an existing template

You can select an existing template, and fill in the parameters for your needs.

 1. From the DSNs panel, click   to open the Add DSN dialog box.

The Add DSN dialog is displayed with existing DSNs, if any

 2. Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use 
the name when you set up the ODBC event source type.)

 3. Fill in the parameters and click Save.

Your DSN is added to the list of DSNs.

Add a New DSN by editing an existing DSN template

You can add a DSN by updating an existing DSN template to fit your needs.

 1. From the DSNs panel, click  .

The Manage DSN Templates dialog is displayed.
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 2. Select the existing template that you want to modify.

The right panel is activated, and the default parameters for the selected template are 
displayed.
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 3. Specify a name in the DSN Name field.

 4. Add, delete or edit the default parameters.

 5. Once you have the set of required parameters, click Save, then Close.

 6. Choose the DSN Template that you updated from the drop down menu and enter a name for 
the DSN. (You use the name when you set up the ODBC event source type.)

 7. Fill in the parameters and click Save.

Your DSN is added to the list of DSNs.

Remove a DSN or DSN template

If you no longer use a DSN or a DSN template, you can remove it from the system.

To remove an existing DSN:

 1. From the DSNs panel, select an existing DSN.

 2. Click .

A Warning message appears, asking whether you are sure you want to delete the DSN.

 3. To delete the DSN, click Yes. Alternatively, to cancel the deletion, click No.

If you confirmed the deletion, the selected DSN is removed from the system.

92



Log Collection Configuration Guide

To remove an existing DSN Template:

 1. From the DSNs panel, click  .

The Manage DSN Templates dialog is displayed.

 2. From the DSNs panel, select an existing DSN Template.

 3. Click .

A Confirmation message appears, asking whether you are sure you want to delete the DSN 
Template.

 4. To delete the DSN Template, click Yes. Alternatively, to cancel the deletion, click No.

If you confirmed the deletion, the selected DSN Template is removed from the system.

Configure device.ip meta for ODBC Data Source

For any ODBC event source, you can choose to have the ODBC collector populate the device.ip 
meta value with either the event source IP address or the actual source IP on which logs are 
being collected. 
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To view or set this parameter:

 1. Go to ADMIN >   Services.

 2. In the Services grid, select a Log Collector service.

 3. Click   under Actions and select View > Explore.

 4. Navigate to logcollection > odbc > eventsources.

There are entries for each ODBC event source that you have configured in NetWitness. For 
example, for this installation, the only ODBC event source currently configured is MS SQL:

 5. Click + next to an event source to expand it and see its DSN entry.

 6. Click the DSN entry (in this example Test_DSN) to show the parameters.
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 7. The use_eventsource_address parameter is listed.

 l False: actual source IP address is used. This is the default value.

 l True: event source IP address is used.

 8. Click on the value (in this case False), and type in the new value.

Note: If you type anything other than true or false (case does not matter), you receive an 
error saying that the value you entered cannot be set.

Any changes you make take effect immediately.

Create Custom Typespec for ODBC Collection

This topic tells you how to create a custom typespec for the Log Collector. The topic includes:

 l Create Custom typespec procedure

 l ODBC Collection typespec syntax

 l Sample ODBC Collection typespec files
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Create Custom Typespec

To create a custom typespec file:

 1. Open an SFTP client (for example, WinSCP) and  connect to a Log Collector   or remote Log 
Collector.

 2. Navigate to /etc/netwitness/ng/logcollection/content/collection/odbc, and copy an existing 
file, for example bit9.xml.

 3. Modify the file according to your requirements. See ODBC Collection Typespec Syntax for 
details.

 4. Rename and save the file to the same directory.

 5. Restart the Log Collector.

Note: You will not be able to see new Event Source type in NetWitness Suite   until you restart 
the Log Collector.

ODBC Collection Typespec Syntax

The following table describes the typespec parameters.

Parameter Description

name The display name of your ODBC event source (for example, 
activeidentity). NetWitness Suite   displays this name in the Sources 
panel of the View > Config > Events Sources tab.

Valid value is an alphanumeric string. You cannot use - (dashes),  _
(underscores), or spaces. The name must be unique across all typespec 
files in the folder.

type Event source type: odbc. Do not modify this line.

prettyName User-defined name for the event source. You can use the same value as  
name (for example, apache) or use a more descriptive name.

version Version of this typespec file. Default value is 1.0.

author Person who created the typespec file. Replace author-name with your 
name.

description Formal description of the event source. Replace formal-description with 
your description of the event source.

<device> Section
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Parameter Description

parser This optional parameter contains the name of the log parser. This value 
forces the Log Decoder to use the specified log parser when parsing logs 
from this event source.

Note: Please leave the field blank when unsure of the log parser to be 
used.

name Name your ODBC event source (for example, ActivIdentity ActivCard 

AAA Server).

maxVersion The version number of the event source (for example, 6.4.1).

description Description of the event source.

<collection> Section

odbc The syntax under <odbc> is used for event collection and processing.  
You can provide multiple queries for the same event source type by 
adding <query> tags.

query This section contains the details of the query used to collect information 
from the event source.

tag The prefix tag you want to add to events during transformation (for 

example ActivIdentity).

outputDelimiter Specify the delimiter to use to separate fields. Specify any of the 
following values:

 l || (piping)

 l ^ (caret)

 l , (comma)

 l : (colon)

 l 0x20 (to represent a space)

interval Specify the number of seconds between events. Default value is 60.
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Parameter Description

dataQuery Specify the query to fetch data from the ODBC eventsource database for 
SQL-syntax. For example:

SELECT acceptedrejected, servername, serveripa, sdate, millisecond, suid, 
groupname, ipa, reason, info1, info2, threadid FROM A_AHLOG WHERE 
sdate > '%TRACKING%' ORDER BY sdate

maxTrackingQuery The query used on the initial pull of events to identify the starting point 
within the data set to begin pulling logs from. After the initial pull, this 
query is no longer used, unless the maxTracking value has been reset or 
altered.  For example:

SELECT MAX(Event_Id) from ExEvents

trackingColumn The tracking column value used when the ODBC collector pulls a new 
set of events.

Sample ODBC Collection Typespec Files

The following sample is the typespec file for the IBM ISS SiteProtector event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

   <name>siteprotector4_x</name>

   <type>odbc</type>

   <prettyName>SITEPROTECTOR4_X</prettyName>

   <version>1.0</version>

   <author>Administrator</author>

   <description>Collects events from SiteProtector</description>

   <device>

      <name>Internet Security Systems, Inc. RealSecure SiteProtector v 2.0</name>

      <maxVersion>2.0</maxVersion>

      <description></description>

      <parser>iss</parser>

   </device>

   <configuration>

   </configuration>

   <collection>

      <odbc>

         <query>
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            <tag></tag>

            <outputDelimiter></outputDelimiter>

            <interval></interval>

            <dataQuery></dataQuery>

            <maxTrackingQuery></maxTrackingQuery>

            <trackingColumn></trackingColumn>

            <levelColumn></levelColumn>

            <eventIdColumn></eventIdColumn>

            <addressColumn></addressColumn>

         </query>

      </odbc>

   </collection>

</typespec>

The following sample is the typespec file for the Bit9 Security Platform event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

   <name>bit9</name>

   <type>odbc</type>

   <prettyName>BIT9</prettyName>

   <version>1.0</version>

   <author>Administrator</author>

   <description>Bit9 Events</description>

 

   <device>

      <name>Bit9</name>

      <parser>bit9</parser>

   </device>

   <configuration>

   </configuration>

    

   <collection>

      <odbc>

         <query>

            <tag>BIT9</tag>

            <outputDelimiter>||</outputDelimiter>

            <interval>10</interval>

            <dataQuery>

            SELECT
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            Timestamp,

            Event_Id,

            Computer_Id,

            File_Catalog_Id,

            Root_File_Catalog_Id,

            Priority,

            Type,

            Subtype,

            IP_Address,

            User_Name,

            Process,

            Description

            FROM

            ExEvents

            WHERE

            Event_Id > '%TRACKING%'

            </dataQuery>

            <trackingColumn>Event_Id</trackingColumn>

            <maxTrackingQuery>SELECT MAX(Event_Id) from 

ExEvents</maxTrackingQuery>

            <eventIdColumn></eventIdColumn>

         </query>

      </odbc>

   </collection>

</typespec>

Troubleshoot ODBC Collection

You can troubleshoot problems and monitor ODBC collection by reviewing the ODBC collector 
log informational, warning, and error messages to during execution of collection.

Each ODBC log messages includes the:

 l Timestamp

 l Category: debug, info, warning, or failure

 l collection method = OdbcCollection

 l ODBC event source type (GOTS-name) = Generic ODBC Type Specification name that you 
configured for the event source.

 l collection function completed or attempted (for example, [processing])
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 l ODBC event source name (DSN-name) = Data Source Name that you configured for the 
event source.

 l description (for example, how many events  the Log Collector   collected)

 l tracking ID  = the Log Collector   position in the target database table.

The following example illustrates the message you would receive upon successful collection of 
an ODBC event:

2014-July-25 17:21:25 info (OdbcCollection) : [event-source] [processing] [event-source] Published 
100 ODBC events: last tracking id: 2014-July-25 13:22:00.280

The following example illustrates a message you may receive upon unsuccessful collection of an 
ODBC event:

Log 
Message

timestamp failure (OdbcCollection: [event-source] [processing][event-source-type] 
Failed during doWork: Unable to prepare statement: state: S0002; error-code:208; 
description: [RSA] [ODBC-driver][event-source-type]Invalid object name 'object-
name'.

Possible 
Cause

ODBC collection failed while accessing the ODBC Driver or the target 

database.

Solutions Validate the DSN value pairs for the events source.

Configure SDEE Event Sources in NetWitness Suite
This topic tells you how to configure the SDEE collection protocol.

To add an SDEE Event Source:

 1. Go to ADMIN> Services.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

101



Log Collection Configuration Guide

 4. Click the Event Sources tab.

 5. In the Event Sources tab, select SDEE/Config from the drop-down menu.

The Event Categories panel displays the SDEE event sources that are configured, if any.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  an  event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
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 8. Select the new type in the Event Categories panel and  click       in the Sources panel toolbar.

The Add Source dialog is displayed.

 9. Add a Name, Username, Address, and Password, and modify any other parameters that 
require changes, and click OK.
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Configure SNMP Event Sources in NetWitness Suite
This topic tells you how to configure the SNMP collection protocol.

Configure the SNMP Trap Event Source

To add the SNMP Event Source:

Note: If you have previously added the snmptrap type, you cannot add it again. You can edit 
it, or manage users.

 1. Go to ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Event Sources tab, select SNMP/Config from the drop-down menu.

 6. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 7. Select  the snmptrap event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

 8. Select snmptrap in the Event Categories panel.
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 9. Select snmptrap in the Sources panel and then click the Edit icon, , to edit the 
parameters.

 10. Update any of the parameters that you need to change and click OK.

(Optional) Configure SNMP Users

If you are using SNMPv3, follow this procedure to update and maintain the SNMP v3 users.

Configure SNMP v3 Users

 1. Go to  Admin > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click  under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select SNMP/SNMP v3 User Manager from the 
drop-down menu.

The SNMP v3 User panel is displayed with the existing users, if any.

 5. Click    to open the Add SNMP User dialog.

 6. Fill in the dialog with the necessary parameters. The available parameters are described 
below.

SNMP User Parameters

The following table describes the parameters that you need to enter when you create an 
SNMP v3 user.

Parameter Description

Username * User name (or more accurately in SNMP terminology, security name).  
NetWitness Suite uses this parameter and the Engine ID parameter to create 
a user entry in the SNMP engine of the collection service.

The Username and Engine ID combination must be unique (for example, 
logcollector).

Engine ID (Optional) Engine ID of the event source. For all event sources sending 
SNMP v3 traps to this collection service, you must add the username and 
engine id of the sending event source.

For all event sources sending SNMPv3 informs, you must add just the 
username with a blank engine id.
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Parameter Description

Authentication
Type

(Optional) Authentication protocol. Valid values are as follows:

 l None (default) - only security level of noAuthNoPriv can be used for 
traps sent to this service

 l SHA - Secure Hash Algorithm

 l MD5 - Message Digest Algorithm DO NOT USE: do not select MD5, 
as it conflicts with the Log Collector running in FIPS mode.

Authentication
Passphrase

Optional if you do not have the Authentication Type set.  Authentication 
passphrase.

Privacy Type (Optional) Privacy protocol. You can only set this parameter if 
Authentication Type parameter is set.  Valid values are as follows:

 l None (default)

 l AES - Advanced Encryption Standard

 l DES - Data Encryption Standard DO NOT USE: do not select DES, as 
it conflicts with the Log Collector running in FIPS mode.

Privacy
Passphrase

Optional if you do not have the Privacy Type set.  Privacy passphrase.

Close Closes the dialog without adding the SNMP v3 user  or saving modifications 
to the parameters.

Save Adds the SNMP v3 user parameters or saves modifications to the 
parameters.

Configure Syslog Event Sources for Remote Collector
This topic tells you how to configure Syslog event sources for the Log Collector.

You do not configure Syslog Collection for Local Log Collectors. You only need to configure 
Syslog Collection for Remote Collectors.

Configure a Syslog Event Source

Syslog listeners for UDP on port 514, TCP on port 514 and SSL on port 6514 are created by 
default. You should not change the SSL settings on the TCP and SSL listeners. If you need SSL 
certificate verification, create a new event source type to listen on a different port. Please note 
that iptables needs to be configured to open that port.
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To configure the Remote Log Collector for Syslog collection:

 1. Go to  ADMIN > Services.

 2. In the Services grid, select a Remote Log Collector, and from the Actions menu, choose  
  > View > Config.

 3. Select the Event Sources tab.

 4. Select Syslog/Config from the drop-down menu.

The Event Categories panel displays the Syslog event sources that are configured, if any.

Note: For  RSA NetWitness Suite, some Syslog event sources are available by default. In 
this case, you can proceed to step 6.

 5. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

 6. Select either syslog-tcp or syslog-udp. You can set up either or both, depending on the needs 
of your organization.

 7. Select the new type in the Event Categories panel and  click       in the Sources panel toolbar.

The Add Source dialog is displayed.

 8. Enter the port number, and select Enabled. Optionally, configure any of the Advanced 
parameters as necessary.

Click OK to accept your changes and close the dialog box.

Once you configure one or both syslog types, the Log Decoder or Remote Log Collector collects 
those types of messages from all available event sources. So, you can continue to add Syslog 
event sources to your system without needing to do any further configuration in RSA NetWitness 
Suite.

Syslog Parameters

The following tables describe the available basic and advanced parameters for Syslog 
configuration.

Basic Parameters

Name Description

Port* Default port is 514.
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Name Description

Enabled Select the check box to enable the event source configuration to start 

collection. The check box is selected by default.

SSL Receiver Note: This parameter applies to RSA NetWitness® Suite version 11.1 and 
newer. It is available only for the syslog-tcp Event Category.

If you select the check box, the event source accepts SSL/TLS connections 
only. Also, if you change this setting,  you must stop and restart Syslog 
collection for the change to become effective.

Advanced Parameters

Name Description

Inflight 

Publish 

Log 

Threshold

Establishes a threshold that, when reached, NetWitness generates a log message 
to help you resolve event flow issues. The Threshold is the size of the syslog 
event messages currently flowing from the event source to NetWitness.

Valid values are:

 l 0 (default) - disables the log message

 l 100-100000000 - generates log message when  the syslog event messages 
currently flowing from the event source to NetWitness are within the 100 to 
100000000 byte range.

Maximum 

Receivers

Maximum number of receiver resources used to process collected syslog events.  

The  default value is 2.

Event 

Filter

Select a filter.

Please refer to  Configure Event Filters for a Collector for instructions on how to 
define filters.
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Name Description

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if 
you have a problem with an event source and you need to investigate this 
problem. Enabling debugging will adversely affect the performance of the Log 
Collector.

Enables or disables debug logging for the event source.

Valid values are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. The debug logging is verbose, so limit the number of event sources to 
minimize performance impact.
If you change this value, the change takes effect immediately (no restart 
required).

SSL 

Verify 

Mode

Note: This parameter applies to RSA NetWitness® Suite version 11.1 and 
newer. It is available only for the syslog-tcp Event Category.

This setting is relevant only if the SSL Receiver setting is selected. If you change 
the SSL Verify Mode, you must stop and restart Syslog collection for the change 
to become effective.

Available options:

 l verify-none: (default) The server does not verify the client's certificate, if any. 
A client can connect without presenting a certificate.

 l verify-peer: The server verifies the client's certificate, if any. A client can 
connect without presenting a certificate.

Note: If verification fails, a warning is logged but the messages will still be 
accepted.

 l verify-peer-fail-if-no-cert: The client must present a certificate and the server 
will verify it.

Note: If you use this mode, the client's CA certificate must be uploaded to 
the Log Collector's truststore using the REST API at http://LC-ip-
address:50101/sys/caupload
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Configure VMware Event Sources in NetWitness Suite
This topic tells you how to configure the VMware collection protocol.

To add a VMware Event Source:

 1. Go to ADMIN> Services.

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Log Collector Event Sources tab, select VMware/Config from the drop-down menu.

The Event Categories panel displays the VMware event sources that are configured, if any.

 6. Click   to open the Available Event Source Types dialog.
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 7. Select vmware-events or vmware-tasks from the Available Event Source Types dialog and 
click OK.

The VMware available event source types are as follows:

 l vmware-events: Setup vmware-events to collect events from vCenter Servers and 
ESX/ESXi servers.

 l vmware-tasks: (Optional) Setup vmware-tasks to collect tasks from vCenter Servers.

 8. Select the new type in the Event Categories panel, and click + in the Sources toolbar.

 9. Add a Name, Username and Password, and  modify any other parameters that require 
changes.

Caution: If you need to enter the domain name as part of the Username, you must use a 
double-backslash as a separator. For example, if the domain|username is corp\smithj, you 
must specify corp\\smithj.

 10. Click OK to save your changes.

Configure Windows Event Sources in NetWitness Suite
This topic tells you how to configure the Windows collection protocol.

In RSA NetWitness Suite, you need to configure the Kerberos Realm, and then add the 
Windows Event Source type.

To configure the Kerberos Realm for Windows collection:

 1. Go to  ADMIN > Services.

 2. Select a Log Collection service.

 3. Under Actions, select > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.
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 5. Select Windows/Kerberos Realm from the drop-down menu.

 6. In the Kerberos Realm Configuration panel toolbar, click   to add a new realm.

The Add Kerberos Domain dialog is displayed.

 7. Fill in the parameters, using the guidelines below.

Parameter Details

Kerberos 
Realm 
Name

Enter the realm name, in all caps. For example, DSNETWORKING.COM. 
Note that the Mappings parameter is automatically filled with variations on 
the realm name.

KDC Host 
Name

Enter the name of the Domain Controller. Do not use a fully qualified name 
here: just the host name for the DC.

Note: Make sure that the log collector is configured as a DNS client for the 
corporate DNS server. Otherwise, the Log Collector will not know how to find 
the Kerberos Realm.

Admin 
Server

(Optional) The name of the Kerberos Administration Server in FQDN 
format.

 8. Click Save to add the Kerberos domain.

To add a Windows Event Source:

 1. Go to  ADMIN > Services.

 2. Select a Log Collection service.
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 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Log Collector Event Sources tab, select Windows/Config from the drop-down menu.

The Event Categories panel displays the VMware event sources that are configured, if any.

Next, continue from the current screen to add a Windows Event Category and type.

To configure the Windows Event Type:

 1. Select Windows/Config from the drop-down menu.

 2. In the Event Categories panel toolbar, click   to add a source.

The Add Source dialog is displayed.

 3. Fill in the parameters, using the guidelines below.

Parameter Details

Alias Enter a descriptive name.

Authorization 
Method

Choose Negotiate.

Channel For most event sources that use Windows collection, you want to collect 
from the Security, System, and Application channels.

User Name Enter the account name for the Windows user account that you set up 
earlier for communicating with NetWitness. Note that you need to enter 
the full account name, which includes the domain. For example, 
rsalog@DSNETWORKING.COM.

Password Enter the correct password for the user account.

Max Events 
Per Cycle

(Optional). RSA recommends that you set this value to 0, which collects 
everything.

Polling 
Interval

(Optional). For most users, a value of 60 should work well.

 4. Click OK to add the source.

The newly added Windows event source is displayed in the Event Categories panel.

 5. Select the new event source in the Event Categories panel.

The Hosts panel is activated.
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 6. Click  in the Hosts panel toolbar.

 7. Fill in the parameters, using the guidelines below.

Parameter Details

Event Source Address Enter the IP address for the Windows host.

Port Accept the default value, 5985.

Transport Mode Enter http.

Enabled Ensure the box is checked.

 8. Click Test Connection.

Note: You should be able to successfully test the connection, even if the Windows service 
is not running.

For more information on any of the previous steps, see the following Help topics in the 
NetWitness Suite User Guide:

 l Configure Windows Collection: https://community.rsa.com/docs/DOC-43410

 l Microsoft WinRM Configuration Guide: https://community.rsa.com/docs/DOC-58163

 l Test and Troubleshoot Microsoft WinRM Guide: https://community.rsa.com/docs/DOC-58164

Windows Legacy and NetApp Collection Configuration
This Windows Legacy protocol collects events from Windows Legacy (Windows 2003 or 
earlier event sources) and CIFS Auditing events from NetApp ONTAP event sources.

You must deploy Log Collection, that is set up a Local Collector and Windows Legacy Remote 
Collector, before you can configure the Windows Legacy collection protocol.

How Legacy Windows and NetApp Collection Works

You use the Windows Legacy collection protocol to configure NetWitness Suiteto collection 
events from:

 l Legacy Microsoft Windows event sources (Window 2003 and earlier event sources)

 l NetApp event sources

114

https://community.rsa.com/docs/DOC-43410
https://community.rsa.com/docs/DOC-58163
https://community.rsa.com/docs/DOC-58164


Log Collection Configuration Guide

Window 2003 and Earlier Event Sources

Legacy Windows event sources are older Windows versions (such as Windows 2000 and 
Window 2003).  The Windows Legacy collection protocol collects from Windows event sources 
that are already configured for enVision collection without having to reconfigure them. You set 
up these event sources under the windows event source type. 

NetApp Event Sources

NetApp appliances running Data ONTAP support a native auditing framework that is similar to 
Windows Servers. When configured, this auditing framework generates and saves audit events 
in Windows.evt file format. The Windows Legacy collection protocol supports collection of 
events from such NetApp.evt files.  You set up these event sources under the netapp_evt event 
source type. 

The NetApp Data ONTAP appliance is configured to generate CIFS Auditing events and save 
them periodically as.evt files in a format that includes the timestamp in the filename. Refer to 
the Network Appliance Data ONTAP Event Source Configuration Guide on RSA Link for 
details. The collection protocol saves the timestamp of the last processed.evt filename to keep 
track of collection status.

Net App Specific Parameters

Most of the parameters that you maintain in Add/Edit Source dialog apply to both Windows 
Legacy and Net App events sources.

The following two parameters are unique to NetApp event sources.

 l Event Directory Path - The NetApp appliance generates event data and saves it in.evt files 
in a shareable directory on the NetApp appliance. NetWitness Suite requires you to specify 
this directory path in the Event Directory Path parameter

 l Event File Prefix - Similar to the Event Directory Path, NetWitness Suite requires you to 
specify the prefix (for example, adtlog.) of the event data.evt files so that NetWitness Suite 
can process this data.

In each polling cycle, NetWitness Suite browses the configured NetApp shared path for the .evt 
files that you identified with the Event Directory Path and Event File Prefix parameters. 
NetWitness Suite:

 l Sorts Files matching the event-file-prefix.YYMMDDhhmmss.evt format in ascending order.

 l Uses the timestamp of the last file processed to determine the files that still need processing. 
If NetWitness Suite finds a partially processed file, it skips the events already processed.
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Deployment Scenario

The Windows Legacy collection protocol collects event data from Windows 2003 or earlier, and 
NetApp ONTAP appliance, event sources. The Windows Legacy Remote Collector is the SA 
Legacy Windows Collector installed on physical or virtual Windows 2008 64-bit server in your 
event source domain.

Set Up the Windows Legacy Collector

This topic tells you where to find the executable and instructions required to install or upgrade 
the Windows Legacy collector in your Windows Legacy domain or domains.

You install the NetWitness Suite Windows Legacy collector on a physical or virtual Windows 
2008 R2 SP1 64-Bit server using the NWLegacyWindowsCollector-11.version-number.exe. 
You download the NWLegacyWindowsCollector-11.version-number.exe from RSA Link. 
Please refer to the NetWitness 11.x Windows Legacy Collection Upgrade & Installation 
Instructions  for the details on how to install or upgrade Windows Legacy collection.

Note: The Microsoft Management Console (MMC) should be closed during the installation 
process.
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Configure Windows Legacy and NetApp Event Sources

This topic tells you how to configure Windows Legacy event sources in NetWitness Suite.

The Windows Legacy collection protocol collects event data from Windows 2003 or earlier 
event sources, and from NetApp event sources.

Prerequisites

Before you configure a Windows Legacy event source, make sure that you have:

 1. Installed the NetWitness Suite Windows Legacy Remote Collector on a physical or virtual 
Windows 2008 64-bit server.

 2. Added this Windows Legacy Remote Collector to NetWitness Suite.

Add a Windows Legacy Event Source

 1. Access the Services view by selecting Admin > Services  from the NetWitness Suite menu.

 2. In the Services grid, select a Windows Legacy Log Decoder service.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Sources tab.

 5. In the Event Sources tab, select one of the following options from the drop-down menu.

 l Windows   Legacy/Windows.

 l Windows   Legacy/NetApp.

 6. Configure the alias:

 a. Click  in the Event Categories panel toolbar.

The Add Source dialog is displayed.

 b. Specify values for the parameters and click OK.

117



Log Collection Configuration Guide

Note: By default, Remote Registry Initialization is selected. For details, see Remote 
Registry Access below.

The newly added windows event source type is displayed in the Event Categories panel.

 7. Add the event source:

 a. Select the new alias in the Event Categories panel and click  in the Source panel 
toolbar.

The Add Source dialog is displayed.

 b. Specify values for the event source parameters and click OK.

118



Log Collection Configuration Guide

For details, see Windows Legacy Configuration Parameters below.

The newly added Windows event source is displayed in the Event Categories panel.

Remote Registry Access

Windows Legacy Collector performs an initial verification of the event source before collecting 
data. By default, Windows Legacy Collector uses Windows Management Instrumentation 
(WMI) method to perform this initial verification. If you enable Remote registry access method, 
Windows Legacy Collector performs a remote registry query to verify the event source.

Configure Push or Pull between Log Collector and Windows Legacy Collector

You can configure the Windows Legacy Collector to push event data to a Local Collector, or 
you can configure a Local Collector       to pull event data from the Windows Legacy Collector.
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To configure a Local Collector or the Windows Legacy Collector:

 1. Go to ADMIN > Services.  

 2. Select a Local Collector or the Windows Legacy Collection service.

 3. Under Actions, select   > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Depending on your selection in step 2:

 l If you selected a Local Collector, the Remote Collectors tab is displayed. Select the 
Windows Legacy Collector from which the Local Collector       pulls events in this tab.

 l If you selected a Windows Legacy Collector, the Local Collectors are displayed. Select 
the Local Collectors to which the Windows Legacy Collector pushes events in this tab.

Windows Legacy Configuration Parameters

The following table describes the parameters for a Windows Legacy event source.

Feature Description

Basic

Name* The name of the event source. Valid value is a name in the [_a-zA-Z] [_a-zA-Z0-

9]* range. You can use a dash "-" as part of the name.

Event 

Source 

Address*

IP address of the event source. Valid value is an IPv4 address, IPv6 address, or a 

hostname including a fully qualified domain name. NetWitness Suite   defaults to 

127.0.0.1.

Log Collector   converts the hostname to lower-case letters to prevent duplicate 

entries.

120



Log Collection Configuration Guide

Feature Description

Event 

Log 

Name

The name of the event log from which to collect event data (for example, System, 
Application, or Security).
The following are examples of some of these channels:

 l System ‐ applications that run under system service accounts (installed system 
services), drivers, or a component or application that has events that relate to 
the health of the system.

 l Application ‐ all user‐level applications. This channel is unsecured and it is 
open to any application. If an application has extensive information, you should 
define an application‐specific channel for it.

 l Security ‐ the Windows Audit Log (event log) used exclusively for the 
Windows Local Security Authority.

Enabled Select this checkbox to collect from this event source. If you do not check this 

checkbox, the Log Collector   does not collect events from this event source.

Event 

Directory 

Path

NetApp .evt or.evtx files directory path. This must be the UNC path.

The NetApp generates event data and saves it in.evt or.evtx files in a shareable 
directory on the NetApp appliance.

 l In each polling cycle, Log Collector   browses the configured NetApp shared 
path for the.evt files that you identified with the Event Directory Path and 
Event File Prefix parameters. Log Collector  :

 o sorts files that match the event-file-prefix.YYMMDDhhmmss.evt format 
in ascending order.

 o uses the timestamp of the last file processed to determine the files that still 
need processing. If Log Collector  finds a partially processed file, it skips the 
events already processed.

 l In each polling cycle, Log Collector   browses the configured NetApp shared 
path for the .evtx files that you identified with the Event Directory Path and 
Event File Prefix parameters. Log Collector  :

 o sorts files that match the event-file-prefix.YYMMDDhhmmssms.evtx 
format in ascending order.

 o uses the timestamp of the last file processed to determine the files that still 
need processing. If Log Collector   finds a partially processed file, it skips the 
events already processed.
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Feature Description

Event 

File 

Prefix

Prefix of the .evt files (for example, adtlog.) saved in the Event Directory Path.

Advanced

Event 

Buffer 

Size

Maximum size of the data the Log Collector   pulls from the event source for each  
request.

Valid value is a number in 0 to 511 Kilobytes range. You specify this value in 
Kilobytes.

Event 

Too 

Large 

Result

Tells Log Collector   what to do if an event is too large for the event buffer.

Maximum 

Event 

Data

Maximum size of event data to include in the output. Valid value is a number in 0 
to 511Kilobytes range. You specify this value in Kilobytes or Megabytes.

 l 1 Kilobyte - 100 Megabytes

 l 0 = do not include event data in the output.

Max 

Events 

Per Cycle

The maximum number of events per polling cycle (how many events collected per 

polling cycle).

Polling 

Interval

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, it will 
wait for it to finish that cycle. If you have a large number of event sources that 
you are polling, it may take longer than 180 seconds for the polling to start 
because the threads are busy.
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Feature Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose  = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. If you change this value, the change takes effect immediately (no restart 
required). Limit the number of event sources for which you use Verbose 
debugging to minimize performance impact.

Cancel Closes the dialog without adding the Windows Legacy event source.

OK Adds the current parameter values as a new event source

Troubleshoot Windows Legacy and NetApp Collection

This topic highlights possible problems that you may encounter with Windows Legacy Collection 
(LWC) and suggested solutions to these problems.

Note: In general, you receive more robust log messages by disabling SSL.
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Protocol Restart Problems

Problem
Possible 
Causes

Solutions

You restart the 
Legacy Windows collection protocol, 
but NetWitness Suite is not receiving 
events.

The 
logcollector 
service is 
stopped.

Restart the logcollector service.

 1. Log on to the Windows 
Legacy Remote Collector.

 2. Go to Start >   Administrative 
Tools   > Task Scheduler and 
click on Task Scheduler 
Library.

 3. In the right panel, look for 
the restartnwlogcollector task 
and make sure that it is running.

 4. If this is not the case, right-click 
restartnwlogcollector
and select Run.

Installation Problems

If you see any of the following messages in the MessageBroker.log, you may have issues. 

Log 
Messages

Any message that contains "rabbitmq"

Possible 
Cause

RabbitMQ service may not be running.

Port 5671 may not be opened.

Solutions
Make sure that the RabbitMQ service is running.

Make sure that port 5671 is open.

Log 
Messages

Error: Adding logcollector user account.

Error: Adding administrator tag to logcollector account.

Error: Adding Adding logcollection vhost.

Error: Setting permissions to logcollector account in all vhosts.
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Possible 
Cause

rabbitmq-server was not running when installer tried to create users and 

vhosts.

Solutions

Make sure that the RabbitMQ service is running and run below 
commands manually.

rabbitmqctl -q add_user logcollector netwitness
rabbitmqctl -q set_user_tags logcollector administrator
rabbitmqctl -q add_vhost logcollection
rabbitmqctl -q set_permissions -p / logcollector ".*" ".*" ".*"
rabbitmqctl -q set_permissions -p logcollection logcollector ".*" ".*" ".*"

Windows Legacy Federation Script Issues

If you see any of the following messages in the federation script log, you may have issues. 

Problem Possible Symptoms Solutions

Federation 
script started, b
ut the LWC 
service went 
down.

NetWitness 

Suite log shows connection 

failure exceptions 

with Windows 

Legacy Collector.

This issue is fixed automatically after 
restarting the Windows Legacy service.
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Problem Possible Symptoms Solutions

LWC is 

running, but 

RabbitMQ 

service is down 

or restarting. 

Federation log file at 
Windows Legacy side 
displays an error message 
about RabbitMQ service being 
down.

The log file to look at is:
C:\NetWitness\ng\logcollecto
r

The following error 
message is logged in case 
RabbitMQ is not running:

"Unable to connect 
to node 
logcollector@localho
st: nodedown"

The following diagnostics 
messages are displayed:
 attempted to contact: 

[logcollector@localhos

t] 

logcollector@localhos
t:
   * connected to epmd 
(port 4369) on 

localhost
   * epmd reports: node 
'logcollector' not 
running at all other 
nodes on localhost: 
['rabbitmqctl-4084']
   * suggestion: start 
the node

Run the federation.bat script manually at 
LWC.
To run the federate.bat 
script manually, perform the following 
steps:

 1. Go to folder C:\Program 
Files\NwLogCollector where the 
Windows Legacy instance is installed.

 2. Locate the file federate.bat in this 
folder. Select the file and right click.

 3. Select Run as Administrator.

 4. To monitor the log file, navigate to 
C:\NetWitness\ng\logcollector\federa
te.log while the federate.bat script is 
being executed.

Note: Make sure the log file does not 
show any errors while the script is being 
executed.

RabbitMQ servi
ce is down on 
the NetWitness 
Suite side.

NetWitness Suite User 

Interface pages do not work.

Restart RabbitMQ service.
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Problem Possible Symptoms Solutions

Customer 
receives 
a Health and 
Wellness 
notification, or 
the 
following Healt
h and Wellness 
Alarm is 
displayed:
 
"Communicatio
n failure 
between Master 
NetWitness 
Suite Host and 
a Remote Host" 
with LWC Host 
as the Remote 
IP.

Federate.bat script failed to 
run successfully.

If the Federate.bat script did not run 
correctly, run it manually as described 
previously.

Windows Log Collection for Endpoint Agents

In 11.1, Windows Log collection can be achieved using the RSA® NetWitness®  Endpoint 
Insights Agent. When the agent is enabled for log collection, a log configuration file is included 
with the Agent Packager to enable collection and forwarding of windows logs in addition to the 
Endpoint data. The generated configuration file contains information of the channels from which 
logs are to be collected from and the destination (Log Decoder or a Remote Log Collector) to 
forward the defined windows events. The generated Agent packager is able to collect both 
Endpoint and Windows log data from hosts. The Endpoint Agent packager is extracted locally on 
a Windows machine to create the agent installer file. The installer file is then deployed through 
a third party software distribution tool to all endpoints in your network.

There are three scenarios for Windows log collection, these are:

 l Generate Agent with Log Collection: If the Enable Windows Log Collection option is 
enabled and you click Generate Agent after filling the details. The generated 
AgentPackager.zip contains the log collection file. For more information, see the "Generating 
an Agent Packager with Windows Log Collection" in the Endpoint Insights Agent Installation 
Guide .
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 l Generate Agent file only Without Log Collection: If the Enable Windows Log Collection 
is disabled and you click Generate Agent then only the Zip file gets created without the log 
collection file. For more information, see the "Generate an Endpoint Agent Packager" in the 
Endpoint Insights Agent Installation Guide .

 l If you click on Generate Log Configuration Only then only the log configuration gets 
created. This can be used to update the log configuration file in an existing Endpoint agent 
deployment for log collection or to add the log configuration to an Endpoint agent deployment. 
For more information, see "Add or Update Windows Log Collection Configuration to an existing 

Endpoint Agent". 

Add or Update Windows Log Collection Configuration to an existing 
Endpoint Agent

You can add a Windows Log Collection Configuration file to an Endpoint Agent and also modify 
an existing log collection configuration file. If a change is required in the log collection 
configuration for endpoint agents, the agents do not require to be installed again. The log 
configuration file (nwelcfg file) can be generated from the Packager User Interface and 
modified. 

Workflow
This workflow shows the procedure to add of update a Windows Log Collection Configuration 
file.
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Following are some example reasons that would require a change in the configuration:

 l The destination to which the windows are to be forwarded needs to be changed for better load 
management in the destination side.

 l The endpoint is moved to a new group defined by a third party endpoint management system 
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which needs a change in the destination or list of event ids to be forwarded.

 l There are requirements to change the list of event ids consumed at the destination side.

A new configuration file can be generated either by entering the new values in the Packager 
screen or by loading an existing configuration file.

Note: The endpoint agent is built to read the nwelcfg file with the latest timestamp under the 
config folder. So, please ensure the third party endpoint management tool  updates the 
timestamp of the file to the current time of endpoint while pushing the configuration file.

Follow these steps to add or update a Windows log collection configuration file to an existing 
Endpoint Agent:

 1. In the Packager UI, perform one of the following:

 a. To add the Windows Log Collection Configuration: Fill the required information 
mentioned in the "Generating an Agent Packager with Windows Log Collection" in the 
Endpoint Insights Agent Installation Guide .

 b. To update the Windows Log Collection Configuration: Click Load Existing 
Configuration and edit the intended fields mentioned in the  "Generating an Agent 
Packager with Windows Log Collection" in the Endpoint Insights Agent Installation 
Guide .

 2. Click Generate Log Configuration Only to generate the nwelcfgfile. 

 3. Copy the downloaded nwelcfg file to the Endpoint Agent from where the logs are to be 
forwarded. The configuration file should be copied to %ProgramData%\NWEAgent folder. 
To deploy the configuration file to multiple agents, use the third party software distribution 
tool. 

The agent is designed to pick the log configuration file holding the latest timestamp. If there is a 
time zone difference, please make sure the configuration file is updated to the agent's timestamp 
after copying. This can be achieved by running the command  on the agent: copy /b 
<filename.nwelcfg>  +,,from the folder  %programdata%\NWEAgent\ where the nwelcfg 
file is there. 

Verify Windows Log Collection

To verify the windows log collection is successfully deployed on an Endpoint Agent, follow 
these steps:

 1. Go to ADMIN > Health & Wellness > Event Source Monitoring.

 2. In the Time Frame field, select Last 5 minutes or Last 10 Minutes depending on when the 
Agents were installed. 
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 3. Click Apply. 

 4. In the list displayed, the   IP address of the Agent should be displayed in the Event Source 
column with Event Source Type as windows. This confirms the Agent was installed 
successfully. 

To verify a windows log collection has been updated successfully, follow these steps:

 1. Go to  INVESTIGATE > Navigate. Wait for 2-3 minutes until this config file is picked by 
the Endpoint agent. 

 2. Select the Concentrator from Investigate. 

 3. Change the timeline to last 5 minutes or as applicable. 

 4. Click Load Values.

 5. Search for message ID meta key. 

 6. There should be an agent.test value. An increase in the number of events signifies that the 
updation is done successfully.

Enable log forwarding and Configure Log Decoder

If you want to enable log forwarding feature and configure the log decoder in endpoint hybrid  as 
a destination in the Packager UI. Then you have to add the ports, TCP/UDP 514 in the iptables 
file on Endpoint Hybrid. 

Follow these steps to add the ports: 

 1. For TCP, you have to add the "514" port to the existing list of ports in the 
/etc/sysconfig/iptables file on Endpoint Hybrid:

INPUT -p tcp -m tcp -m multiport --dports 514, 6514,50002,50102,50202,56002,56202 -m 
comment --comment "nwlogdecoderPorts" -m conntrack --ctstate NEW -j ACCEPT -  
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 2. For UDP, you have to add the below content in the /etc/sysconfig/iptables file in 
Endpoint Hybrid:

-A INPUT -p udp -m udp -m multiport --dports 514 -m comment --comment 
"nwlogcollectorUdpPorts" -m conntrack --ctstate NEW -j ACCEPT

 3. Restart iptables service for the above new configurations to take effect: service 
iptables restart.

 

Related Topics
Troubleshooting - Windows log Collection using Endpoint Agent
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Reference

AWS Parameters
This topic provides an overview of the AWS collection configuration parameters for deploying a 
remote log collection service (VLC) in an Amazon Web Services (AWS) environment.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure AWS (CloudTrail) Event Sources in NetWitness Suite
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The following table describes the available configuration parameter for AWS collection.

Parameter Description

Parameter Description

Basic

Name * Name of the event source.

Enabled Select the check box to enable the event source configuration to start 

collection. The check box is selected by default.

Account Id * Account Identification code of the S3 Bucket
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Parameter Description

S3 Bucket 

Name *

Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS 
(CloudTrail) region in which you create the bucket. You specify the name at 
the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for 
DNS-compliant bucket names are:

 l Bucket names must be at least three and no more than 63 characters long.

 l Bucket names must be a series of one or more labels. Adjacent labels are 
separated by a single period “.”. Bucket names can contain lowercase 
letters, numbers, and hyphens. Each label must start and end with a 
lowercase letter or a number.

 l Bucket names must not be formatted as an IP address (for example, 
192.168.5.4).

The following examples are valid bucket names:

 l myawsbucket

 l my.aws.bucket

 l myawsbucket.1

The following examples are invalid bucket names:

 l .myawsbucket  -   Do not start a Bucket Name with a period ".".

 l myawsbucket. - Do not end a Bucket Name with a period ".".

 l my..examplebucket - Only use one period between labels.

Access Key 

*

Key used to access the S3 bucket. Access Keys are used to make seure REST 
or Query protocol requests to any AWS service API.  Please refer to Manage 
User Credentials on the Amazon Web Services support site for more 
information on Access Keys.

Secret Key * Secret key used to access the S3 bucket.

Region * Region of the S3 bucket. us-east-1 is the default value.
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Parameter Description

Region 

Endpoint

Specifies the AWS CloudTrail hostname.

For example, for an AWS public cloud for us-east region, the Region Endpoint 
would be s3.amazonaws.com. More information can be found at 
http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region. This 
parameter is necessary to collect CloudTrail logs from AWS Government or 
Private clouds.

Use Proxy Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Proxy Server Enter the proxy name you want to connect to access the AWS server.

Proxy Port Enter the port number that connects to the proxy server to access the AWS

server.

Proxy User Enter the user name to authenticate with the proxy server.

Proxy 
Password

Enter the password to authenticate with proxy port.

Start Date * Starts AWS (CloudTrail) collection from the specified number of days in the 

past, measured from the current timestamp. The default value is 0, which starts

 from today. The range is 0–89 days. 

Log File 

Prefix

Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure 
to enter the same prefix in this parameter.

Advanced
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Parameter Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this 
problem. Enabling debugging will adversely affect the performance of the 
Log Collector.

Enables or disables debug logging for the event source.

Valid values are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).

Command 

Args

Arguments added to the script.

Polling 

Interval

Interval (amount of time in seconds) between each poll. The default value is 
60.

For example, if you specify 60, the collector schedules a polling of the event 
source every 60 seconds. If the previous polling cycle is still underway, it will 
wait for it to finish that cycle. If you have a large number of event sources that 
you are polling, it may take longer than 60 seconds for the polling to start 
because the threads are busy.

SSL Enabled Select the check box to communicate using SSL. The security of data 
transmission is managed by encrypting information and providing authentication 
with SSL certificates.

The check box is selected by default.
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Parameter Description

Test 

Connection

Validates the configuration parameters specified in this dialog are correct.  For 
example, this test validates that:

 l NetWitness can connect with the S3 Bucket in AWS using the credentials 
specified in this dialog.

 l NetWitness can download a log file from the bucket (test connection would 
fail if there were no log files for the entire bucket, but this would be 
extremely unlikely).

Cancel Closes the dialog without adding the AWS (CloudTrail).

OK Adds the current parameter values as a new AWS (CloudTrail).
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Azure Parameters
Microsoft Azure is a cloud computing platform and infrastructure for building, deploying, and 
managing applications and services through a global network of Microsoft-managed data 
centers. 

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure Azure Event Sources in NetWitness Suite

Azure Event Source Configuration Parameters
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This topic describes the Azure  event source configuration parameters.

Note: Items that are followed by an asterisk (*) are required.

Basic Parameters

Name Description

Name * Enter an alpha-numeric, descriptive name for the source. This value is only 
used for displaying the name on this screen.

Enabled Select the checkbox to enable the event source configuration to start 
collection. The checkbox is selected by default.

Client ID * The Client ID is found the Azure Application Configure tab. Scroll down until 
you see it.

Client Secret 
*

When you are configuring the event source, the client secret is displayed 
when you are creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it 
cannot be retrieved later.

API Resource 
Base URL *

Enter https://management.azure.com/. Be sure to include the 
trailing slash (/).

Federation 
Metadata 
Endpoint *

In your Azure application, click the View Endpoints button (near the bottom 
of the pane).

There are a lot of links that all begin with the same string. Compare the URLs 
and find the common string that begins most of them. This common string is 
the endpoint that you need to enter here.

Subscription 
ID *

You can find this in the Microsoft Azure dashboard: click on Subscriptions at 
the bottom of the list on the left.

Tenant 
Domain *

Go to the active directory and click on the directory. In the URL, the tenant 
domain is the string directly following manage.windowsazure.com/. The 
tenant domain is the string up to and including the .com.

Resource 
Group Names 
*

In Azure, select Resource groups from the left navigation pane, then select 
your group.

Start Date * Choose the date from which to start collecting. Default's to the current date.

Test 
Connection

Checks the configuration parameters specified in this dialog to make sure they 
are correct.
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Advanced Parameters

Click  next to Advanced to view and edit the advanced parameters, if necessary.

Name Description

Polling 
Interval

Interval (amount of time in seconds) between each poll. The default value is 180.
For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, the 
collector waits for that cycle to finish. If you have a large number of event 
sources that you are polling, it may take longer than 180 seconds for the polling to 
start because the threads are busy.

Max 
Duration 
Poll

Maximum duration, in seconds, of a polling cycle. A zero value indicates no 
limit.

Max 
Events 
Poll

The maximum number of events per polling cycle (how many events collected 
per polling cycle).

Max Idle 
Time Poll

Maximum duration, in seconds, of a polling cycle. A zero value indicates no 
limit.

Command 
Args

Optional arguments to be added to the script invocation.

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log Collector.

Caution: Enables or disables debug logging for the event source. Valid values 
are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. If you change this value, the change takes effect immediately (no restart 
required). The debug logging is verbose, so limit the number of event sources to 
minimize performance impact.
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Check Point Parameters
The Check Point Collection protocol collects events from Check Point event sources using 
OPSEC LEA. OPSEC LEA is the Check Point Operations Security Log Export API that 
facilitates the extraction of logs.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure Check Point Event Sources in NetWitness Suite

Check Point Collection Configuration Parameters
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Basic Parameters

Parameter Description

Name* Name of the event source.

Address* IP Address of the Check Point server.

Server 

Name*

Name of the Check Point server.

Certificate 

Name

Certificate name for secure connections to use when the transport mode is 
https. If set, the certificate must exist in the certificate trust store that you 
created using the Settings tab.

Select a certificate from the drop-down list. The file naming convention for 
Check Point event source certificates is checkpoint_name-of-event-source.

Client 

Distinguished

Enter the Client Distinguished Name from the Check Point server.

Client Entity 

Name

Enter the Client Entity Name from the Check Point server.

Server 

Distinguished

Enter the Server Distinguished Name from the Check Point server.

Enabled Select the check box to enable the event source configuration to start 
collection. The check box is selected by default.

Pull 

Certificate

Select the checkbox  to pull a certificate for first time.  Pulling a certificate 
makes it available from the trust store.

Certificate 

Server 

Address

IP Address of the server on which the certificate resides. Defaults to the event 
source address.

Password Only active when you select the Pull Certificate checkbox for first time. 
Password required to pull the certificate. The password is the activation key 
created when adding an OPSEC application to Check Point on the Check Point 
server.
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Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to 
stay open for a specific time and specific event volume (transient connection). RSA NetWitness 
Suite  defaults to the following  connection parameters that establish a transient connection:

 l Polling Interval = 180 (3 minutes)

 l Max Duration Poll = 120 (2 minutes)

 l Max Events Poll = 5000 (5000 events per polling interval)

 l Max Idle Time Poll = 0

For very active Check Point event sources, it is a good practice to set up a connection that stays 
open until you stop collection (persistent connection). This ensures that Check Point collection 
maintains the pace of the events generated by these active event sources. The persistent 
connection avoids restart and connection delays and prevents Check Point collection from 
lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters 
to the following values:

 l Polling Interval = -1

 l Max Duration Poll = 0

 l Max Events Poll = 0

 l Max Idle Time Poll = 0

Parameter Description

Port Port on the Check Point server that Log Collector connects to. Default value is 

18184.
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Parameter Description

Collect Log 

Type

Type of logs that you want to collect:  Valid values are: 

 l Audit - collects audit events.

 l Security - collects security events.

If you want to collect both audit and security events, you must create a 
duplicate event source. For example, first you would create an event source 
with Audit selected pulling a certificate into the trust store for this event 
source. Next you would create another event source with the same values 
except that you would select Security for the Collect Log Type and you would 
select the same certificate in Certificate Name that you pulled when you set up 
the first set of parameters for this event source and you would make sure that 
Pull Certificate was not selected.

Collect Logs 

From

When you set up a Check Point event source, NetWitness collects events from 
the current log file. Valid values are: 

 l Now - Start collecting logs now (at this point in time in the current log file). 

 l Start of Log - Collect logs from the beginning of the current log file.

If you choose "Start of Log" for this parameter value, you may collect a very 
large amount of data depending on how long the current log file has been 
collecting events. Note that this option is effective only for the first collection 
session.

Polling 

Interval

Interval (amount of time in seconds) between each poll. The default value is 
180.

For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, it will 
wait for it to finish that cycle. If you have a large number of event sources that 
you are polling, it may take longer than 180 seconds for the polling to start 
because the threads are busy.

Max 

Duration 

Poll

The maximum duration of polling cycle (how long the cycle lasts) in seconds.

Max Events 

Poll

The maximum number of events per polling cycle (how many events collected 

per polling cycle).
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Parameter Description

Max Idle 

Time Poll

Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is 

the default value.

Forwarder Enables or disables the Check Point server as a forwarder. By default it is 

disabled.

Log Type 
(Name 
Value Pair)

Logs from the event source in Name Value format. By default it is disabled.

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if 
you have a problem with an event source and you need to investigate this 
problem. Enabling debugging will adversely affect the performance of the 
Log Collector.

Enables and disables debug logging for the event source.

Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).
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File Parameters
This topic describes the File Collection configuration parameters.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure File Event Sources in NetWitness Suite

File Collection Event Source Parameters
The following table provides descriptions of the File Collection source parameters.
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Name Description

Basic

File 

Directory*

Collection directory (for example, Eur_London100) into which the File event 
source places its files. Valid value is a character string that is conforms to the 
following regular expression:

[_a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, 
letters, and underscores. Do not modify this parameter after you start collecting 
event data.

After you create the collection, the Log Collector creates the work, save, and 
error sub-directories under the collection directory.

Address* IP address of the event source. Valid value is an IPv4 address, IPv6 address, 

or a hostname including a fully-qualified domain name.

File Spec Regular expression. For example, ^.*$ = process everything.

File 

Encoding

Internationalization file encoding. Enter the File Encoding method, the following 
strings are examples of valid methods:

 l UTF-8 (default)

 l UCS-16LE

 l UCS-16BE

 l UCS-32LE

 l UCS-32BE

 l SHIFT-JIS

 l EBCDIC-US

Enabled Select the check box to enable the event source configuration to start collection. 

The check box is selected by default.

Advanced
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Name Description

Ignore 

Encoding

 Conversion 

Errors

Select the check box to ignore encoding conversion errors and ignore invalid 
data. The check box is selected by default.

Caution: This may cause parsing and transformation errors.

File Disk 

Quota

Determines when to stop saving files regardless of the Save On Error and  
Save On Success parameter settings. For example, a value of 10 indicates that 
when there is less than 10% available disk left, the Log Collector stops saving 
files to reserve enough space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection 
directory is mounted. If the Log Decoder server has a 10TB disk size and 
2TB is allocated to base collection directory, then setting this value to 10 
causes log collection to stop when less than 0.2TB (10% of 2TB) of space is 
left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential 

Processing

Sequential processing flag: 

 l Select the check box (default) to process event source files in collection 
order.

 l Do not select the checkbox to process event source files in parallel.

Save On 

Error

Save on error flag. Check the checkbox to retain the eventsource collection file 

when the Log Collector it encounters an error. The check box is selected by 

default.

Save On 

Success

Save eventsource collection file after processing flag. Check the checkbox to 

save the eventsource collection file after processing it. The check box is not 

selected by default.
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Name Description

Eventsource 

SSH Key

SSH public key used to upload files for this event source. Please refer to the 
Generate Key Pair on Event Source and Import Public Key to Log Collector 
section in the Install and Update the SFTP Agent Guide for instructions on 
generating keys.

Note: If File collection is stopped, NetWitness Suite does not update the 
authorized_keys file with the SSH public key that you add or modify in this 
parameter. You must restart File collection to update the public key.
You can add or modify the value of the public key in this parameter in 
multiple File event sources without File collection running, but NetWitness 
Suite will not update the authorized_keys file until File collection is 
restarted.

Manage 

Error Files

By default, the Log Collectoruses the File Disk Quota parameter to ensure that 
the disk does not fill up with error files. If you set this parameter to true, you 
can specify one of these: 

 l Maximum space allotted to error files in the Error Files Size parameter.

 l Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to 
reduce when the maximum is reached.

Select the check box to manage error files. The check box is not selected by 
default.

Error Files 

Size

Only valid if the Manage Error Files and Save On Error parameters are set 
to true.
Specifies to what extent NetWitness Suite saves error files. The value that you 
specify is the maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. You specify these 
values in either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the 
default. If you change this parameter, the change does not take effect until you 
restart collection or restart the Log Collector service.

Error Files 

Count

Only valid if the Manage Error Files and Save On Error parameters are set 
to true. Maximum number of error files allowed in the error directory. Valid 
value is a number in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.
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Name Description

Error Files 

Reduction 

%

Percent amount by size or count of the error files that the Log Collectorservice 
removes when the maximum size or count has been reached. The service 
removes the oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Manage 

Saved Files

Select the check box to manage saved files. The check box is not selected by 
default.
By default, the Log Collector uses the File Disk Quota parameter to ensure that 
the disk does not fill up with saved files. If check this check box, you can 
specify one of these: 

 l Maximum space allotted to saved files in the Saved Files Size parameter.

 l Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to 
reduce when the maximum is reached.

Saved Files 

Size

Only valid if the Manage Saved Files and Save On Success parameters are set 
to true.
Maximum total size of all the files in the save directory. Valid value is a 
number in the 0 to 281474976710655 range. You specify these values in either 
Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.

Saved Files 

Count

Only valid if the Manage Saved Files and Save On Success parameters are set 
to true. Maximum number of saved files in the save directory. Valid value is a 
number in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart 
collection or restart the Log Collector service.

Saved File 

Reduction 

%

Percent amount by size or count of the saved files that the Log Collector service 
removes when the maximum size or count has been reached. The service 
removes the oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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Name Description

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you 
have a problem with an event source and you need to investigate this problem. 
Enabling debugging will adversely affect the performance of the Log 
Collector.

Enables/disables debug logging for the event source.
Valid values are: 

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source 
collection issues. The debug logging is verbose, so limit the number of event 
sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart 
required).

Cancel Closes the dialog without making adding an event source type.

OK Adds the parameters for the event source.
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Log Collection Service System View
A Log Collector is a service that runs on a Log Decoder host (referred to as a Local Collector) 
or sends events from a Remote Collector to a Local Collector, and is configured and managed in 
a similar way to a Log Decoder. 

To access the Log Collection Service System view, go to ADMIN > Services and select a Log 
Collector service, then select View > System.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to ... Documentation

Administrator Perform basic Log Collection 
implementation

Basic Implementation

Administrator Set up a lockbox to maintain lockbox 
settings

Set Up a Lockbox

Administrator *Start Log Collection Services. Start Collection Services

Administrator Configure Log Collection protocols and 
event sources.

Configure Collection Protocols and 

Event Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is 

Working

*You can perform this task here.

Related Topics
Basic Implementation

Quick Look
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From the Log Collector Service Information Toolbar, you can manage event data using the 
Collection icon to start event data from a stopped protocol or stop collecting data from a started 
protocol. From the Host Tasks icon, you can select tasks that you want to run. You can also 
shutdown your service and reboot your service from the Service Information Toolbar.
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ODBC Event Source Configuration Parameters
This topic tells you how to configure ODBC collection protocol which collects events from 
event sources that store audit data in a database using the Open Database Connectivity (ODBC) 
software interface.

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:

 1. Go to  Administration > Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select View > Config to display the Log Collection configuration parameter 
tabs.

The Service Config view is displayed with the Log Collector General tab open.

 4. Click the Event Sources tab, and select ODBC/Config from the drop-down menu.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I Want to... Documentation

Administrator Perform basic Log Collection 
implementation.

Basic Implementation

Administrator Set up a lockbox to maintain lockbox 
settings.

Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and 
event sources.

Configure Collection Protocols and 

Event Sources
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Role I Want to... Documentation

Administrator Verify that Log Collection is working. Verify That Log Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure ODBC Event Sources in NetWitness Suite

 l Configure Data Source Names (DSNs)

 l Troubleshoot ODBC Collection

 l Create Custom Typespec for ODBC Collection

Data Source Name (DSN) Parameters

Use the Sources panel to review, add, modify, and delete Data Source Name (DSN) parameters.

Sources Panel

An ODBC DSN tells the Log Collector how to reach an ODBC endpoint. You refer to an 
ODBC DSN when you configure a data source name with information such as which ODBC 
driver to use or the host name and port of the ODBC endpoint.

An ODBC DSN is a sequence of name‐value pairs. For information about the valid names for a 
given ODBC data source type, such as Sybase, Microsoft SQL Server, or Oracle, please 
download the DataDirect Connect Series for ODBC User's Guide and DataDirect Connect 
Series for ODBC User's Guide in the Progress DataDirect Document Library.

Toolbar

The following table provides descriptions of the toolbar options.

Option Description

Opens the Add DSN dialog in which you add an event source for the 
event source type you selected in the Event Categories panel.

Deletes the selected event sources.
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Option Description

Opens the Edit DSN dialog in which you modify the configuration 
parameters for the selected event source.

When you select multiple event sources, this option opens the Bulk Edit 
Source dialog in which you can edit the parameters values for the 
selected file directories. 

Opens the Bulk Add Option dialog in which you can import DSN 
parameters in bulk from a comma-separated values (CSV) file.  The Bulk 
Add Option dialog has the following two options:

 l Import CSV File

 l Paste CSV Content

Creates a .csv file that contains the parameters for the selected DSNs.

Validates the configuration parameters for the selected ODBC database.

Add or Edit DSN Dialog

In this dialog, you add or modify an event source for the selected event source.

Basic Parameters

Name Description

DSN* The data source name (DSN) that defines the database from which to collect 
events.

Select an existing DSN from the drop-down list. For details, see ODBC DSNs 
Event Source Configuration Parameters.

Username* User name that the data source name uses to connect to the database. You must 
specify a user name when you create the event source.

Password Password that the data source name uses to connect to the database.

Caution: The password is encrypted internally and is displayed in its 
encrypted form.

Enabled Select the checkbox to enable the event source configuration to start collection. 
The checkbox is selected by default.

Address* For ODBC, this field is not used.  The Log Collector uses the address in the 
ODBC.ini file.
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Advanced Parameters

Name Description

Max Cell 
Size

Maximum size in bytes of the data that the Log Collector can pull from one cell 
in the database. The default value is 2048.

Nil Value Character string that the Log Collector displays when NIL is returned for a cell 
in the database. Default value: “” (null).

Polling 
Interval

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event 
source every 180 seconds. If the previous polling cycle is still underway, the 
collector waits for that cycle to finish. If you have a large number of event 
sources that you are polling, it may take longer than 180 seconds for the polling 
to start because the threads are busy.

Max 
Events Poll

The maximum number of events per polling cycle (how many events collected 
per polling cycle).

Debug Caution: Caution: Only enable debugging (set this parameter to On or 
Verbose) if you have a problem with an event source and you need to 
investigate this problem. Enabling debugging will adversely affect the 
performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:

 l Off = (default) disabled

 l On = enabled

 l Verbose = enabled in verbose mode ‐ adds thread information and source 
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection 
issues. If you change this value, the change takes effect immediately (no restart 
required). The debug logging is verbose, so limit the number of event sources to 
minimize performance impact.

Initial 
Tracking 
Id

Initial identification code that the Log Collector assigns to this event source if 
collection is not started. If there is no value for this parameter, the Log Collector 
starts at the end of the table and only pulls rows after the end of the table as they 
are added. The default value is “” (null).
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Name Description

Filename For Microsoft SQL Server Event Sources only, the location of the trace files 
directory  (for example, C:\MyTraceFiles).

Refer to the RSA Microsoft SQL Server Event Source Configuration Guide, 
located on RSA Link here: https://community.rsa.com/docs/DOC-40241.

Test 
Connection

Checks the configuration parameters specified in this dialog to make sure they 
are correct.

Cancel Closes the dialog without adding or modifying DSN parameters.

OK Adds or modifies the parameters for the DSN.
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ODBC DSNs Event Source Configuration Parameters
Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you 
need to define DSNs with their associate value pairs for ODBC event source configuration. 

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:

 1. Access the Services view by selecting Admin > Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select  View > Config to display the Log Collection configuration 
parameter tabs.

The Service Config view is displayed with the Log Collector General tab open.

 4. Click the Event Sources tab, and select ODBC/DSNs from the drop-down menu.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services
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Role I want to... Documentation

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l Configure ODBC Event Sources in NetWitness Suite

 l Configure Data Source Names (DSNs)

ODBC DSN Configuration Parameters
This topic describes the Data Source Names DSNs configuration parameters.

DSN Panel

In the DSNs panel, you can add, delete, or edit DSNs and the DSN name‐value pairs for ODBC 
Event sources.

Feature Description

Displays the Add DSN dialog in which you define a DSN and its parameters.

Deletes the selected DSNs.

Displays the Edit DSN dialog in which you edit the name-value pairs for the 

selected DSN.

Displays the Manage DSN Templates dialog in which you can add or delete 

DSN name-value pair templates.

Selects DSNs.

DSN Name of the DSN that you added.

Parameters <name-value for="" p="" pairs="" the=""> </name-value>
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Add or Edit DSN Dialog

In this dialog, you add or modify a file directory for the selected event source.

Feature Description

DSN 

Template

Select a predefined DSN value name-value pairs template for the DSN.

DSN 

Name*

Add the name of the DSN.  You cannot edit a DSN name after you add it.

This value must correspond with a DSN entry in the ODBC.ini file. Valid value 
is a character string that is restricted to the following characters:

[_a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, 
letters, and underscores (for example, oracle_executive_compensation).

Parameters   Adds a row in which you can define a parameter name-value pair.

 Deletes the selected parameter name-value pair.

 Selects parameter name-value pairs.

Name -  Enter or modify the parameter name.

Value -  Enter or modify the value associated with the parameter name.

Cancel Closes the dialog without adding the DSN and its name-value pairs or saving 

modifications to the name-value pairs.

Save Adds the DSN and its name-value pairs or saves modifications to the name-value 

pairs.

Manage DSN Templates Dialog

In this dialog, you can add or delete DSN name-value pair templates.

Feature Description

Template Selection Panel

Opens the Add Template panel in which you can add a DSN name-value pair 

template.
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Feature Description

Deletes the selected template.

Selects a template for deletion or modification.

Add Template Panel

Adds a value pair row.

Deletes a value pair row.

Selects a value pair row.

Name Enter the parameter name.

Value Enter the value associated with the parameter name.

Cancel Cancels any changes you made in the dialog.

Save Adds the DSN and its name-value pairs or saves modifications to the name-value 

pairs.

Close Closes the dialog without adding the DSN and its name-value pairs or saving 

modifications to the name-value pairs.
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 Remote/Local Collectors Configuration Parameters
When you deploy Log Collection, you must configure the Log Collectors to collect the log events 
from various event sources, and to deliver these events reliably and securely to the Log Decoder      
host, where the events are parsed and stored for subsequent analysis.

This topic introduces features of the Services Config view > Remote Collectors/Local Collectors 
tab.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
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 l Provision Local Collectors and Remote Collectors

 l Configure Local and Remote Collectors

Services Config View
The Services Config view is the view on which you maintain all the Log Collection parameters. 
The tab in which you maintain the deployment parameters referred to in this guide is the 
Remote/Local Collectors tab:

 l If you are configuring a Local Collector      , NetWitness Suite   displays the Remote Collectors 
tab so that you can configure the Local Collector       to pull events from Remote Collectors.

 l If you are configuring a Remote Collector       , NetWitness Suite   displays the Local Collectors 
tab so that you can configure the Remote Collector        to push events to a Local Collector      .

Remote Collectors Tab

On a Local Collector, the Remote Collectors panel provides a way to add or delete Remote 
Collectors from which the Local Collector       pulls events.

Column Description

Displays the Add Source dialog in which you select the Remote Collectors from 

which you want the Local Collector       to pull events.

Deletes the Remote Collector        from the Local Collector       Remote Collectors panel.

Displays the Edit Source dialog for the selected Remote Collector       .

Selects Remote Collectors.

Name Names of the Remote Collectors from which the Local Collector       currently pulls 

events.

Address IP Addresses of the Remote Collectors from which the Local Collector       currently 

pulls events.

Collections Choose which collection protocols that the Remote Collector        pushes to a Local 
Collector.

You can select any combination of protocols. If you do not select a protocol, 
NetWitness Suite   selects all protocols.
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Local Collector       Tab

On a Remote Collector       , the Local Collector       panel provides a way to add or delete the Local 
Collectors to which you want to the Remote Collector        to push events.

Select the Destination or Source in the Select Configuration drop-down menu.

 l Destination displays the  Add Remote Destination dialog.

 l Source displays the Add Source dialog.

The following table describes the Add Source dialog.

Column Description

Displays the Add Source dialog in which you select the Remote Collectors from 

which you want the Local Collector       to pull events.

Deletes the Remote Collector        from theLocal Collector       Remote Collectors panel.

Displays the Edit Source dialog for the selected Remote Collector       .

Selects Remote Collectors.

Name Names of the Remote Collectors from which the Local Collector       currently pulls 

events.

Address IP Addresses of the Remote Collectors from which the Local Collector       currently 

pulls events.

The following table describes the Local Collectors Panel.

Column Description

Displays the Add Remote Destination dialog for the Group that you selected. 

You add destination Local Collectors for this group to which you want the 

Remote Collector        to push events.

Deletes the destination Log Collector   from the group.
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Column Description

Displays the Edit Remote Destination dialog for the selected destination Local 

Collector      .

Selects a destination Local Collector      .

Destination 

Name

Displays the name of the destination Local Collector      .

Address Displays the IP address of the destination Local Collector      .

Collections Choose which collection protocols that the Local Collector       pulls from a Remote 
Collector.

You can select any combination of protocols. If you do not select a protocol, 
NetWitness Suite   selects all protocols.

Log Collection Tabs
This topic describes the tabs available in the Log Collection view.

Access Log Collection View

 1. Go to ADMIN > Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Under Actions, select View > Config to display the Log Collection configuration parameter 
tabs.

The Service Config view is displayed with the Log Collector General tab open.

 4. Select any of the available tabs to view or update the corresponding parameters.

Available Tabs

Use the Admin > Services view to maintain Log Collection parameters. It has the following 
tabs:

 l General: contains high-level parameters that govern the operation of the Log Collector  
service and each collection protocol. See Log Collection General Tab for details.
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 l Remote Collectors: use this tab to set up remote collectors. See Configure Local and Remote 

Collectors for details.

 l Files: provides an interface for editing Log Collector configuration files.

 l Event Sources: use this tab to configure collection for your event sources. See Log Collection 

Event Sources Tab for details.

 l Event Destinations: Use the Event Destinations tab of the Log Collection service Config 
view to configure the destination of event data collected by the Log Collector. See Log 

Collection Event Destinations Tab for details.

 l Settings: contains parameters for Lockbox security setup, and certificate management.

 l Appliance Service Configuration: contains configuration parameters for the RSA 
NetWitness Suite Core Appliance service.

Please refer to the Files tab and the Appliance Service Configuration  tab in the Host and 
Services Configuration Guide for information on the configuration parameters on these tabs.
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Log Collection General Tab

This topic introduces features of the service Config view > General tab that relate specifically to 
Log Collector  .

To access the Log Collection General tab:

 1. Go to  ADMIN> Services  from the NetWitness Suite menu.

 2. Select a Log Collection service.

 3. Click   under Actions and  select View > Config.

The Service Config view is displayed with the Log Collector General tab open.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 

Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 

Services

Administrator Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator *Verify that Log Collection is working. Verify That Log 

Collection Is 

Working
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*You can perform this task here.

Related Topics

 l Configure AWS (CloudTrail) Event Sources in NetWitness Suite

 l Configure Check Point Event Sources in NetWitness Suite

 l Configure File Event Sources in NetWitness Suite

 l Configure Netflow Event Sources in NetWitness Suite

 l Configure ODBC Event Sources in NetWitness Suite

 l Configure SDEE Event Sources in NetWitness Suite

 l Configure SNMP Event Sources in NetWitness Suite

 l Configure Syslog Event Sources for Remote Collector

 l Configure VMware Event Sources in NetWitness Suite

 l Configure Windows Event Sources in NetWitness Suite

 l Windows Legacy and NetApp Collection Configuration

Quick Look

The RSA NetWitness Suite   administrator must configure event sources to send logs to the 
collectors. When event sources are configured they poll event sources, retrieve logs, and send 
the event data to NetWitness Suite  ). 

System Configuration Panel

The System Configuration panel manages service configuration for a NetWitness Suite   service. 
When a service is first added, default values are in effect. You can edit these values to tune 
performance. Refer to the General tab for a description of these parameters.

1 System Configuration Panel manages service configuration for a NetWitness Suite   

service. 
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2 Compression: The minimum number of bytes that must be transmitted per response before 

compression. A setting of 0 disables compression. The default value is 0.

A change in value is effective immediately for all subsequent connections.

3 Port: The port on which the service  listens. The ports are: 

 l 50001 for Log Collectors

 l 50002 for Log Decoders

 l 50003 for Brokers

 l 50004 for Decoders

 l 50005 for Concentrators

 l 50007 for other services

4 SSL FIPS Mode: When enabled (on), the security of data transmission is managed by 

encrypting information and providing authentication with SSL certificates. The default 

value is off.

5 SSL Port: The NetWitness Suite   Core SSL port on which the service listens. The ports 

are: 

 l 56001 for Log Collectors

 l 56002 for Log Decoders

 l 56003 for Brokers

 l 56004 for Decoders

 l 56005 for Concentrators

 l 56007 for other services

6 Stat Update Interval: The number of milliseconds between statistic updates on the system. 

Lower numbers cause more frequent updates and can slow down other processes. The 

default value is 1000.

 A change in value is effective immediately.

7 Threads: The number of threads in the thread pool to handle incoming requests. A setting 

of 0 lets the system decide. The default value is 15. 

 A change takes effect on service restart.
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Collector Configuration Panel

The Collector Configuration panel provides a way to enable automatic start of log collection by 
event source type.

1 Collector Configuration Panel provides a way to enable automatic start of log collection 

by event source type.

2 Enable All enables the automatic collection for all event types. 

Enable All = start receiving events and collecting logs for all event types when the Log 
Collector   service starts.

3 Disable all disables the automatic collection for all event types.

Disable All = (default) do not receive event data for all event types until you explicitly 
start collection.

4 Start Collection on Service Startup enables automatic start, per event source type, of log 

collection when the Log Collector   service starts. Valid values are: 

 l Selected = start collecting logs when the Log Collector   service starts.

 l Not selected = (default) do not collect event data until you explicitly start collection.

5 Apply: Click Apply to save the changes to the parameter values.
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Log Collection Event Destinations Tab

Use the Event Destinations tab of the Log Collection service Config view to configure the 
destination of event data collected by the Log Collector :

 l Log Decoders

 l Identity Feed

Prerequisites 

You must implement the following configuration to create an identity feed.

 l A Log Collector   service with an Identity Feed Event Processor

 l A Log Collector   service with Windows Collection configured and enabled

Note: See the "Create an Identity Feed" topic in the Live Resource Management Guide for 
more information on how to create and investigate on an identity feed.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 
Implementation

Administrator Set up a to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources
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Role I want to... Documentation

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics

 l See the Create an Identity Feed topic in the Live Resource Management Guide.

Quick Look

The Event Destinations tab of the Log Collection service Config view allows you to configure 
the destination of event data collected by the Log Collector  .

The required permission to access this view is Manage Services.

 1. Go to  ADMIN> Services .

 2. Select a Log Collection service.

 3. Under Actions, select  > View > Config to display the Log Collection configuration 

parameter tabs.

 4. Click the Event Destinations tab.

 5. In the Select Event  Destinations drop-down menu:

 l Select Log Decoder to configure Log Decoder destinations for event data collected by 
the Log Collector  .
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Note: You must select a Log Decoder service from the Add Log Decoder 
Destination dialog, but the remainder of the configuration is done automatically. 

 l Select Identity Feed to configure an identity feed destination for event data collected by 
the Log CollectorLog Collector  .
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Log Collection Event Sources Tab

Use the Event Sources tab  to configure the AWS (CloudTrail), Check Point, File, ODBC, 
SDEE, SNMP, Syslog, SNMP, VMware,  Windows, and Windows Legacy event sources. 

To access the Event Sources tab, go to ADMIN > Services > select Log Collection service > 
View > Config >  Event Sources) .

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 
Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 
Services

Administrator *Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics

 l Configure AWS (CloudTrail) Event Sources in NetWitness Suite

 l Configure Check Point Event Sources in NetWitness Suite
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 l Configure File Event Sources in NetWitness Suite

 l Configure ODBC Event Sources in NetWitness Suite

 l Configure SDEE Event Sources in NetWitness Suite

 l Configure SNMP Event Sources in NetWitness Suite

 l Configure Syslog Event Sources for Remote Collector

 l Configure VMware Event Sources in NetWitness Suite

 l Configure Windows Event Sources in NetWitness Suite

 l Windows Legacy and NetApp Collection Configuration

Quick Look
The Config view has two drop-down menus:

 l The left-most menu lists all of the available collection protocols.

 l The right-most menu has two choices: Config and Filter.

 

The Config view in the Event sources tab has two panels: Event Categories and Sources.

177 Reference



Log Collection Configuration Guide

Note: For details on the Filter menu item, see Configure Event Filters for a Collector.

Event Source Types Menu

The Log Collector Event Sources tab has a two-box, drop-down menu in which you select the 
collection protocol and any supporting parameters for that protocol.

In the left box, you select one of the following protocols: Check Point, File, ODBC, 
Plugins, SDEE, SNMP, SNMP, VMware, Windows, and Windows Legacy.

In the right box, you select:

 l Config to configure the generic event source parameters for the type you selected in the left 
drop-down.  All generic Config panels have a toolbar with these options:

 l Add, Edit, and Delete

 l Import  (also Import Source, Import DSN)

 l Export (also Export Source, Export DSN)

 l For ODBC, SNMP, and Windows only: 

 l For ODBC, DSNs to configure

 l For SNMP, SNMP v3 User Manager

 l For Windows, Kerberos Realm Configuration

Selecting an option displays a configuration panel where you configure the collection parameters 
for the event source. The configuration panels are slightly different for different event sources 
and are described separately.

Event Categories Panel

Once you select a collection protocol, the Event Categories panel is populated with all of the 
event sources that you have configured for that collection protocol. For example, the following 
image shows ODBC event sources that have been configured:
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The Event Categories panel provides a way to add or delete event source types.

1 Displays the Available Event Source Types dialog from which you select the event source 

type for which you want to define parameters.

2 Deletes the selected event source types from the Event Categories panel.

3 Selects event source types.

4 Displays the name of the event source types that you have added.

Sources Panel

The Sources panel lists the values of the parameters for the selected event source type. For 
details, see the individual collection protocol topics.
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Log Collection SettingsTab

Use the Settings tab to:

 l Set up a lockbox

 l Reset Stable System value

 l Manage certificates

Caution: If the host name on which the Log Collector is installed is changed after installation, 
the Log Collector will fail to collect events from event sources.  You must reset stable system 
values if the hostname changes.

To access the Log Collection Settings Tab, go to ADMIN > Services. In the Services grid, 
select a Log Collector Service. Click Actions menu cropped under Actions and select View > 
Config.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log 
Collection.

What do you want to do?

Role I want to... Documentation

Administrator Perform basic Log Collection implementation. Basic 
Implementation

Administrator *Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection 

Services

Administrator Configure Log Collection protocols and event 

sources.

Configure Collection 

Protocols and Event 

Sources
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Role I want to... Documentation

Administrator Verify that Log Collection is working. Verify That Log 
Collection Is 
Working

*You can perform this task here.

Related Topics
 l See the "Create an Identity Feed topic" in the Live Resource Management Guide.

Quick Look
This is an example of the Settings tab.
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Troubleshoot Log Collection
This topic describes the format and content of Log Collection Troubleshooting. NetWitness Suite 
informs you of Log Collector problems or potential problems in the following two ways.

 l Log files.

 l Health and Wellness Monitoring views.

Log Files
If you have an issue with a particular event source collection protocol, you can review debug 
logs to investigate this issue. Each event source has a Debug parameter that you can enable (set 
parameter to On or Verbose) to capture these logs.

Caution:  Only enable debugging if you have a problem with this event source and you need to 
investigate this problem. If you have Debug enabled all the time it will adversely affect the 
performance of the Log Collector.

Health and Wellness Monitoring
Health and Wellness monitoring makes you aware of potential hardware and software problems 
in a timely manner so that you can avoid to outages. RSA recommends that you monitor the Log 
Collector statistical fields to make sure that the service is operating efficiently and is not at or 
near the maximum values you have configured. You can monitor the following statistics (Stats) 
described in the Admin > Health & Wellness view.

Sample Troubleshooting Format
RSA NetWitness Suite returns the following types of error messages in the log files for.

Log 
Messages

timestamp failure (LogCollection) Message-Broker Statistics:...

timestamp failure (AMQPClientBaseLogCollection):...
timestamp failure (MessageBrokerLogReceiver):...

Possible 
Cause

The Log Collector cannot reach the Message Broker because the Message 
Broker:

 l stopped running.

 l has erroneous connection settings.
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Solutions

 1. <use the="the" systemctl="systemctl" command="command" 
on="on" console="console" to="to" check="check" 

status="status" of="of" message="message" 

broker="broker" shell="shell" 

console.="console.">returns the following if the message 

broker is not running:</use>

            prompt$ systemctl status rabbitmq-server

            rabbitmq start/running, process 10916 

 2. Start the RabbitMQ Message Broker on event-broker node in the Explore 
view:

Troubleshooting - Windows log Collection using Endpoint Agent
The following topics helps troubleshoot issues you can come across while using windows log 
collection file on Endpoint Insights Agent.

Windows Log Configuration File Format Explained

Caution: Do not edit the generated configuration file. If any  changes are made, the agent does 
not read the information from the file.

The log configuration file contains information helpful for analyzing event logs. Below is an 
example:
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The generated config file contains the following:

 l Config name: Name of the configuration file. 

 l Servers: Array of server URLs, describing both their address and protocol to use when 
forwarding the logs. The agent will attempt to contact them in order. 

 l Filter: Windows Event viewer compatible XML which describes the channels to watch and 
any event ID exclusion. A standard XML filter to collect from channel Application and 
System, with one event ID excluded from both would look like this:

 l Enabled: Allows to disable collection but still send a test log if that is enabled.

 l TestLogOnLoad: Will send a log message when a configuration is loaded, even if event 
forwarding is not enabled. This helps Analysts test a configuration before enabling collection. 
This message is not logged locally in the Windows Event log.

Test Log - How to Read

Test log message is sent whenever an Endpoint Agent with windows log collection file is 
installed for the first time on an Endpoint Agent or when the log configuration file is updated. On 
a successful install or updation of windows log collection - There are 3 sections displayed in the 
test log file. 
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1 Test log message type, Agent's IP address, Agent's Hostname and time of generation of 

the test log

2 Configuration provided during the creation of the agent

3 Status and the message associated with it

There are three scenarios.

 1. Successful deployment of a log collection configuration - Test Log message type will be -1 
and status will be displayed as success. 

 2. Whenever the log collection configuration file is tampered with - The Agent Test message 
will be displayed as -2 and a message displaying the configuration file has been tampered 
with is displayed. In case, you want to reapply the changes, regenerate the log collection 
file.

 3. When the custom channel name is wrong - Status Failure message is displayed. Regenerate 
the log collection with the correct channel.
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