AFX Server intermittently shuts down in RSA Identity Governance & Lifecycle
Originally Published: 2019-10-07
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: 7.1.0
Issue
The aveksaServer.log shows the following warnings and errors:
12/12/2018 04:00:00.015 WARN (ThreadPool-5) [com.aveksa.server.scheduler.SchedulerServiceProvider] ScheduledTask: Heartbeat_TASK could not be persisted
12/12/2018 04:04:29.887 WARN (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 17002, SQLState: 08006
12/12/2018 04:04:29.887 ERROR (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] IO Error: The Network Adapter could not establish the connection DSRA0010E: SQL State = 08006, Error Code = 17,002
12/12/2018 04:00:00.010 WARN (ThreadPool-5) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 17002, SQLState: 08006
12/12/2018 04:00:00.010 ERROR (ThreadPool-5) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] IO Error: The Network Adapter could not establish the connection DSRA0010E: SQL State = 08006, Error Code = 17,002
12/12/2018 04:00:00.010 ERROR (ThreadPool-5) [com.aveksa.server.node.HeartbeatServiceProvider] Unable to update Server Node status
com.aveksa.server.system.SystemServiceException: com.aveksa.server.db.PersistenceException: n/a
Please refer to RSA Knowledge Base Article 00000327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment.
The home/afxuser/AFX/esb/logs/esb.AFX-MAIN.log file shows the following errors:
2018-12-11 21:33:12.656 [WARN] com.aveksa.afx.server.component.ResponseTransformerComponent:159 - Unable to process primary response from ACM (http status 401):2018-12-11 21:33:12.656 [WARN] com.aveksa.afx.server.component.ResponseTransformerComponent:159 - Unable to process primary response from ACM (http status 401):Error 401: SRVE0295E: Error reported: 401
2018-12-11 21:34:13.080 [ERROR] org.mule.exception.DefaultMessagingExceptionStrategy:337 - ********************************************************************************Message : Failed to route event via endpoint: DefaultOutboundEndpoint{endpointUri=https://<server-name>:8444/aveksa/afx/settings-test, connector=HttpsConnector{ name=afxRequestHttpsConnector lifecycle=start this=11e9cd82 numberOfConcurrentTransactedReceivers=4 createMultipleTransactedReceivers=true connected=true supportedProtocols=[https] serviceOverrides= session.handler=org.mule.session.NullSessionHandler}, name='endpoint.https.<server-name>.8444.aveksa.afx.settings.test', mep=REQUEST_RESPONSE, properties={exceptionOnMessageError=true, http.method=POST, followRedirects=false}, transactionConfig=Transaction{factory=null, action=INDIFFERENT, timeout=0}, deleteUnacceptedMessages=false, initialState=started, responseTimeout=60000, endpointEncoding=UTF-8, disableTransportTransformer=false}. Message payload is of type: PostMethodCode : MULE_ERROR--2--------------------------------------------------------------------------------Exception stack is:1. Read timed out (java.net.SocketTimeoutException) java.net.SocketInputStream:-2 (null)2. Failed to route event via endpoint: DefaultOutboundEndpoint{endpointUri=https://<server-name>:8444/aveksa/afx/settings-test, connector=HttpsConnector{ name=afxRequestHttpsConnector lifecycle=start this=11e9cd82 numberOfConcurrentTransactedReceivers=4 createMultipleTransactedReceivers=true connected=true supportedProtocols=[https] serviceOverrides= session.handler=org.mule.session.NullSessionHandler}, name='endpoint.https.<server-name>.8444.aveksa.afx.settings.test', mep=REQUEST_RESPONSE, properties={exceptionOnMessageError=true, http.method=POST, followRedirects=false}, transactionConfig=Transaction{factory=null, action=INDIFFERENT, timeout=0}, deleteUnacceptedMessages=false, initialState=started, responseTimeout=60000, endpointEncoding=UTF-8, disableTransportTransformer=false}. Message payload is of type: PostMethod (org.mule.api.transport.DispatchException) org.mule.transport.http.HttpClientMessageDispatcher:151 (http://www.mulesoft.org/docs/site/current3/apidocs/org/mule/api/transport/DispatchException.html)--------------------------------------------------------------------------------Root Exception stack trace:java.net.SocketTimeoutException: Read timed out at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.socketRead(SocketInputStream.java:116) at java.net.SocketInputStream.read(SocketInputStream.java:171) + 3 more (set debug level logging or '-Dmule.verbose.exceptions=true' for everything)********************************************************************************
Cause
Resolution
- RSA Identity Governance & Lifecycle 7.1.0 P07
- RSA Identity Governance & Lifecycle 7.1.1 P01
- RSA Identity Governance & Lifecycle 7.2
Workaround
afx restart
Related Articles
How to shut down Authentication Manager 8.x primary, replicas and web tiers 81Number of Views 'No such service afx_server' error when performing afx status/stop/start commands in RSA Identity Governance & Lifecycle 147Number of Views RSA Identity Governance & Lifecycle 6.8.x and above remote Access Fulfilment Express (AFX) server fails to start with the … 163Number of Views AFX Server fails to start in RSA Identity Governance & Lifecycle 442Number of Views Cannot download offline authentication on some DC machines 117Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?