AFX Server is in a 'Not running' State in the user interface but 'afx status' indicates AFX is running in RSA Identity Governance & Lifecycle
Originally Published: 2018-06-20
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.0.2, 7.1.0
Issue
Additional Symptoms
- The output from the afx status command indicates that AFX is running.
- No changes have been made to the system.
- There may be connection refused errors in the $AFX_HOME/esb/logs/esb.AFX-INIT.log but the other AFX logs and the aveksaServer.log have no errors.
- The following message is seen repeatedly in the $AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log file:
[com.aveksa.afx.server.service.AFXServerAgentServiceProvider] getServerAgentUptimeDate: Removing the uptime date for server agent 1 - prior uptime date: null, prior last polled date: null, last polled date: 2018-06-12 19:08:56.0, current date: 2018-06- 12 20:25:35.0, polling interval 5000
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (Admin > System > Server Nodes tab > under Logs.)
Cause
Resolution
This patch updates the persistence layer which prevents deadlocks when updating the T_AV_AFX_SERVER_AGENT table (and other tables).
Unfortunately due to the complexity of the fix for this issue, this issue cannot be back-ported to 7.0.2.
Workaround
afx stop acm stop acm stopdb acm startdb acm start afx start
Related Articles
AFX Connectors remain in a Deployed state and ActiveMQ is not running in RSA Identity Governance & Lifecycle 464Number of Views 'The RSA Identity Governance & Lifecycle server is not running and is not in a starting state' when starting RSA Identity … 578Number of Views AFX Server Fails to Start with 'Could Not Build a Validated Path' and 'Timed Out Waiting for AFX Applications to Start' in… 1.22KNumber of Views AFX Server remains in a 'Not running' State with 'An issue with handling encryption was encountered' error on startup in R… 502Number of Views 'AFX server is not running' message printed in logs every minute for each unused (Disabled, Not running, or deleted) AFX S… 10Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?