ASR fails to generate with an 'ORA-31011: XML parsing failed ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245' error in RSA Identity Governance & Lifecycle
Originally Published: 2020-02-05
Article Number
Applies To
RSA Version/Condition: 7.1.0, 7.1.1, 7.2.0
Issue
NOTE: An ASR is generated by going to (Admin > Diagnostics > Create Report) or (Admin > System > Diagnostics tab > Create Report) depending on your version of RSA Identity Governance & Lifecycle.
The RSA Identity Governance & Lifecycle user interface (Admin > Diagnostics) shows all Statistics Reports with a status of Generating.
The aveksaServer.log file ($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log) has the following errors:
04/01/2019 00:09:40.900 INFO (SystemReport) [com.aveksa.server.db.persistence.PersistenceServiceProvider]
executeCallableStatement giving up after hitting SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
04/01/2019 00:09:40.902 WARN (SystemReport) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 31011, SQLState: 99999
04/01/2019 00:09:40.903 ERROR (SystemReport) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
04/01/2019 00:09:40.906 ERROR (SystemReport) [com.aveksa.server.system.SystemReport] ASR Params:
[Lcom.aveksa.server.db.ProcedureParameter;@5c98455f
com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1534)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1469)
at com.aveksa.server.db.PersistenceManager.runStoredProcedure(PersistenceManager.java:269)
at com.aveksa.server.system.SystemReport.backgroundGenerateReport(SystemReport.java:136)
at com.aveksa.server.system.SystemReport.access$000(SystemReport.java:53)
at com.aveksa.server.system.SystemReport$1.run(SystemReport.java:72)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:450)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:399)
at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1059)
at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:522)
at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:257)
at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:587)
at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:220)
at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:48)
at oracle.jdbc.driver.T4CCallableStatement.executeForRows(T4CCallableStatement.java:938)
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1150)
at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:4798)
at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:4901)
at oracle.jdbc.driver.OracleCallableStatement.execute(OracleCallableStatement.java:5631)
at oracle.jdbc.driver.OraclePreparedStatementWrapper.execute(OraclePreparedStatementWrapper.java:1385)
at org.jboss.jca.adapters.jdbc.WrappedPreparedStatement.execute(WrappedPreparedStatement.java:442)
at com.aveksa.server.db.persistence.work.PersistenceServiceBaseWork.executeCallableStatement(PersistenceServiceBaseWork.java:36)
at com.aveksa.server.db.persistence.work.StoredProcedureCallWork.execute(StoredProcedureCallWork.java:80)
at org.hibernate.jdbc.WorkExecutor.executeWork(WorkExecutor.java:37)
at org.hibernate.internal.SessionImpl$3.accept(SessionImpl.java:2134)
at org.hibernate.internal.SessionImpl$3.accept(SessionImpl.java:2131)
at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.coordinateWork(JdbcCoordinatorImpl.java:332)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2153)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2138)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1512) ... 6 more
04/01/2019 00:09:40.907 ERROR (SystemReport) [SystemErr] Exception in thread "SystemReport"
04/01/2019 00:09:40.924 ERROR (SystemReport) [SystemErr] java.lang.RuntimeException: com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
executeCallableStatement giving up after hitting SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
04/01/2019 00:09:40.902 WARN (SystemReport) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 31011, SQLState: 99999
04/01/2019 00:09:40.903 ERROR (SystemReport) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
04/01/2019 00:09:40.906 ERROR (SystemReport) [com.aveksa.server.system.SystemReport] ASR Params:
[Lcom.aveksa.server.db.ProcedureParameter;@5c98455f
com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1534)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1469)
at com.aveksa.server.db.PersistenceManager.runStoredProcedure(PersistenceManager.java:269)
at com.aveksa.server.system.SystemReport.backgroundGenerateReport(SystemReport.java:136)
at com.aveksa.server.system.SystemReport.access$000(SystemReport.java:53)
at com.aveksa.server.system.SystemReport$1.run(SystemReport.java:72)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:450)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:399)
at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1059)
at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:522)
at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:257)
at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:587)
at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:220)
at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:48)
at oracle.jdbc.driver.T4CCallableStatement.executeForRows(T4CCallableStatement.java:938)
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1150)
at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:4798)
at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:4901)
at oracle.jdbc.driver.OracleCallableStatement.execute(OracleCallableStatement.java:5631)
at oracle.jdbc.driver.OraclePreparedStatementWrapper.execute(OraclePreparedStatementWrapper.java:1385)
at org.jboss.jca.adapters.jdbc.WrappedPreparedStatement.execute(WrappedPreparedStatement.java:442)
at com.aveksa.server.db.persistence.work.PersistenceServiceBaseWork.executeCallableStatement(PersistenceServiceBaseWork.java:36)
at com.aveksa.server.db.persistence.work.StoredProcedureCallWork.execute(StoredProcedureCallWork.java:80)
at org.hibernate.jdbc.WorkExecutor.executeWork(WorkExecutor.java:37)
at org.hibernate.internal.SessionImpl$3.accept(SessionImpl.java:2134)
at org.hibernate.internal.SessionImpl$3.accept(SessionImpl.java:2131)
at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.coordinateWork(JdbcCoordinatorImpl.java:332)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2153)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2138)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1512) ... 6 more
04/01/2019 00:09:40.907 ERROR (SystemReport) [SystemErr] Exception in thread "SystemReport"
04/01/2019 00:09:40.924 ERROR (SystemReport) [SystemErr] java.lang.RuntimeException: com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-31011: XML parsing failed
ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245
ORA-06512: at line 1
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (Admin > System > Server Nodes tab > under Logs.)
Cause
Resolution
Workaround
Related Articles
Tables embedded in workflow email nodes are malformed after upgrading to version 7.1.1 of RSA Identity Governance & Lifecycle 88Number of Views RSA Authentication Manager 8.2 hardware appliance fails to reboot when patch or upgrade is applied 167Number of Views RSA Announces the Availability of RSA Governance & Lifecycle 8.0 Patch 09 6Number of Views AFX Server is in a 'Not running' State in the user interface but 'afx status' indicates AFX is running in RSA Identity Gov… 374Number of Views RSA Authentication Manager no longer connects to the RSA Cloud Access Service 46Number of Views
Trending Articles
Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update Authentication Manager How to Retrieve the LDAPS Certificate and Configure an External Identity Source to Use LDAPS
Don't see what you're looking for?