After successful Account data collection, Custom Account Integer Attribute value is not displaying under Accounts tab in RSA Identity Governance and Lifecycle
2 years ago
Originally Published: 2017-03-15
Article Number
000063550
Applies To
RSA Product Set: RSA Identity Governance and Lifecycle
RSA Version/Condition: 7.0
 
Issue
After successful Account data collection, Custom Account Integer Attribute value is not displaying under Accounts tab in RSA Identity Governance and Lifecycle.
 
User-added image

We can see them by clicking on the i icon of every account.
 
User-added image 

If we group by that attribute in the Accounts screen, then grouping is also successful.
User-added image
Cause
Custom Account Integer Attribute are defined with datatype Integer but at the time of retrieval from database as column length for CAI attribute in account table defined as NUMBER(38,0), it will considered value as BigDecimal, There is no handling for custom attribute having value as BigDecimal therefore it returns null value. 
Resolution
This issue is fixed in 7.0 P03, 7.0.1 and above versions.