Apache 2.x fails to start after configuring the RSA Authentication Agent 8.0 for Web for Apache
Originally Published: 2016-04-08
Last Modified: 2026-05-13
Article Number
Applies To
RSA Product/Service Type : Authentication Agent for Web for Apache
RSA Version/Condition: 8.0
Platform : Red Hat Enterprise Linux
O/S Version : 6.x
Issue
[Fri Apr 08 15:30:04.177613 2016] [:error] [pid 4064:tid 140189449340672] (20019)DSO load failed:
/usr/local/apache2/rsawebagent/librsawa_apache.so
Cause
In this example the library is called librsawa_apache.so. The output shows that libxerces-c-3.1.so was not found.
[root@redhat65 rsawebagent]# ldd librsawa_apache.so
linux-vdso.so.1 => (0x00007fff397ff000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x00007f2c9a077000)
libxerces-c-3.1.so => not found
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f2c99e59000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f2c99b53000)
libm.so.6 => /lib64/libm.so.6 (0x00007f2c998cf000)
libc.so.6 => /lib64/libc.so.6 (0x00007f2c9953a000)
/lib64/ld-linux-x86-64.so.2 (0x0000003997a00000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f2c99324000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x00007f2c9a077000)
libxerces-c-3.1.so => not found
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f2c99e59000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f2c99b53000)
libm.so.6 => /lib64/libm.so.6 (0x00007f2c998cf000)
libc.so.6 => /lib64/libc.so.6 (0x00007f2c9953a000)
/lib64/ld-linux-x86-64.so.2 (0x0000003997a00000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f2c99324000)
[root@redhat65 rsawebagent]#
Resolution
On page 18 of the RSA Authentication Agent 8.0 for Web for Apache Web Server Installation and Configuration Guide, step 11 states that a Linux environment variable must be set called LD_LIBRARY_PATH.
- Check the LD_LIBRARY_PATH environment variable has been set up correctly so the Apache 2.x web server can locate the library libxerces-c-3.1.so.
The library libxerces-c-3.1.so resides in the <APACHE_HOME>/rsawebagent folder.
- Restart the Apache 2.x web server and review the Apache error log for further messages.
Related Articles
RSA Governance & Lifecycle Exchange 2013 Connector Datasheet 23Number of Views RSA Governance & Lifecycle Exchange 2007 Connector Datasheet 15Number of Views Is the PAM Agent supported with Redhat 6.2 7Number of Views Announcement: End of Primary Support for RSA Authentication Agents for Microsoft IIS and Apache 124Number of Views Microsoft Exchange Management Console/PowerShell error with RSA Authentication Agent 8.0 for Web for IIS 81Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?