Authentication Manager version 8.5: Failed to register to the FedRamp - Govcloud Cloud Authentication Service
Originally Published: 2021-08-30
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.5.0
Platform: Linux
O/S Version: Suse Linux
Issue
ERROR: Failed to register to the Cloud Authentication Service
An unknown system error occurred.
===imsTrace.log===
2021-08-09 12:19:52,772, [[ACTIVE] ExecuteThread: '12' for queue: 'weblogic.kernel.Default (self-tuning)'], (RetriveRootCertificate.java:178), trace.com.rsa.authmgr.integration.via.internal.client.RetriveRootCertificate, FATAL, <primary_FQDN>,,,,Exception while retrieving the root certificate.
java.lang.RuntimeException: io.netty.channel.ConnectTimeoutException: connection timed out: access.securidgov.com/20.140.188.86:80
Connection to https://access.securidgov.com from AM Primary and Embedded IDR fails with
FATAL, <primary>.qnet.com,,,,Exception while retrieving the root certificate.
Connection timed out: access.securidgov.com/20.140.188.86:80
Cause
- Original, Non-FedRamp to https://access.securid.com supported since AM 8.3 P1
- Newer, FedRamp to https://access.securidgov.com which is CAS for Govcloud sites, supported in AM 8.5 P5 and AM 8.6 P1 or later.
Both connections are essentially the same, though they have slightly different Certificate Trust chains that must be included in an internal .jks key store by Engineering in a specific patch or version of Authentication Manager.
Typical registration failure messages are somewhat clear, like this: Invalid or expired registration code
But when you see unknown system error occurred
is the Security Console, and the /opt/rsa/am/server/logs/imsTrace.log shows
FATAL, <primary_FQDN>,,,,Exception while retrieving the root certificate.
java.lang.RuntimeException: io.netty.channel.ConnectTimeoutException: connection timed out: access.securidgov.com/20.140.188.86:80
The first thing to check is that you have AM 8.5 patch 5.
Resolution
AM-42355. Added support for the FedRAMP domain name securidgov.com to the embedded identity router.
You need AM 8.5 P5 or AM 8.6 P1 or later.
Notes
Related Articles
Error message when attempting to register on the RSA Community (The Salesforce record provisioning for the user failed wit… 18Number of Views Unable to register an RSA SecurID Access SSO application in the Cloud Administration Console 42Number of Views Initialization error "Unable to register service ReviewService" and "Unable to start local agent" in RSA Identity Governan… 374Number of Views Connection to Cloud Authentication service via Security Console fails with an error; ""Failed to register to the Cloud Aut… 486Number of Views Can you enforce DN uniqueness on KCA 14Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?