"BufferOverflowException" when attempting to authenticate to RSA Via Lifecycle and Governance console
Originally Published: 2016-09-20
Article Number
Applies To
RSA Version/Condition: 7.0
Issue
For users who have an existing session the console is unresponsive and although the menu's display if an item is selected the console shows Loading data... indefinitely.
The /home/oracle/wildfly-8.2.0.Final/standalone/log/aveksaServer.log shows the following exception.
08/13/2016 16:31:28.406 ERROR (default task-254) [com.aveksa.gui.core.MainManager]
java.nio.BufferOverflowException
at java.nio.DirectByteBuffer.put(DirectByteBuffer.java:357)
An AWR report may show queries associated with logon active at the time of the problem, specifically queries in the SecurityContext.csv file.
Cause
When a user logs in (i. e., authenticates) a query is done to build a cache to hold the resources the user is allowed to access. A lock is put on the cache at the start of the cache building process. This prevents other user authentications from proceeding until the previous users authentication cache building is complete. If multiple users are authenticating at the same time they will be blocked from completing their authentication and users with existing sessions will be blocked from access new menu items in the console.
Customers using a custom SecurityContext.csv file may be more prone to this problem if there are complicated queries in the file that are processed during authentication.
Resolution
A change has been made that only locks the cache for the specific user that is authenticating and allows other user sessions to continue while the authenticated users authentication cache is being constructed.
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