Cannot create token file error and unable to distribute RSA SecurID software token using any profile for RSA Authentication Manager 8.2 and higher
Originally Published: 2020-04-27
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
- Unable to distribute any RSA SecurID software token to any user, using any profile.
- Receiving the following error in the Security Console:
Cannot create token file.
Cause
- In the /opt/rsa/am/server/logs/imsConsoleTrace.log:
[[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'], (EJBRemoteTargetBase.java:187), trace.com.rsa.command.EJBRemoteTargetBase, ERROR, <SERVER_HOSTNAME>,,,,Exception during command execution. com.rsa.command.AuditedLocalizableSystemException: COMMAND_EXECUTION_UNEXPECTED_ERROR
Caused by: com.rsa.common.UnexpectedDataStoreException: org.postgresql.util.PSQLException: No value specified for parameter 3. Caused by: org.postgresql.util.PSQLException: No value specified for parameter 3.
at org.postgresql.core.v3.SimpleParameterList.checkAllParametersSet(SimpleParameterList.java:178)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:246)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:273)
at org.postgresql.core.v3.SimpleParameterList.checkAllParametersSet(SimpleParameterList.java:178)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:246)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:273)
- In the /opt/rsa/am/server/logs/biztier.log:
####<Apr 19, 2020 11:05:01 PM IST> <Critical> <EmbeddedLDAP> <HOSTNAME> <biztier> <[ACTIVE] ExecuteThread: '5' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1587333901189> <BEA-000000> <java.io.FileNotFoundException: /opt/rsa/am/server/servers/biztier/data/ldap/ldapfiles/EmbeddedLDAP.index (Too many open files)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:146) at java.io.FileInputStream.<init>(FileInputStream.java:101)
at com.octetstring.vde.backend.standard.BackupTask.writeFile(BackupTask.java:86)
at com.octetstring.vde.backend.standard.BackupTask.runTask(BackupTask.java:60)
at com.octetstring.vde.util.TimedActivityThread.runOnDemand(TimedActivityThread.java:76)
at weblogic.ldap.EmbeddedLDAP$EmbeddedLDAPTimedActivity.timerExpired(EmbeddedLDAP.java:1165)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:304)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:553)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311) at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)
at com.octetstring.vde.util.TimedActivityThread.runOnDemand(TimedActivityThread.java:76)
at weblogic.ldap.EmbeddedLDAP$EmbeddedLDAPTimedActivity.timerExpired(EmbeddedLDAP.java:1165)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:304)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:553)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311) at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)
Resolution
- Reboot the primary RSA Authentication Manager server.
- Increase the memory on the RSA Authentication Manager server.
Related Articles
aservers occasionally are unable to decrypt tokens from other aservers. 21Number of Views Unable to load bean named CTKIPServerService when importing a token via CTKIP to RSA SecurID Software Token 706Number of Views Unable to activate virtual host certificate; RSA Authentication Manager is unable to activate your selected certificate at… 121Number of Views Unable to see orgs after in place upgrade from 5.7.3 to 6.0.2.1 SP2 15Number of Views Unable to restart the RSA Authentication Manager services 150Number of Views
Trending Articles
Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update Authentication Manager How to Retrieve the LDAPS Certificate and Configure an External Identity Source to Use LDAPS
Don't see what you're looking for?