Cannot create token file error and unable to distribute RSA SecurID software token using any profile for RSA Authentication Manager 8.2 and higher
Originally Published: 2020-04-27
Last Modified: 2026-04-15
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
- Unable to distribute any RSA SecurID software token to any user, using any profile.
- Receiving the following error in the Security Console:
Cannot create token file.
Cause
- In the /opt/rsa/am/server/logs/imsConsoleTrace.log:
[[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'], (EJBRemoteTargetBase.java:187), trace.com.rsa.command.EJBRemoteTargetBase, ERROR, <SERVER_HOSTNAME>,,,,Exception during command execution. com.rsa.command.AuditedLocalizableSystemException: COMMAND_EXECUTION_UNEXPECTED_ERROR
Caused by: com.rsa.common.UnexpectedDataStoreException: org.postgresql.util.PSQLException: No value specified for parameter 3. Caused by: org.postgresql.util.PSQLException: No value specified for parameter 3.
at org.postgresql.core.v3.SimpleParameterList.checkAllParametersSet(SimpleParameterList.java:178)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:246)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:273)
at org.postgresql.core.v3.SimpleParameterList.checkAllParametersSet(SimpleParameterList.java:178)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:246)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:273)
- In the /opt/rsa/am/server/logs/biztier.log:
####<Apr 19, 2020 11:05:01 PM IST> <Critical> <EmbeddedLDAP> <HOSTNAME> <biztier> <[ACTIVE] ExecuteThread: '5' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1587333901189> <BEA-000000> <java.io.FileNotFoundException: /opt/rsa/am/server/servers/biztier/data/ldap/ldapfiles/EmbeddedLDAP.index (Too many open files)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:146) at java.io.FileInputStream.<init>(FileInputStream.java:101)
at com.octetstring.vde.backend.standard.BackupTask.writeFile(BackupTask.java:86)
at com.octetstring.vde.backend.standard.BackupTask.runTask(BackupTask.java:60)
at com.octetstring.vde.util.TimedActivityThread.runOnDemand(TimedActivityThread.java:76)
at weblogic.ldap.EmbeddedLDAP$EmbeddedLDAPTimedActivity.timerExpired(EmbeddedLDAP.java:1165)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:304)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:553)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311) at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)
at com.octetstring.vde.util.TimedActivityThread.runOnDemand(TimedActivityThread.java:76)
at weblogic.ldap.EmbeddedLDAP$EmbeddedLDAPTimedActivity.timerExpired(EmbeddedLDAP.java:1165)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:304)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:553)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311) at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)
Resolution
- Reboot the primary RSA Authentication Manager server.
- Increase the memory on the RSA Authentication Manager server.
Related Articles
Choose the Priority of Agent or User RADIUS Profiles 5Number of Views Assign and Distribute a Software Token to a User Using Dynamic Seed Provisioning in the User Dashboard 98Number of Views Unable to load bean named CTKIPServerService when importing a token via CTKIP to RSA SecurID Software Token 722Number of Views aservers occasionally are unable to decrypt tokens from other aservers. 22Number of Views Unable to activate virtual host certificate; RSA Authentication Manager is unable to activate your selected certificate at… 124Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?