Collect Prime logs and Configuration files using the collect script
Last Modified: 2024-12-20
Article Number
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: RSA Authentication Manager Prime Kit, HDAP
RSA Product/Service Type: RSA Authentication Manager Prime Kit, AMIS
RSA Product/Service Type: RSA Authentication Manager Prime Kit, SSP
Issue
We need to gather the configurations and the Logs of the prime server and we have 2 scripts to make the process easy for customers
Resolution
- We need to confirm that the logs are set on Debug level.
- On Linux:
- Under these folders:
- /opt/rsa/primekit/configs/amis/tomcat-amis "Only available for internal Prime servers"
- /opt/rsa/primekit/configs/hdap/tomcat-hdap "On;y available for Internal Prime servers"
- /opt/rsa/primekit/configs/ssp/tomcat-ssp
- Check this line inside config.sh inside each directory of those:
export CATALINA_OPTS="$CATALINA_OPTS '-Dlog.level=DEBUG'" - If it says anything other than DEBUG change it and save then you will have to restart the tomcat services.
- Under these folders:
- On Windows:
- Run the Following exe files:
- C:\RSA\primekit\configs\amis\tomcat-amis\tomcat-amisw "Only available for internal prime servers"
- C:\RSA\primekit\configs\hdap\tomcat-hdap\tomcat-hdapw "Only available for internal prime servers"
- C:\RSA\primekit\configs\ssp\tomcat-ssp\tomcat-ssp
- Inside the window that appears go to Java.
- Check this line in Java options:
- -Dlog.level=DEBUG
- If it is anything other than DEBUG change it then save and restart the tomcat services.
- Run the Following exe files:
- On Linux:
- Use the scripts configured to collect the logs and the configurations:
- For Linux:
- run: /opt/rsa/primekit/scripts/tools/gather_configs.sh
- run: /opt/rsa/primekit/scripts/tools/gather_logs.sh
- The output for both will be stored under /tmp download it and provide it to RSA Support.
- For Windows:
- Go to C:\RSA\primekit\scripts\tools
- Run gather_logs and gather_configs
- The output will be stored under C:\Users\ADMINI~1\AppData\Local\Temp\2
- Collect it and provide it to RSA Support.
- For Linux:
Notes
In case you faced any issues you can collect the logs manually with guidance from this article:
https://community.rsa.com/s/article/a67930-What-logs-to-collect-to-trouble-shoot-AM-Prime
Related Articles
Prime kit tomcat.pid: Permission denied error when restarting services for RSA Authentication Manager Prime Kit 107Number of Views RSA Authentication Manager Prime throws "Node secret mismatch: cleared on server but not on agent" despite repeated cleari… 540Number of Views Authentication Manager Prime: SSP Keystore Import Fails with "Failed to Establish Chain from Reply" 1.39KNumber of Views Login failed because of unexpected error after upgrading to RSA SecurID Access PrimeKit 12172019 on Windows 41Number of Views Mandatory Update: DigiCert Certificate Configuration for RSA Prime (Required by October 06, 2025 for Cloud Access Service … 125Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?