Database Statistics running after every collection in RSA Identity Governance & Lifecycle
Originally Published: 2021-11-08
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.2.1, 7.5.0
Issue
- Database Statistics against T_AV_EXPLODEDUSERENTITLEMENTS table are running after every collection in RSA Identity Governance & Lifecycle.
- Collections are slow in Step 11/12 Relationship Processing: Update Statistics.
- AWR reports show a query similar to the following running for a long time:
/* SQL Analyze(0) */ select /*+ full(t) parallel(t, 5) parallel_index(t, 5) dbms_stats cursor_sharing_exact use_weak_name_resl dynamic_sampling(0) no_monitoring xmlindex_sel_idx_tbl opt_param('optimizer_inmemory_aware' 'false') no_substrb_pad */to_char(count("ID")), substrb(dump(min("ID"), 16, 0, 64), 1, 240), substrb(dump(max("ID"), 16, 0, 64), 1, 240), to_char(count("RUN_ID")), substrb(dump(min("RUN_ID"), 16, 0, 64), 1, 240), substrb(dump(max("RUN_ID"), 16, 0, 64), 1, 240), to_char(count("DC_ID")), substrb(dump(min("DC_ID"), 16, 0, 64), 1, 240), substrb(dump(max("DC_ID"), 16, 0, 64), 1, 240), to_char(count("APPLICATION_ID")), substrb(dump(min("APPLICATION_ID"), 16, 0, 64), 1, 240), substrb(dump(max("APPLICATION_ID"), 16, 0, 64), ETC....Cause
This issue may occur on systems where the T_AV_EXPLODEDUSERENTITLEMENTS table is very large. Normally database statistics is run on this table after each collection. In some instances, the cost of this run may be more than the benefit.
Resolution
- RSA Identity Governance & Lifecycle 7.2.1 P04
- RSA Identity Governance & Lifecycle 7.5.0
After patching to the version where this is resolved, set the following parameter from Admin > System > Settings > Custom section. When this parameter is set, the Database Statistics will only run on the T_AV_EXPLODEDUSERENTITLEMENTS table if more than 5% of the table has changed.
| Parameter | Value |
| CollectorStatsConditional | True |
Related Articles
Apply error 'ORA-01403: no data found' occurring on all clusters every 15 minutes 120Number of Views I1912 - The SEL is full of events and is unable to log any more 12Number of Views java.sql.SQLSyntaxErrorException: ORA-00932: inconsistent datatypes: expected - got NCLOB in RSA Identity Governance & Lif… 101Number of Views Unification slow and identity collections show users in reprocessed state in RSA Identity Governance & Lifecycle 72Number of Views Remote collection agents fail after installing JRE/JDK 1.7.0_191+ or 1.8.0_181+ in RSA Identity Governance & Lifecycle 363Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?