Dynamic seed provisioning fails after replica promotion
Originally Published: 2020-09-21
Last Modified: 2023-09-22
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.4.0
Platform: null
Platform (Other): null
O/S Version: null
Product Name: null
Product Description: null
Issue
[[ACTIVE] ExecuteThread: '6' for queue: 'weblogic.kernel.Default (self-tuning)'], (EJBRemoteTarget.java:316), trace.com.rsa.command.EJBRemoteTargetBase, ERROR, amprimary.example.com,,,,Unable to connect to downgraded EJB/2.1 command server.Failed to initialize JNDI context, tried 2 time or times totally, the interval of each time is 0ms.
t3s://amprimary.example.com:7022: Destination X.X.X.X, 7022 unreachable.; nested exception is:
java.net.ConnectException: Connection refused (Connection refused); No available router to destination.; nested exception is:
java.rmi.ConnectException: No available router to destination.
[[ACTIVE] ExecuteThread: '6' for queue: 'weblogic.kernel.Default (self-tuning)'], (CtkipMessageProcessorBindingImpl.java:74), trace.authmgr.internal.ctkip.ws.CtkipMessageProcessorBindingImpl, ERROR, amprimary.example.com,,,,The CT-KIP Web Service failed to process a client request. com.rsa.common.SystemException: Failed to connect with command server
Cause
Resolution
1-SSH to the primary appliance 2-cd /opt/rsa/am/utils/resources
Take a backup of the current file
3-cp ims.properties ims.properties.backup
4- vim ims.properites
Check if the ims.ssl.client.primary.provider.url is set to the current primary if not change the value to be equal to the current primary like this
ims.ssl.client.primary.provider.url=t3s\://am83p.vcloud.local\:7022Afterward restart all services
5-/opt/rsa/am/server/rsaserv restart allCtkip should function correctly now and be served form the current primary
Related Articles
How to disable Ping Internet Control Message Protocol (ICMP) reply on RSA Authentication Manager 8.1 55Number of Views Promotion of a RSA Authentication Manager 8.1 replica fails 564Number of Views How to connect an existing Web Tier to a newly promoted Primary 62Number of Views Error: 'Rep name in DB doesn't match host' appears in application log 5Number of Views RSA Authentication Manager replica instance fails to attach to the Authentication Manager deployment 458Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?