Promotion of a RSA Authentication Manager 8.1 replica fails
Originally Published: 2015-01-07
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: RSA Authentication Manager
RSA Version/Condition: 8.1 patch 5
Issue
The following errors are in the Planned-Promotion-Precheck-<datestamp>.log:
ERROR: The Operations Console on the primary instance is not reachable to check replication status or reachability with other replica instances.
ERROR: Could not access HTTP invoker remote service at [https://myprimary_server_host_name. domain_name.com:7072/operations-console/dispatcher/HttpInvokerPlannedPromotion]; nested exception is org.apache.commons.httpclient.ConnectTimeoutException: The host did not accept the connection within timeout of 20000 ms
The following errors are in am/server/logs/ops-console.log:
@@@2014-10-02 14:36:21,948 ERROR [PlannedPromoteReplicaPrereqCheck] GUILog.traceException(587) | exception:
com.rsa.ims.operationsconsole.admin.taskmgr.TaskExecutionException: Error in checking primary instance healthy status:
at com.rsa.ims.operationsconsole.admin.promote.planned.tasks.CheckOriginalPrimaryHealthyTask.execute(CheckOriginalPrimaryHealthyTask.java:160)
at com.rsa.ims.operationsconsole.admin.taskmgr.TaskManager.executeTasks(TaskManager.java:42)
at com.rsa.ims.operationsconsole.admin.impl.OCManageReplicationImpl$1PlannedPromotePrereqCheckSiteThread.run(OCManageReplicationImpl.java:1101)
at java.lang.Thread.run(Thread.java:680)
Caused by: org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://ma05ace02.rc4ss.com:7072/operations-console/dispatcher/HttpInvokerPlannedPromotion]; nested exception is org.apache.commons.httpclient.ConnectTimeoutException: The host did not accept the connection within timeout of 20000 ms
at orgCause
ERROR: The Operations Console on the primary instance is not reachable to check replication status or reachability with other replica instances.
Promotion activity on a replica, tries to connect to the primary's Operations Console and checks the following:
- To verify replication status and reachability.
- To make sure that there are nobackups scheduled at the time of promotion.
- To make sure that there are no conflicting operations currently in progress.
Resolution
Open port 7072 in addition to other ports described on page 96 of RSA Authentication Manager 8.1 SP1 Setup and Configuration Guide.
Related Articles
Dynamic seed provisioning fails after replica promotion 120Number of Views Replica promotion for maintenance fails with certificate not verified error in RSA Authentication Manager 8.x 824Number of Views Promote a Replica Instance Using Promotion for Maintenance 506Number of Views Promotion for maintenance fails: Unable to apply the data updates from the primary instance 352Number of Views Promotion for Maintenance 133Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?