Error "No such file or directory while trying to open /dev/disk/by-id/scsi-XXXX-part1" and services do not start on RSA SecurID Appliance 8.x
Originally Published: 2019-08-05
Last Modified: 2023-11-30
Article Number
Applies To
RSA Product/Service Type: Hardware Appliance
RSA Version/Condition: 8.x
Issue
Checking file systems...
Fsck from util-linux 2.19.1
fsck.ext3: No such file or directory while trying to open /dev/disk/by-id/scsi-36001e6788a5ef0001ae06e8b07057174-part1
/dev/disk/by-id/scsi-36001e6788a5ef0001ae06e8b07057174-part1:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>Cause
- RAID foreign configuration was imported on SecurID Hardware Appliance
- Operating System configuration files were backed up and restored from one appliance to the another
Resolution
- Launch an SSH client, such as PuTTY.
- Login to the primary Authentication Manager server as rsaadmin and enter the operating system password.
- Reboot the appliance through the command line.
- Enter Single User Mode using the steps in one of the following article according to your Authentication Manager version:
- How to reset the OS user password for RSA Authentication Manager 8.1 through 8.4 (Steps 1-5)
- How to reset the rsaadmin command line password for RSA Authentication Manager 8.4 and up (Steps 1-8)
- Once you are booted into Single User Mode, mount the filesystem:
mount -o remount,rw /
- Take a backup of /etc/fstab:
cp /etc/fstab /etc/fstab.bak
- Open /etc/fstab using a text editor.
- Find the mount point the error message references:
tmpfs /run tmpfs noauto 0 0 /dev/systemVG/LVRoot / ext3 defaults 1 1 /dev/disk/by-id/scsi-36001e6788a5ef0001ae06e8b07057174-part1 /boot ext3 defaults 1 2 /dev/systemVG/LVSwap swap swap defaults 0 0
- Press i to enter Insert mode.
- Change the entry to use the disk name instead of disk id:
tmpfs /run tmpfs noauto 0 0 /dev/systemVG/LVRoot / ext3 defaults 1 1 /dev/sda1 /boot ext3 defaults 1 2 /dev/systemVG/LVSwap swap swap defaults 0 0
- Press Esc to exit Insert mode.
- Type :wq! and press Enter to save and exit.
- Reboot using one of the following commands:
/sbin/reboot /sbin/init 6 exec /sbin/init 6
Related Articles
How to minimally test IMG WebService commands in RSA IMG 226Number of Views RSA Identity Management and Governance DB logs, task results, task progress are not available on run details of collection… 128Number of Views Failed to open remote console in RSA AM8 Appliance BCM Web Console 6Number of Views Error "No input source supplied to the exporter" occurs when attempting to view an archived report in RSA Identity Governa… 45Number of Views RSA Authentication Manager 8.x running on Hyper V enters maintenance mode. Failed to start file system check on /dev/dis..… 312Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?