Error message "java.security.InvalidKeyException: Illegal key size" in RSA Data Loss Prevention Enterprise Manager
Originally Published: 2015-10-02
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Enterprise Manager
Platform: Windows Server 2008R2/2012
Issue
- The Enterprise Coordinator can't communicate with the Enterprise Manager.
- The Root Endpoint Coordinator can't communicate with the Enterprise Manager.
- The following errors are seen:
29 Sep 2015 16:16:06,593 | ERROR - HttpChannel.sendViaClient(144) | javax.net.ssl.SSLException: java.security.InvalidKeyException: Illegal key size
29 Sep 2015 16:16:06,593 | ERROR - PrivateConnectorClientServiceImpl.logTransmissionError(232) | FunctionalFlow - alert config Unable to transmit alert config to web service endpoint rsadlpec.xxxxxxx.xxxxx.com. Reason is Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.
29 Sep 2015 16:16:06,593 | ERROR - LoggingAsynchronousExceptionListener.onEvent(39) | Asynchronous exception occurred processing event continuation: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.
29 Sep 2015 16:16:06,593 | ERROR - EMApplicationEventMulticaster$1.run(180) | Unexpected exception occurred during event processing: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.; job is recoverable and will be retried
29 Sep 2015 16:16:06,593 | ERROR - PrivateConnectorClientServiceImpl.logTransmissionError(232) | FunctionalFlow - alert config Unable to transmit alert config to web service endpoint rsadlpec.xxxxxxx.xxxxx.com. Reason is Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.
29 Sep 2015 16:16:06,593 | ERROR - LoggingAsynchronousExceptionListener.onEvent(39) | Asynchronous exception occurred processing event continuation: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.
29 Sep 2015 16:16:06,593 | ERROR - EMApplicationEventMulticaster$1.run(180) | Unexpected exception occurred during event processing: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Couldn't send message.; job is recoverable and will be retried
Cause
Resolution
- Download the updated local_policy.jar and US_export_policy.jar files from Oracle Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files 7 Download page.
- Move the two files of that name that are in C:\Program Files\Java\jre1.7.0_25\lib\security to a backup folder.
- Replace the files with the unlimited local_policy.jar and the US_export_policy.jar files downloaded from the Oracle website.
- Restart the EM service.
Related Articles
Is RSA Mobile multi-threaded? 2Number of Views Error message "Asynchronous exception occurred processing event continuation" is reported in RSA Data Loss Prevention 29Number of Views RSA Identity Governance and Lifecycle 7.1.0.4 Release Notes 23Number of Views RSA Identity Management and Governance 6.9.1 P12 Active Directory Identity Data Collector (IDC) collection fails with "Unp… 89Number of Views RSA Identity Governance and Lifecycle 7.1.0.8 Release Notes 112Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?