FIM error "The provided SP entity ID is null"
Originally Published: 2015-01-07
Last Modified: 2022-06-20
Article Number
000066583
Applies To
RSA Product Set: FIM
RSA Product/Service Type: Federated Identity Management Module
RSA Version/Condition: 4.1
Platform: Linux
Platform (Other): null
O/S Version: Red Hat Linux 6.2
Product Name: null
Product Description: null
Issue
FIM throws the error "The provided SP entity ID is null" when processing a WSFed authentication request.

2015-01-05 12:05:15,431, (SSOHelper.java:624), fim1, , , , Unable to process the AuthnRequest message, com.rsa.fim.profile.sso.SSOProfileException: The provided SP entity ID is null
Resolution
This error message indicates the request is not a valid SAML 2.0 request.   Ensure that you are using the correct WSFed endpoint for your entity.  SAML 2.0 and WSFed use different endpoints.   The default endpoint for SAML 2.0 is /SSO/sso/, the default endpoint for WSFed is /federation/WSFEDfederation.   This error occurs if a WSFed request is incorrectly sent to a SAML 2.0 endpoint.