How to fix error "-bash: /usr/bin/Check_Instance_Running.sh: /bin/ksh: bad interpreter: No such file or directory" while installing RSA Identity Governance and Lifecycle
Originally Published: 2017-10-05
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: 7.0.0+
Issue
[Fri Oct 6 18:15:53 CEST 2017] Start Wildfly to configure and load ear
-bash: /usr/bin/Check_Instance_Running.sh: /bin/ksh: bad interpreter: No such file or directory
Fresh install failed.. deleting /home/oracle/install, /home/oracle/Aveksa_System.cfg and /home/oracle/setDeployEnv.sh as part of cleanup.
Step failed! See /tmp/aveksa-install.log for more information.
Cause
1. You do not have ksh installed on the OS or the ksh shell (/bin/ksh or /usr/bin/ksh) is owned by a user other than root,or
2. It was removed from /bin or /usr/bin/ directory, or
3. The symbolic link was broken (ksh -> /bin/ksh93).
Resolution
- Login as root user and run the below commands to check if the ksh is installed.
rpm -qa | grep ksh
- If there is no output for this command, it indicates there is no ksh in the operating system.
- Download the supported ksh file for the OS (RedHat or SuSE) online and place the file in /tmp directory.
- Run the below command to install the ksh in the system.
rpm -ivh ksh-<version>.rpm
- Replace the <version> field with the version of the downloaded ksh script file.
- Once the ksh is installed, run the command in the first step to confirm ksh is present in the operating system.
- Uninstall RSA Identity Governance and Lifecycle and start a fresh installation with the steps mentioned in the Installation guide.
Related Articles
Executing the RSA Identity Governance and Lifecycle patch.sh script fails with "No such file or directory" error 126Number of Views How to customize the application using customizeACM.sh in RSA Identity Governance & Lifecycle 354Number of Views 'java.io.FileNotFoundException: aveksa-version.properties' error running migrate.sh in RSA Identity Governance & Lifecycle 165Number of Views 'java.io.FileNotFoundException: aveksa-version.properties' error running createSchema.sh in RSA Identity Governance & Life… 172Number of Views Error "This field cannot exceed 4000 characters" is received when adding membership rule in a Role in RSA Identity Governa… 9Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?