Installation fails with 'unzip: cannot find zipfile directory in one of /tmp/aveksa/packages/<filename.zip>' error in RSA Identity Governance & Lifecycle
2 years ago
Originally Published: 2015-03-19
Article Number
000060138
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: All
 
Issue
An RSA Identity Governance & Lifecycle installation fails with the following error:
 
unzip: cannot find zipfile directory in one of: tmp/aveksa/packages/<filename>.zip, or /tmp/aveksa/packages/<filename>.zip.zip, and cannot find /tmp/aveksa/packages/<filename>.zip.ZIP.

The zip file exists on the disk but the operating system cannot find it.

The aveksa installation log (/tmp/aveksa-install.log) has the following error:
Shutting down ntpd: [60G[[0;31mFAILED[0;39m]
Shutting down ntpd: [60G[[0;31mFAILED[0;39m]
Expand the Oracle Installers...
Check the System Configuration...
Archive:  /tmp/aveksa/packages/<filename>.zip
Oracle environment check has found a problem which does not have an automated fix
Check /tmp/aveksa-install.log for details on problem ... cancelling install

Manually attempting to unzip the file results in the same error.
 
Cause
The zip file is corrupt and cannot be unpacked.
 
Resolution
The resolution is to
  1. Re-download the zip file along with the checksum verification file and verify the checksum using one of the following utilities:
  • On Windows: File Checksum Integrity Verifier (FCIV) 
  • On Linux: md5sum <path><filename>
  1. Calculate the checksum and compare with the downloaded checksum file.
  2. Run the installation again.