Installation of RSA Identity Governance and Lifecycle 7.0.1 P03 fails with a groovy error
Originally Published: 2017-05-25
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Appliance
RSA Version/Condition: 7.0.1
Issue
Wildfly is running Repackaging the aveksa.war and aveksa.ear Archive name is: aveksa_7.0.1_116052_P03-2017-May-19-12.26.ear Creating aveksa.ear file for deployment Exception while building deployment ear file. Caught: groovy.lang.MissingPropertyException: No such property: ARCHIVE_DIR$ for class: CustomizeACM groovy.lang.MissingPropertyException: No such property: ARCHIVE_DIR$ for class: CustomizeACM at CustomizeACM.deploy(CustomizeACM.groovy:366) at CustomizeACM.run(CustomizeACM.groovy:100) An error occured in the customizeACM command : error code 1 Newly patched ear file has now been deployed to Application Server
Please note that this error does not show on the command line output. The command line output implies there was no error, but no ear with the patch is deployed.
Cause
Resolution
The patch installation will use the CURRENTLY_DEPLOYED_ARCHIVE from /home/oracle/deploy/wildfly_deployment.properties.
You can force the redeploy of the INITIAL_ARCHIVE in the same file.
Workaround
- Navigate to /home/oracle/deploy.
- Run the customizeACM.sh.
cd /home/oracle/deploy
customizeACM.sh -c /home/oracle/archive/aveksa_7.0.1_116052-2017-Jan-25-13.16.ear
(which was the INITIAL_ARCHIVE)
Customization dir being cleaned: /tmp/customizeACM
Unzipping aveksa.war and aveksa.ear
[unzip] Expanding: /home/oracle/archive/aveksa_7.0.1_116052-2017-Jan-25-13.16.ear into /tmp/customizeACM
Ready for customization. Please go to /tmp/customizeACM to continue modifications.
- Then redeploy:
customizeACM.sh -d
- Then reinstall the patch.
Related Articles
SSOLogin=false no longer works after upgrade to 7.0.2 from 7.0.0 P03 RSA Identity Governance & Lifecycle 18Number of Views Custom Account Attribute mapped to the Active Directory accountExpires attribute no longer collects a value after upgradin… 102Number of Views In RSA Identity Governance & Lifecycle, the change request manual activity assignment link (Assign to Specific Group or Ro… 19Number of Views RSA Announces End of Primary Support for RSA Authentication Manager 8.2 Service Pack 1 and a Direct Upgrade to Version 8.5 85Number of Views Create list of users who have not logged into RSA Authentication Manager 8.x for a specific period of days 123Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?