Installer prerequisite fails on files that are not relevant to the RSA Governance & Lifecycle deployment
Originally Published: 2018-03-30
Last Modified: 2023-12-01
Article Number
Applies To
RSA Version: 7.1
Issue
There are several scenarios that can occur:
When choosing to install using a remote database, you fail on missing the local database installation files.
-------------------------------------------------------------
Pre-Requisites Test(s) failed with the following message(s) :
Could not find necessary package instantclient-basiclite-linux.x64-12.1.0.2.0.zip in /tmp/aveksa/packages
-------------------------------------------------------------
Quitting installation due to system does not meet requirements
Fresh install failed.. deleting /home/oracle/install, /home/oracle/Aveksa_System.cfg and /home/oracle/setDeployEnv.sh as part of cleanup.
Step failed! See /tmp/aveksa-install.log for more information.
The asmlib is required on non-hardware appliance installations
-------------------------------------------------------------
Pre-Requisites Test(s) failed with the following message(s) :
Could not find necessary package asmlib-008_x64.tar.bz2 in /tmp/aveksa/packages
-------------------------------------------------------------
Quitting installation due to system does not meet requirements
Fresh install failed.. deleting /home/oracle/install, /home/oracle/Aveksa_System.cfg and /home/oracle/setDeployEnv.sh as part of cleanup.
Step failed! See /tmp/aveksa-install.log for more information.
There is a Red Hat RPM reported as missing when installing on SUSE Linux.
-------------------------------------------------------------
Pre-Requisites Test(s) failed with the following message(s) :
Could not find necessary package redhat-release-6Server-1.noarch.rpm in /tmp/aveksa/packages
-------------------------------------------------------------
Quitting installation due to system does not meet requirements
Fresh install failed.. deleting /home/oracle/install, /home/oracle/Aveksa_System.cfg and /home/oracle/setDeployEnv.sh as part of cleanup.
Step failed! See /tmp/aveksa-install.log for more information.Cause
Resolution
Workaround
Here are the commands to run for each scenario:
Remote database with RSA Governance & Lifecycle on Red Hat
touch /tmp/aveksa/packages/asmlib-008_x64.tar.bz2 touch /tmp/aveksa/packages/cvupack_Linux_x86_64.zip touch /tmp/aveksa/packages/linuxamd64_12102_database_1of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_database_2of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_grid_1of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_grid_2of2.zip touch /tmp/aveksa/packages/oracle_12.1.0.2_patches_v001.zip
Remote database with RSA Governance & Lifecycle on SUSE
touch /tmp/aveksa/packages/asmlib-008_x64.tar.bz2 touch /tmp/aveksa/packages/cvupack_Linux_x86_64.zip touch /tmp/aveksa/packages/linuxamd64_12102_database_1of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_database_2of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_grid_1of2.zip touch /tmp/aveksa/packages/linuxamd64_12102_grid_2of2.zip touch /tmp/aveksa/packages/oracle_12.1.0.2_patches_v001.zip touch /tmp/aveksa/packages/redhat-release-6Server-1.noarch.rpm
Local database of RSA Governance & Lifecycle on SUSE non-hardware appliance
touch /tmp/aveksa/packages/asmlib-008_x64.tar.bz2 touch /tmp/aveksa/packages/instantclient-basiclite-linux.x64-12.1.0.2.0.zip touch /tmp/aveksa/packages/instantclient-sqlplus-linux.x64-12.1.0.2.0.zip touch /tmp/aveksa/packages/redhat-release-6Server-1.noarch.rpm
Local database of RSA Governance & Lifecycle on SUSE hardware appliance
touch /tmp/aveksa/packages/instantclient-basiclite-linux.x64-12.1.0.2.0.zip touch /tmp/aveksa/packages/instantclient-sqlplus-linux.x64-12.1.0.2.0.zip touch /tmp/aveksa/packages/redhat-release-6Server-1.noarch.rpm
After the zero byte files exist under /tmp/aveksa/packages, our installer should progress on to installing the components that are relevant to your choices.
Related Articles
All change requests are stalled or in open state in RSA Identity Governance and Lifecycle 86Number of Views Envision: Why are we writing to the master database when collecting Microsoft SQL database logs 21Number of Views Monitoring scripts delayed when sent to remote syslog 27Number of Views How to configure which events the Logging Server records 10Number of Views Import of AFX Connectors fails with 'Connector Install Failure' in RSA Identity Governance & Lifecycle 62Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?