Login fails with an 'Internal Server Error' when using SiteMinder SSO to log into RSA Identity Governance & Lifecycle
Originally Published: 2017-05-01
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Appliance
RSA Version/Condition: All
Platform: Red Hat
Issue
Internal Server Error:
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.3 (Red Hat) Server at <hostname> port 80
Analysis:
- RSA Identity Governance & Lifecycle is accessible by directly logging into the server with:
https://<hostname>/aveksa/main
- There are no errors in the server.log or the aveksaServer.log.
- /etc/sysconfig/iptables has the correct settings.
- SiteMinder is used for SSO login.
- The SiteMinder log file located in /var/log/httpd/error_log is full of these errors:
[30/Apr/2017:04:02:27] [Error] [CA WebAgent IPC] [3505] [CSmSem::SemWait]
Error performing decrement operation on semaphore 19267598 - Invalid argument (22)
[30/Apr/2017:04:02:27] [Info] [CA WebAgent IPC] [3505] [CSmSem::getSem]
Attempted to attach to non-existent semaphore with key 0x6690874a
[30/Apr/2017:04:02:27] [Error] [CA WebAgent IPC] [3505] [CSmNamedMutex::Lock]
Error reinitializing mutex with key base 0x66
[30/Apr/2017:04:02:27] [Error] [CA WebAgent IPC] [3505] [CSmSem::SemWait]
Error performing decrement operation on semaphore 19070984 - Invalid argument (22)
[30/Apr/2017:04:02:27] [Info] [CA WebAgent IPC] [3505] [CSmSem::getSem]
Attempted to attach to non-existent semaphore with key 0x6b90874a
[30/Apr/2017:04:02:27] [Error] [CA WebAgent IPC] [3505] [CSmNamedMutex::Lock]
Error reinitializing mutex with key base 0x6b
[30/Apr/2017:04:02:27] [Error] SiteMinder Agent
PID Cache error.
Failed to read PID Cache
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment.
Cause
Resolution
For further root cause analysis and/or to determine other ways to rectify this issue, please contact your SiteMinder vendor as this is a third party product that we neither license nor deploy.
Workaround
Related Articles
Troubleshoot 'User is not enrolled for identity confirmation methods' error 47Number of Views Salesforce Experience Cloud - SAML Relying Party Configuration - RSA Ready Implementation Guide 18Number of Views Identity Confirmation questions not displayed for RSA Via Lifecycle & Governance while using external password reset 49Number of Views Review Refresh fails with 'ORA-00607 Internal error while making a change to a data block' in RSA Identity Governance & Li… 107Number of Views Disable the RSA Token "Run As Administrator" requirement 46Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?