Prime kit tomcat.pid: Permission denied error when restarting services for RSA Authentication Manager Prime Kit
Originally Published: 2020-06-04
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: RSA Authentication Manager Prime Kit
Platform: Linux
Issue
/opt/rsa/primekit/tomcat/tomcat-ssp/bin/tomcat.pid: Permission denied
/opt/rsa/primekit/tomcat/tomcat-hdap/bin/tomcat.pid: Permission denied
/opt/rsa/primekit/tomcat/tomcat-amis/bin/tomcat.pid: Permission deniedCause
- /opt/rsa/primekit/tomcat/tomcat-ssp/bin/
- /opt/rsa/primekit/tomcat/tomcat-hdap/bin/
- /opt/rsa/primekit/tomcat/tomcat-amis/bin/
Resolution
- Use SSH to access the RSA Authentication Manager Prime Kit server.
- Run the following command against the directory corresponding to the service with which you are facing the issue.
- For SSP:
chmod -R 777 /opt/rsa/primekit/tomcat/tomcat-ssp/bin/
- For HDAP:
chmod -R 777 /opt/rsa/primekit/tomcat/tomcat-hdap/bin/
- For AMIS:
chmod -R 777 /opt/rsa/primekit/tomcat/tomcat-amis/bin/
- Restart the RSA Authentication Manager Prime Kit services:
service tomcat-amis restart service tomcat-hdap restart service tomcat-ssp restart
The proper way to resolve this issue is to run the reset_perms script to assign the correct permissions to the directory. To do so:
- Use SSH to access the RSA Authentication Manager Prime Kit server.
- Go to the <Prime_installation_directory>/scripts/tools:
cd /opt/rsa/primekit/scripts/tools
- Run the reset permissions script to correct the permissions for all directories:
./3_reset_perms.sh
- Press Enter when prompted to for the script to do its job.
- Restart the RSA Authentication Manager Prime Kit services:
service tomcat-amis restart service tomcat-hdap restart service tomcat-ssp restart
Related Articles
Collect Prime logs and Configuration files using the collect script 179Number of Views RSA Authentication Manager Prime services fail to start after Java update on a Windows server: Error Failed creating java 300Number of Views Determining an existing RSA Prime version 54Number of Views RSA Authentication Manager Prime throws "Node secret mismatch: cleared on server but not on agent" despite repeated cleari… 540Number of Views Oracle software installation throws Permission denied error when installing or upgrading RSA Identity Governance & Lifecycle 116Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?