ORA-01403 no data found error in Account Data Collectors (ADC) in Step 10/11 in RSA Governance & Lifecycle
2 years ago
Article Number
000071608
Applies To

This is a known issue in the following version.

  • SecurID Governance & Lifecycle 7.5.2
  • RSA Governance & Lifecycle 8.0.0
Issue

Account Data Collectors (ADC) may fail in Step 10/11 Post-Processing: Tag Affected User Relationships.

The aveksaserver.log file will generate the following ERROR level log message
 

11/29/2023 20:32:30.278 INFO  (Exec Task Consumer#1 - Main) [com.aveksa.server.db.persistence.PersistenceServiceProvider] executeCallableStatement giving up after hitting SQLException: ORA-01403: no data found
ORA-06512: at "AVUSER.UNFC_PROCESSOR", line 66
ORA-06512: at "AVUSER.UNFC_USERS", line 1970
ORA-06512: at "AVUSER.UNFC_USERS", line 1970
ORA-06512: at "AVUSER.UNFC_PROCESSOR", line 304
ORA-06512: at "AVUSER.UNFC_PROCESSOR", line 41
ORA-06512: at line 1


 
Cause
This issue may occur after a data migration (upgrade) from an earlier version if some of the historical data for collections has been deleted by Data Purging.  
Resolution

This is resolved in the following versions which makes a change to Data Purging to preserve at least one data run for every ADC regardless of the time of the last collection. 

  • SecurID Governance & Lifecycle 7.5.2 P09
  • RSA Governance & Lifecycle 8.1.0
Workaround
  • Navigate to the Participating Collectors tab under the Collectors Unification menu and select "Run Unification".
  • For each of the ADC's run a new ADC collection.