'ORA-01722: invalid number' or 'Non supported SQL92 token at position: XXX' errors in the aveksaServer.log when rendering or editing/creating forms with dynamic variables in RSA Identity Governance & Lifecycle
Originally Published: 2020-03-25
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: 7.0.x, 7.1.x, 7.2.0
Issue
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQuery(PersistenceServiceProvider.java:2992)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQueryInteger(PersistenceServiceProvider.java:3127)
at com.aveksa.server.db.PersistenceManager.executeJDBCQueryInteger(PersistenceManager.java:439)
at com.aveksa.gui.components.table.special.SQLTable.getObjectCount(SQLTable.java:330)
... 79 more
Caused by: org.hibernate.exception.SQLGrammarException: error executing work
at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:63)
at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:42)
at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:109)
at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:95)
at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.coordinateWork(JdbcCoordinatorImpl.java:337)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2153)
at org.hibernate.internal.SessionImpl.doReturningWork(SessionImpl.java:2149)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQuery(PersistenceServiceProvider.java:2973)
... 82 more
Caused by: java.sql.SQLSyntaxErrorException: ORA-01722: invalid number
or
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQuery(PersistenceServiceProvider.java:2992)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQueryInteger(PersistenceServiceProvider.java:3127)
at com.aveksa.server.db.PersistenceManager.executeJDBCQueryInteger(PersistenceManager.java:439)
at com.aveksa.gui.components.table.special.SQLTable.getObjectCount(SQLTable.java:330)
... 79 more
Caused by: org.hibernate.exception.GenericJDBCException: error executing work
at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:47)
at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:109)
at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:95)
at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.coordinateWork(JdbcCoordinatorImpl.java:337)
at org.hibernate.internal.SessionImpl.doWork(SessionImpl.java:2153)
at org.hibernate.internal.SessionImpl.doReturningWork(SessionImpl.java:2149)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.executeJDBCQuery(PersistenceServiceProvider.java:2973)
... 82 more
Caused by: java.sql.SQLException: Non supported SQL92 token at position: 2300
Please refer to RSA Knowledge Base Article 00003027 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (Admin > System > Server Nodes tab > under Logs.)
Cause
This issue occurs when a request form field has a table Control Type with a filter that cannot be resolved until the form is triggered or the form has valid context. (Requests > Configuration > Request Forms > {form name} > Fields > Edit/New).
In this example the Control Type is a User Account Table and the Account Filter has the following advanced Where clause:
x."Account Name" in (select a.name from t_av_user_account_mappings map inner join t_av_accounts a on a.id = map.account_id where map.user_id = '${avform.requestor.Id}' and map.deletion_date is null and a.deletion_date is null)
or
x."Account Name" in (select a.name from t_av_user_account_mappings map inner join t_av_accounts a on a.id = map.account_id where map.user_id = ${avform.requestor.Id} and map.deletion_date is null and a.deletion_date is null)
Note the dynamic form field ${avform.requestor.Id}. When this field is surrounded by single quotes ('${avform.requestor.Id}'), the error is:
ORA-01722: invalid number
When the single quotes are removed (${avform.requestor.Id}) the error is:
Non supported SQL92 token at position: 2300
Resolution
- RSA Identity Governance & Lifecycle 7.1.1 P07
- RSA Identity Governance & Lifecycle 7.2.0 P02
Related Articles
Menu bar is not refreshed after creating a Change Request or Pending Submission in RSA Identity Governance & Lifecycle 47Number of Views Creating a custom attribute and reporting on it in RSA Authentication Manager 8.2 SP1 or later 20Number of Views Creating a Trust Relationship 12Number of Views How to modify the number of allowable active tokens per user on RSA Authentication Manager 8.x 73Number of Views New Archive run cannot be created due to overlapping with existing archives error in RSA Identity Governance & Lifecycle 41Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?