ORA-39070: "Unable to open the log file" error or ORA-06512: at "SYS.DBMS_SYS_ERROR" and "SYS.DBMS_DATAPUMP" errors when backing up (exporting) an RSA Identity Governance & Lifecycle database
Originally Published: 2019-07-28
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.x
Issue
7.1.1 / 7.2.0
ORA-39002: invalid operation
ORA-06512: at "SYS.DBMS_SYS_ERROR", line 79
ORA-06512: at "SYS.DBMS_DATAPUMP", line 4087
ORA-06512: at "SYS.DBMS_DATAPUMP", line 4338
ORA-06512: at line 1
7.1.0 does not fail in this scenario.
7.0.x
ORA-39002: invalid operation ORA-39070: Unable to open the log file. ORA-39087: directory name AVEKSA_EXPORTIMPORT_DIRECTORY is invalid
6.x
ORA-39002: invalid operation
ORA-39070: Unable to open the log file.
ORA-29283: invalid file operation
ORA-06512: at "SYS.UTL_FILE", line 475
ORA-29283: invalid file operation
Cause
Resolution
- Check that the database directory is defined in the database.
- Run the following SQL as SYSDBA:
select * from dba_directories where directory_name like 'AVEKSA%';
- This should return the following:
DIRECTORY_NAME DIRECTORY_PATH ------------------------------------------------------------ AVEKSA_EXPORTIMPORT_DIRECTORY /home/oracle/AveksaExportImportDir
- If the path is missing or incorrect, use the following SQL to correct the directory path:
create or replace directory AVEKSA_EXPORTIMPORT_DIRECTORY as '/home/oracle/AveksaExportImportDir';
- The path specified above must also be the same in the /home/oracle/Aveksa_System.cfg file and the /home/oracle/setDeployEnv.sh script. If not, make them the same.
- Check the read/write privileges on the directory path:
- Run the following SQL as SYSDBA:
select * from all_tab_privs where table_name like 'AVEKSA%';
- This should return the following:
- If this query returns no rows, then grant the needed access to AVUSER by running the following SQL as SYSDBA:
grant read, write on directory AVEKSA_EXPORTIMPORT_DIRECTORY to AVUSER;
NOTE:
- If -o option is specified for AVDB_Export_AVUSER.sh with the full path to a directory for the output file, ensure that OS permissions are sufficient for the 'oracle' user to read/write to that directory.
If -o option is not specified, the export file is saved to /home/oracle/AveksaExportImportDir/
- In 6.x two additional directories exist that require read/write privileges to be granted to AVUSER. These directories and paths are as follows:
AVEKSA_REPORTS_DIRECTORY /home/oracle/AveksaReportsDir AVEKSA_DATA_DIRECTORY /home/oracle/AveksaDataDir
Related Articles
Patch fails on remote database because execute privilege is not granted to AVDWUSER on SYS.DBMS_LOB in RSA Identity Lifecy… 204Number of Views RSA Identity Governance and Lifecycle - 702 Migration fails with ORA-01720: grant option does not exist for 'SYS.DUAL' 139Number of Views What is the SYS.ORA_TEMP_1_DS_% table sometimes seen in a running query in RSA Identity Governance & Lifecycle 37Number of Views Upgrade/patch fails with 'ORA-00001: unique constraint (SYS.I_WRI$_OPTSTAT_HH_OBJ_ICOL_ST) violated' error in RSA Identity… 104Number of Views Authentication Agent for Windows v. 7.4.x Challenge lookup fails with "Cannot open challenge cache data key for user <User… 154Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?