Patch fails on remote database because execute privilege is not granted to AVDWUSER on SYS.DBMS_LOB in RSA Identity Lifecycle and Governance
Originally Published: 2017-10-25
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.0.2
Issue
Initialization has failed! Errors found while patching the schema.
In the patch.log:
--------------------------- Dbms_Output Begin --------------------------- No permission to grant select on V_APPSUMMARYINFO to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_AVR_ESCALATED_EXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_AVR_EXCEPTIONS_4_OWNR_IN_GRP to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_EXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_NEWEXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_OPENEXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_OPENIGNOREDEXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_OPENINCIDENTEXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' No permission to grant select on V_OPENWORKINGEXCEPTIONS to avdwuser ORA-01720: grant option does not exist for 'SYS.DBMS_LOB' --------------------------- Dbms_Output End ---------------------------
Cause
Workaround
GRANT EXECUTE ON SYS.DBMS_LOB TO AVDWUSER; or GRANT EXECUTE ON SYS.DBMS_LOB TO PUBLIC;
Notes
Related Articles
RSA Identity Governance and Lifecycle - 702 Migration fails with ORA-01720: grant option does not exist for 'SYS.DUAL' 139Number of Views What is the SYS.ORA_TEMP_1_DS_% table sometimes seen in a running query in RSA Identity Governance & Lifecycle 37Number of Views ORA-39070: "Unable to open the log file" error or ORA-06512: at "SYS.DBMS_SYS_ERROR" and "SYS.DBMS_DATAPUMP" errors when b… 280Number of Views Upgrade/patch fails with 'ORA-00001: unique constraint (SYS.I_WRI$_OPTSTAT_HH_OBJ_ICOL_ST) violated' error in RSA Identity… 104Number of Views Differences between List Folder Contents and Read & Execute permissions when using StealthAUDIT and Data Access Governance… 37Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?