Patch or upgrade running long in step ACM-105090.sql in RSA Identity Governance & Lifecycle
4 years ago
Originally Published: 2021-11-24
Article Number
000044478
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.2.0, 7.2.1, 7.5.0
Issue
When upgrading, the patch takes a long time to complete.
The patch.log file shows the process spending time on the step that deletes data from WP_ACTI_ALERT table:
[0:03:27  27%] executing updates/7.1/ACM-105090.sql
Cause

This is a known issue when patching (or upgrading) from versions older than the following versions if there is a very large amount of data in WP_ACTI_ALERT and WP_WI_ALERT tables:

  • RSA Identity Governance & Lifecycle 7.2.0 P05
  • RSA Identity Governance & Lifecycle 7.2.1 P01
  • RSA Identity Governance & Lifecycle 7.5.0
An improvement was added in the above versions/patches which reduces the amount of workflow data (alerts) that are created for certain types of workflows.  The patch and upgrade script removes all historical data that is no longer required in current versions.  The removal of historical data may take some time when there is a large amount of legacy data.
Resolution

Allow the patch or upgrade to complete.  This is a one time process.

If the patch or upgrade was aborted or you wish to reduce the upgrade time for other environments, please contact RSA Customer Support and request a workaround for this issue.

Workaround

If you encounter this issue during patching or upgrade and want to reduce the time for the migration, please contact RSA Customer Support and quote this article.  RSA Customer Support can supply a cleanup script that can be run prior to the patching or upgrade to greatly reduce the migration time.