Patching RSA Governance & Lifecycle fails with error Unable to connect to controller.
Last Modified: 2023-10-06
Article Number
Applies To
RSA Version/Condition: 7.x
Issue
Caught: java.lang.IllegalStateException: Unable to connect to controller. java.lang.IllegalStateException: Unable to connect to controller. at org.jboss.as.cli.scriptsupport.CLI.doConnect(CLI.java:306) at org.jboss.as.cli.scriptsupport.CLI.connect(CLI.java:82) at org.jboss.as.cli.scriptsupport.CLI$connect$0.call(Unknown Source) at com.aveksa.wildfly.Util.connect(Util.groovy:157) at com.aveksa.wildfly.Util$connect.call(Unknown Source) at com.aveksa.wildfly.CustomizeACM.addLoggingFilters(CustomizeACM.groovy:573) at com.aveksa.wildfly.CustomizeACM.run(CustomizeACM.groovy:55) Caused by: org.jboss.as.cli.CommandLineException: The controller is not available at localhost:9990 at org.jboss.as.cli.impl.CommandContextImpl.tryConnection(CommandContextImpl.java:1520) at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:1296) ... 22 more An error occured in the customizeACM command : error code 1
Resolution
- Connect to the server SSH session.
- ACM stop.
- Run the command ifconfig to get the server IP address.
- Go to the path /home/oracle/wildfly/bin/
- Take a backup of the file jboss-cli.xml by running the command
cp jboss-cli.xml jboss-cli.xml.bkp
- Edit the jboss-cli.xml file and replace Localhost with the server IP address.
<default-controller> <protocol>remote+http</protocol> <host>localhost</host> <port>9990</port> </default-controller>
- ACM start
- Install the Patch
Related Articles
Cloud Access Service - Administrators 7Number of Views How to configure LDAP synchronization from RSA ACE/Server 5.2 to Microsoft Active Directory 2003 20Number of Views Configure RADIUS Settings 31Number of Views RSA Authentication Manager Identity Sources 68Number of Views Connect to Identity Sources Using LDAPS 106Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?