Persistence layer issue in RSA Identity Governance & Lifecycle degrades performance and potentially leads to system crash
Originally Published: 2019-10-03
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: 7.1.0
Issue
- Illegal TXN State during transaction rollback.
- Blocking sessions on the database caused by Idle sessions.
- Row lock contention.
- AFX Server stops running
- Performance degradation
- Possible system crash
Below are examples of symptoms that indicate you are having this issue:
- Illegal TXN State in the user interface (Admin > System > Server Nodes)
Error - Illegal TXN State: Attempt to start new transaction during rollback.
- An increasing number of blocking sessions are seen in Oracle Enterprise Manager (OEM):
- Illegal TXN State errors and PersistenceServiceProvider references are seen in the aveksaServer.log:
07/03/2018 12:01:30.698 ERROR (default task-26) [com.aveksa.gui.core.filters.LoginFilter] java.lang.IllegalStateException: have sessions (SessionImpl(PersistenceContext
...
at com.aveksa.server.db.persistence.PersistenceServiceProvider.checkAllClosed(PersistenceServiceProvider.java:3925) at com.aveksa.gui.core.MainManager.doGet(MainManager.java:135)
...
at com.aveksa.server.db.persistence.PersistenceServiceProvider.checkAllClosed(PersistenceServiceProvider.java:3925) at com.aveksa.gui.core.MainManager.doGet(MainManager.java:135)
and
07/03/2018 12:04:29.857 ERROR (default task-8) [com.aveksa.server.core.AdminServiceProvider] Error cleaning up database context java.lang.RuntimeException: Illegal TXN State: Attempt to start new transaction during rollback. Txn count=3 at com.aveksa.server.db.persistence.PersistenceServiceProvider.beginTransaction(PersistenceServiceProvider.java:2633)
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment.
- The AFX Server shuts down
Please refer to RSA Knowledge Base Article 000038027 -- AFX Server intermittently shuts down in RSA Identity Governance & Lifecycle for additional information.
Cause
Resolution
- RSA Identity Governance & Lifecycle 7.1.0 P03
- RSA Identity Governance & Lifecycle 7.1.1.
Workaround
Related Articles
When editing/creating a SOAP Web Service AFX Connector and configuring any capability, a 'Request could not be handled' me… 55Number of Views Incorrect setting for Oracle PARALLEL_DEGREE_POLICY causes issue in RSA Identity Governance & Lifecycle 85Number of Views Roles stuck in Applied state in SecurID Governance & Lifecycle 384Number of Views Performance issue with Change Request generation from a Review to Revoke a large volume of access in RSA Identity Governan… 10Number of Views Running upgradeJDK.sh issues "ACM is not supported on this version of linux" in RSA VIA Lifecycle & Governance 68Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?