RSA Identity Governance and Lifecycle migration script insertMigrationReportDefinitions.sh fails with error ORA-01017: table or view does not exist
Originally Published: 2017-01-12
Last Modified: 2026-05-19
Article Number
Applies To
RSA Version/Condition: 6.9.1, 7.0.0, 7.0.1
Product Name: RSA Identity Governance and Lifecycle
Issue
ERROR: ORA-01017: invalid username/password; logon denied
When running any of the Migration Reports they fail with the error ORA-00942: table or view does not exist.
The /home/oracle/jboss-4.2.2.GA/server/default/deploy/aveksa.ear/aveksa.war/log/aveksaServer.log shows the following exception:
12/14/2016 08:31:36.298 ERROR (http-0.0.0.0-8443-31) [com.aveksa.server.report.Report] get all display cols
com.aveksa.server.runtime.ServerException: java.sql.SQLException: ORA-00942: table or view does not exist
Cause
The following shows a failed attempt to run the insertMigrationReportDefinitions.sh
oracle@acm-691:/tmp/aveksa/MigrationReports> insertMigrationReportDefinitions.sh Using /home/oracle/Aveksa_System.cfg configuration file to find the target database ... ORACLE_CONNECTION_ID=AVDB AVEKSA_USER=avuser AVEKSA_REPORTS_USER=avdwuser Provide the password for the user avuser: Creating required views and reports for migration ... Package created. No errors. Package body created. No errors. View created. View created. View created. View created. View created. View created. View created. View created. View created. View created. PL/SQL procedure successfully completed. Granting privileges on migration report views to reports user ... PL/SQL procedure successfully completed. Provide the password for the reporting user avdwuser: Creating synonyms for avdwuser user ... ERROR: ORA-01017: invalid username/password; logon denied oracle@acm-691:/tmp/aveksa/MigrationReports>
Resolution
- Ensure that the insertMigrationReportDefinitions.sh completes without error.
- Ensure that you have used the correct password for AVUSER and for AVDWUSER.
- Note that the default password for AVDWUSER on a hardware appliance is not the same a the password for AVUSER. If you are not sure of the passwords in use for the appliance, contact RSA Customer Support and request assistance.
- On page 11 of the RSA Identity Governance and Lifecycle V7.0.1 Upgrade and Migration Guide, the instructions indicate that when the script completes correctly it should end with a status of Created required reports with Category Migration.
The following shows a successful attempt to run the insertMigrationReportDefinitions.sh:
oracle@acm-691:/tmp/aveksa/MigrationReports> insertMigrationReportDefinitions.sh Using /home/oracle/Aveksa_System.cfg configuration file to find the target database ... ORACLE_CONNECTION_ID=AVDB AVEKSA_USER=avuser AVEKSA_REPORTS_USER=avdwuser Provide the password for the user avuser: <enter avuser password> Creating required views and reports for migration ... Package created. No errors. Package body created. No errors. View created. View created. View created. View created. View created. View created. View created. View created. View created. View created. PL/SQL procedure successfully completed. Granting privileges on migration report views to reports user ... PL/SQL procedure successfully completed. Provide the password for the reporting user avdwuser: Creating synonyms for avdwuser user ... PL/SQL procedure successfully completed. Thu Jan 12 12:44:21 EST 2017 Created required reports with Category Migration oracle@acm-691:/tmp/aveksa/MigrationReports>
Notes
Related Articles
Authentication Manager 8.5 to 8.6 Pre-Migration Script Fails 71Number of Views Status pages very slow on one of the two appliances in a cluster 19Number of Views Clearing PuTTY's Cache Of Host Finger Prints On Windows OS Event Sources 7Number of Views 'ORA-00942: Table or View does not exist' error when referencing a custom table/view in a report query in RSA Identity Gov… 244Number of Views After restoring KCA (with nCipher) cannot issue a certificate. 10Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?