RSA SecurID Authenticate app registration fails on MIUI devices with error "Unsuccessful RSA SecurID Access Setup"
4 years ago
Originally Published: 2017-09-12
Article Number
000041532
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Cloud
RSA Version/Condition: Not Applicable
Issue
The RSA SecurID Authenticate app is unable to register with the Cloud Authentication Service when it is installed on a device running the MIUI operating system.  The error displayed by the app is

Unsuccessful RSA SecurID Access setup
Complete the registration process again.

 

Unsuccessful RSA SecurID Access setup Complete the registration process again.

The RSA SecurID Authenticate log shows the following sequence of events:
 
2017-08-21 06:34:53 UTC [INFO] : [companyname] : Request sent: Register device.
2017-08-21 06:34:56 UTC [ERROR] : [companyname] : Response received: Device registration unsuccessful.
2017-08-21 06:34:56 UTC [INFO] : Alert displayed: Title: Unsuccessful RSA SecurID Access setup. Message: Complete the registration process again.

Although the registration fails according to the RSA SecurID Authenticate app, when you View All Devices for the Cloud Authentication Service User, the device may appear as a registered Android device.
Cause
The RSA SecurID Authenticate app is not supported on devices running the MIUI operating system.  

RSA only supports devices that meet the Cloud Authentication Service User Requirements.  Although MIUI is based on Android, it is not standard Android so does not meet these requirements.
Resolution
The end user will not be able to use the RSA SecurID Authenticate app on their MIUI device.

If the MIUI device is showing as registered for the user in the Cloud Administration Console, a Super Admin or Help Desk Administrator should Delete the User's Device from the Console.
 
Workaround
 If the end user has no alternate device to use that meets the Cloud Authentication Service User Requirements then Emergency Access for Cloud Authentication Service Users could be used for a short time until a suitable alternative authentication method can be made available for the end user.
Notes
For additional RSA SecurID Authenticate app troubleshooting assistance, see Troubleshooting Cloud Authentication Service User Issues in the Online Help.