RSA enVision throws error org.apache.tomcat.util.digester.Digester:SEVERE: Parse Fatal Error
Originally Published: 2016-02-16
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: enVision Core
RSA Version/Condition: 4.1
Platform: Windows Server 2003/2008 R2
Issue
- NIC Webserver service is showing as started in services.msc, however, the GUI is not responding.
- This is causing the commenting/uncommenting logic of http connector code in server.xml(when switching between http and https using Communication Configuration tool) in HttpConf.java to fail.
Cause
Feb 12, 2016 11:31:08 AM org.apache.tomcat.util.digester.Digester:SEVERE: Parse Fatal Error at line 87 column -1: Next character must be ">" terminating comment .
org.xml.sax.SAXParseException: Next character must be ">" terminating comment.
Resolution
2. On line 87, find the following text:
{code}
<!-- Define a non-SSL HTTP/1.1 Connector on port 8080-->
<!--Http-Connector-starts.DO NOT DELETE, MOVE THIS COMMENT. Do not add new line after this line --> <!--
<Connector port="${envision.http.port}" maxHttpHeaderSize="8192" protocol="HTTP/1.1"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="${envision.https.port}" acceptCount="100" server=" "
connectionTimeout="20000" disableUploadTimeout="true" maxPostSize="${envision.http.maxPostSize}" />
--> <!-- Http-Connector-ends. DO NOT DELETE, MOVE THIS COMMENT. Do not add new line before this line -->
<!-- Note : To disable connection timeouts, set connectionTimeout value
to 0 -->
{code}
3. Change this text to:
{code}
<!-- Define a non-SSL HTTP/1.1 Connector on port 8080-->
<!--Http-Connector-starts.DO NOT DELETE, MOVE THIS COMMENT. Do not add new line after this line -->
<!--
<Connector port="${envision.http.port}" maxHttpHeaderSize="8192" protocol="HTTP/1.1"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="${envision.https.port}" acceptCount="100" server=" "
connectionTimeout="20000" disableUploadTimeout="true" maxPostSize="${envision.http.maxPostSize}" />
-->
<!-- Http-Connector-ends. DO NOT DELETE, MOVE THIS COMMENT. Do not add new line before this line -->
<!-- Note : To disable connection timeouts, set connectionTimeout value
to 0 -->
{code}Related Articles
Machines Running Windows Server 2012 R2 are not challenged after configuration of GPO Policy Correclty 27Number of Views RSA Authentication Manager Identity Sources 68Number of Views Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperrepor… 265Number of Views Considerations when using F5 of other Load Balancer for MFA and ReST API agents. How to configure F5 or other Load Balancing. 120Number of Views How to check the connectivity and response time of an Identity source for RSA Authentication Manager using ldapsearch 541Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?