Read-only file system message for RSA Identity Governance & Lifecycle
Originally Published: 2018-09-27
Last Modified: 2023-11-30
Article Number
Applies To
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.0.0 and above
Platform: Linux running on VMware
Issue
# service aveksa_server status
/etc/init.d/aveksa_server: line 29: /var/run/aveksa_server.pid: Read-only file system
RSA Via Lifecycle and Governance is running
# service aveksa_server stop
/etc/init.d/aveksa_server: line 29: /var/run/aveksa_server.pid: Read-only file system
Stopping RSA Via Lifecycle and Governance:
Authenticating against security realm: ManagementRealm
In this case, the /var mount point has been switched to Read Only mode.
The /var/run/aveksa_server.pid file gets created when an operation is performed with the aveksa_server service. The /var/run directory has the following access: drwxr-xr-x, so only root has write access.
Cause
Resolution
Examine the /var/log/messages log file, to determine if any disk failure has been reported. If none has been reported, then the problem was likely caused by the virtual machine.
Notes
If you are running an RSA Appliance, please engage RSA Customer Support for further assistance, as the hard disk may need to be replaced.
Related Articles
User cannot change password with an error Read ONLY external database. 40Number of Views RSA RADIUS Fails to Redirect Authentications to RSA Authentication Manager 76Number of Views How to recover failed RSA Authentication Manager 8.x virtual appliance when the filesystem is stuck in read-only mode 635Number of Views How to recover the user id or password of a read only database user from RSA Authentication Manager 8.x 301Number of Views Common User Schema Migration Dashboard 6Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?