SAP connector fails with hostname not found when using a non-default port in RSA Identity Governance & Lifecycle
Originally Published: 2019-09-20
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: All
Issue
GetHostByName: '10.100.99.99:3301' not found SYSTEM CALL getaddrinfo
The Connection Details used in this example are:
A test connection using the default SAP port of 3300 is successful:
Cause
In the example above, RSA Identity Governance & Lifecycle is converting the entire string 10.100.99.99:3301 as a Hostname to an IP address.
Resolution
/H/hostname/S/port
For example,
Related Articles
Intermittent IWA Authentication Issues for IDR Portal Users 8Number of Views Segregation of Duties (SOD) Rule fails with error 'ORA-30926: unable to get a stable set of rows in the source tables' err… 231Number of Views RSA Authentication Manager 8.x Web Tier is not listening on TCP port 443 735Number of Views RSA Authentication Manager 8.x services won't start when network interface adapter eth0 is not found 262Number of Views Identity Router Network Interfaces and Default Ports 308Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?