Security Object Manager (SOM) client fails to connect to SOM Server
2 years ago
Originally Published: 2015-04-30
Article Number
000055983
Applies To
Security Object Manager Client - SOM Client
Security Object Manager Server - SOM Server
 
Issue
SOM Client logs:
2015-04-21 08:01:25,898 [RT BAPT] INFO com.rsa.pso.som.SOMRequest <createxmldoc> - Ping called: requestID =23c47a0c-e5b9-427d-ab77-c890b0e829f9 
2015-04-21 08:01:25,898 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Connecting to host: som-mah.rsa.net 
2015-04-21 08:01:26,163 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #1 host som-mah.rsa.net 
2015-04-21 08:01:31,233 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #2 host som-mah.rsa.net 
2015-04-21 08:01:36,303 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #3 host som-mah.rsa.net 
2015-04-21 08:01:41,373 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Connecting to host: som-win.rsa.net 
2015-04-21 08:01:41,638 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #1 host som-win.rsa.net 
2015-04-21 08:01:46,849 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #2 host som-win.rsa.net 
2015-04-21 08:01:52,059 [RT BAPT] INFO com.rsa.pso.som.SOMConnection <sendSOMRequestHostList> - Retry #3 host som-win.rsa.net 
2015-04-21 08:01:57,269 [RT BAPT] ERROR com.rsa.pso.som.TokenClient <ServerPing> - SOM Exception: RequestID = 23c47a0c-e5b9-427d-ab77-c890b0e829f9 -- I/O Error
ost: som-win.rsa.net : Socket closed : Error Code <78106> Error Code: 78106 

2015-04-21 08:01:57,269 [RT BAPT] ERROR com.rsa.pso.som.TokenClient <ServerPing> - Unknown Exception happened while processing Ping Request: Error Code <78032> 
2015-04-21 08:01:57,269 [RT BAPT] ERROR com.rsa.pso.som.TokenClient <ServerPing> - SOM Exception: Unknown Exception happened while processing Ping Request: Error Code <78032> Error Code: 78032 
2015-04-21 08:01:57,269 [RT BAPT] ERROR com.rsa.pso.som.TokenClient <CheckServers> - Check Servers failed: Unknown Exception happened while processing Ping Request: Error Code <78032> 
2015-04-21 08:01:57,269 [RT BAPT] ERROR com.rsa.pso.som.TokenClient <Initialize> - SOM Exception: address check failed Error Code: 78101 



Server Log: 
2015-04-21 08:01:31,201 INFO [com.example.som.mvc.controller.SomController] - XML Message parsing took 1 ms. 
2015-04-21 08:01:31,201 INFO [com.example.som.mvc.controller.SomController] - In SomController.doPost with requestId=23c47a0c-e5b9-427d-ab77-c890b0e829f9, sender=MyApp, version=1.0 
2015-04-21 08:01:31,201 INFO [com.example.som.mvc.controller.SomPingSubcontrollerImpl] - --> Ping.execute with IP=153.2.50.91,RequestID=23c47a0c-e5b9-427d-ab77-c890b0e829f9,AppID=83709165264081601407727708055956098738,AppName=MyApp
2015-04-21 08:01:31,202 INFO [com.example.som.mvc.controller.SomPingSubcontrollerImpl] - [PCI-LOG]<-- Ping.execute with IP=153.2.50.91,RequestID=23c47a0c-e5b9-427d-ab77-c890b0e829f9,AppID=83709165264081601407727708055956098738,AppName=MyApp,Status=0 
2015-04-21 08:01:31,202 INFO [com.example.som.mvc.controller.SomController] - Total Transaction 23c47a0c-e5b9-427d-ab77-c890b0e829f9 Time: 2 ms. 
Cause
Java Automatic Update installed Java 8 and removed Java 6
Resolution
Re-install Java 6 and edit your startup files to point to the Java 6 JRE