Step 5 of the RSA Identity Governance & Lifecycle OVA installation fails with 'error configuring certificates' and 'ORA-00942: table or view does not exist'
2 years ago
Originally Published: 2019-08-16
Article Number
000041212
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.1.0, 7.1.1
Platform(Other): Customer-supplied database
Issue
Step 5 of the RSA Identity Governance & Lifecycle OVA installation fails with the below errors:
 
STEP 5
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Note that this error is in Step 5 and not in Step 1 as indicated by the error below:
 
[Step 1 of 9] Error configuring certificates ('./configureSSLCertificates.sh')
 
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The errors in the aveksaServer.log are:
 
Creating Aveksa CA.
Args: createca apliam01
CertificateManager execution error!
com.aveksa.server.certificates.AveksaCertificateException: ORA-00942: table or view does not exist

    at com.aveksa.server.certificates.CertificateManager.doesPathExist(CertificateManager.java:1237)
    at com.aveksa.server.certificates.CertificateManager.executeCmdLine(CertificateManager.java:1456)
    at com.aveksa.server.certificates.CertificateManager.main(CertificateManager.java:1525)
Caused by: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:450)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:399)
    at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1059)
    at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:522)
    at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:257)
    at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:587)
    at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:225)
    at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:53)
    at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java:774)
    at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:925)
    at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1111)
    at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:4798)
    at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:4845)
    at oracle.jdbc.driver.OraclePreparedStatementWrapper.executeQuery(OraclePreparedStatementWrapper.java:1501)
    at com.aveksa.server.certificates.CertificateManager.doesPathExist(CertificateManager.java:1232)
    ... 2 more
Failed to create Aveksa CA!

Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment. 
 
Cause

This error occurs because table T_AV_FILES does not exist in the customer-supplied (remote) database. T_AV_FILES is required during the generation of CA certificates phase of the installation. This table is created as part of the AVUSER schema which is not created until later in the installation process. The script file supplied in aveksa-supplement-7.1.0.zip for setting up a customer-supplied (remote) database also does not create this table.

This issue has been reported in engineering ticket ACM-92268.

Resolution

This issue is resolved in the following versions:

  • RSA Identity Governance & Lifecycle 7.1.1 P04
  • RSA Identity Governance & Lifecycle 7.2.0
  • RSA Identity Governance & Lifecycle 7.2.1
  • RSA Identity Governance & Lifecycle 7.5.0
Workaround

Manually create table T_AV_FILES in the remote database before beginning the OVA installation. Please contact RSA Identity Governance & Lifecycle Support for the SQL that will create the T_AV_FILES table and mention this RSA Knowledge Base Article ID 000037243 for reference and for instructions on running the SQL.
 

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