Unable to use the User Scope Restriction in RSA Authentication Manager 8.x
Originally Published: 2015-04-20
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
There was a problem processing your request. Specified scope restriction condition PRINICIPAL.<attributename> IN
{“<myvalue>”} is invalid.
{“<myvalue>”} is invalid.
The User Scope Restriction allows you to restrict which users the administrator can manage within the administrative scope of this role. To restrict user scope, you must specify an attribute condition.
Cause
Resolution
Confirm that the User to define conditions on administrative user management permission is checked as shown above.
Once you have an attribute defined to use for scope restriction and this option checked then you will be able to use User Scope Restriction in Administrative roles.
In this instance, this option was not checked, triggering the error.
Notes
- The syntax is PRINICIPAL. IN {“”}
- The syntax is case sensitive. PRINCIPAL and IN are always uppercase. The attribute name should be exactly what you mentioned when creating the attribute above.
- For example, if you create an attribute name called Department, then your syntax will look something like PRINCIPAL.Department IN { "RESEARCH"}.
- Using PRINCIPAL.DEPARTMENT IN { "RESEARCH"} will fail.
- The working syntax here will give the administrative role to admin who can manage users from research department.
Related Articles
Scheduling Cleanup for Unresolvable Users and User Groups 113Number of Views Indirect Relationship Processing fails with ORA-30926 and 'ORA-06512: at "AVUSER.CE_USERS" ' errors when collecting Groups… 967Number of Views Emergency Access for RSA Authentication Manager Users 365Number of Views Limiting users to one token per user ID in RSA Authentication Manager 8.x 135Number of Views Authentication Methods for Cloud Access Service Users 622Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?