Upgrading to Authentication Manager 8.4 fails with the error message "Unable to delete file /opt/rsa/am/server/wrapper/backup/AdminServerWrapper.conf"
Originally Published: 2018-12-31
Last Modified: 2023-11-30
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.3 or later
Issue
[delete] Deleting: /opt/rsa/am/config/classpaths/replication.IMS.classpath
[copy] Copying 1 file to /opt/rsa/am/config/classpaths
[exec] Generating wrapper Class-Path Manifest JAR file.
[exec] wrapper Class-Path Manifest JAR file generated successfully.
[delete] Deleting: /opt/rsa/am/config/classpaths/wrapper.IMS.classpath
270673 2018-12-28 15:26:00,326 INFO: Generating the classpath jar used for thirdparty jars that are packaged outside the ear due to licensing restrictions.
Exception in thread "main" : Unable to delete file /opt/rsa/am/server/wrapper/backup/AdminServerWrapper.conf
at org.apache.tools.ant.taskdefs.Delete.handle(Delete.java:704)
at org.apache.tools.ant.taskdefs.Delete.removeDir(Delete.java:753)
at org.apache.tools.ant.taskdefs.Delete.removeDir(Delete.java:749)
at org.apache.tools.ant.taskdefs.Delete.removeDir(Delete.java:749)
at org.apache.tools.ant.taskdefs.Delete.execute(Delete.java:571)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at UpdateRollback.update_InvokeGroovy_Update_AM(UpdateRollback.groovy:460)
at UpdateRollback$_update_closure2.doCall(UpdateRollback.groovy:45)
at UpdateRollback$_update_closure2.doCall(UpdateRollback.groovy)
at Utils.withArtifacts(Utils.groovy:48)
at Utils$withArtifacts.call(Unknown Source)
at UpdateRollback.update(UpdateRollback.groovy:37)
at com.rsa.plugins.install.GroovyInstallEngine.invokeScript(GroovyInstallEngine.groovy:68)
at com.rsa.plugins.install.GroovyInstallEngine$_runTask_closure2.doCall(GroovyInstallEngine.groovy:57)
at com.rsa.plugins.install.GroovyInstallEngine.runTask(GroovyInstallEngine.groovy:56)
at com.rsa.plugins.install.GroovyInstallEngine$_runTasks_closure3.doCall(GroovyInstallEngine.groovy:106)
at com.rsa.plugins.install.GroovyInstallEngine.runTasks(GroovyInstallEngine.groovy:105)
at com.rsa.plugins.install.GroovyInstallEngine$runTasks.call(Unknown Source)
at com.rsa.plugins.install.CommandLineInstallEngine.main(CommandLineInstallEngine.groovy:40)
Configuration step UpdateRollback:update [FAILED]
[ERROR] Error: Failed to invoke update engine: Failed to apply the update.
java.lang.Exception: Failed to apply the update.
at com.rsa.am.updateengine.tasks.BaseUpdateEngineTask.doExecute(BaseUpdateEngineTask.java:56)
at com.rsa.am.updateengine.tasks.Task.execute(Task.java:136)
at com.rsa.am.updateengine.components.impl.TaskManagerImpl.doExecuteTask(TaskManagerImpl.java:86)
at com.rsa.am.updateengine.components.impl.TaskManagerImpl.execute(TaskManagerImpl.java:41)
at com.rsa.am.updateengine.components.impl.UpdateInstallerImpl.run(UpdateInstallerImpl.java:29)Cause
Resolution
- SSH into Authentication Manager using the rsaadmin credentials.
- Login to the primary Authentication Manager server as rsaadmin and enter the operating system password.
Note that during Quick Setup another user name may have been selected. Use that user name to login.
- Change to root using the command sudo su -
sudo su -
- Navigate to the directory in question using the following command:
cd /opt/rsa/am/server/wrapper/
- Use the following command to check the current permissions of the backup directory:
ls -lsd backup/
- Change the owner of the directory and its content to be rsaadmin:
chown -R rsaadmin:rsaadmin backup/
- Make sure that the owner of the directory was changed successfully:
ls -lsd backup/
- Make sure that the owner of the content of the directory was changed successfully:
ls -lsR backup/
- Run the Authentication Manager 8.4 update again and the update should be successful.
Related Articles
RSA Authentication Manager 8.2 SP1 SDK SOAP connect fails due to ClassNotFoundException for RemoteAuthenticatorTestConnect… 148Number of Views What is 'AFX fulfillment state V' that is sometimes seen in the AFX log in RSA Identity Governance & Lifecycle? 289Number of Views Guidelines and resources for upgrading to SecurID Governance & Lifecycle 7.5.2 606Number of Views RSA Authentication Manager Upgrade to V8.6 Fails with Error: "Warning: Could not find file /opt/rsa/am/radius/system/lib/r… 319Number of Views How to verify TLS v.1.2 is configured correctly in RSA Authentication Manager 8.x 992Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Governance & Lifecycle Generic Database Collector Guide RSA Authentication Manager 8.7 SP2 Administrator's Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Authentication Manager 8.9 Setup and Configuration Guide
Don't see what you're looking for?