Users are not redirected back to SAML application after authenticating to the RSA SecurID Access Application Portal during SP-initiated SAML workflow.
Originally Published: 2021-09-15
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Cloud Authentication Service
Issue
The following message is displayed to the end user in the Application Portal:
Application appears to be improperly configured. Contact your Administrator for assistance.
The URL displayed in the end user's browser looks like:
https://portal.sso.example.com/WebPortal/error.html?singlepoint-auth-error=DENY&singlepoint-portal-event=auth-failed&singlepoint-error-message=You+are+not+authorized+to+use+this+IdP+connection.+If+you+think+this+is+in+error%2C+please+see+your+SinglePoint+administrator."
The identity router's symplified.log shows the following message for the user's attempt:
INFO com.symplified.service.appliance.idp.IdPServlet[91] - Authorization denied by IdP service:
com.symplified.service.appliance.idp.AssertionCreationException: DENY
at com.symplified.service.appliance.idp.IdPService.createAssertion(IdPService.java:402)
at com.symplified.service.appliance.idp.IdPServlet.doPost(IdPServlet.java:78)
at com.symplified.service.appliance.idp.IdPServlet.doGet(IdPServlet.java:59)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:634)
Cause
The following are examples of Request URLs that include the idp_id=<Issuer Entity ID> value.
https://portal.sso.example.com/IdPServlet?idp_id=<Issuer Entity ID>and
https://portal.sso.example.com/IdPServlet?idp_id=<Issuer Entity ID>&SAMLRequest=<encoded AuthnRequest>
To check whether or not the idp_id=<Issuer Entity ID> value is being included in the Request URL, a capture of the browser traffic can be done while recreating the issue. Once the browser traffic has been captured, look for the Request URL that the user is redirected with from the SAML app to the Application Portal to see if the idp_id=<Issuer Entity ID> is included in it.
Resolution
Workaround
Notes
- View the Identity Router System Log from the Cloud Administration Console
- Generate and Download the Identity Router Log Bundle
- View the /var/log/symplified/symplified.log file within the log bundle.
Related Articles
Users cannot authenticiate to the RSA SecurID Access Portal or protected applications using Microsoft Integrated Windows A… 200Number of Views Troubleshooting RSA SecurID Access Application Portal unsuccessful logon message due to a bad identity source bind 343Number of Views Users are unable to authenticate to external Self-Service Portal (SSP) after RSA Authentication Manager Integration Servic… 180Number of Views The RSA SecurID Access Cloud Authentication Service rejects signed SP-initiated SAML requests with an HTTP Redirect binding 399Number of Views Can the Microsoft Integrated Windows Authentication (IWA) icon be hidden in the RSA SecurID Access Application Portal? 95Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?