Workflow import sometimes does not work even though the result is a success
2 years ago
Originally Published: 2015-01-29
Article Number
000050727
Applies To
RSA Product Set: Identity Management and Governance
RSA Product/Service Type: Appliance
RSA Version/Condition: 6.8.1
Platform: JBoss
Platform (Other): null
O/S Version: N/A
Product Name: null
Product Description: null
Issue
When trying to overwrite an existing workflow by importing another copy of it, the import may not actually be processed even though the import process reports a success.
Cause
The workflows are compared using the workflow ID and not the name.  If the ID of the imported workflow does not match the ID of the existing workflow then the import assumes that they are not the same and skips the file.
Resolution
There is an enhancement request entered to look at improving the behavior.
Workaround
1. Make a backup
2. Delete the existing workflow
3. Import the replacement workflow