Not able to receive snmp logs when NIC Trapd services have already been turned on
2 years ago
Originally Published: 2009-09-30
Article Number
000043769
Applies To
enVision 3.7.x, 4.0.x
You can see that the NIC TRAPD service is turned on, however you don't see any log entries from EnVision Event Viewer, LC shared memory block or IPDB lsnode folders.

Running the following command line from the LC shows no logs are being collected in the shared memory block.

e:\nic\%version%\%hostname%\bin\shmtest TRAPD


Issue
To collect SNMP messages from the manage monitored device (e.g: Symantec AV 10)
NIC Trapd Service
Symantec AntiVirus
Cause
A typical cause is when the Microsoft SNMP TrapD Service is in a started status has occupied port 162.  In that case, the NIC trapd service will still be able to start, but will be listening on an alternate port number.
Resolution

Make sure the Microsoft SNMP service is turned off, then restart NIC trapd service for it to take effect.