The fimconsole application does not load correctly. The following error message shows in the admin server startup and in the adminserver.log
####<Feb 18, 2010 9:18:37 AM PST> <Error> <HTTP> <vdc-image001> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1266513517568> <BEA-101216> <Servlet: "AdminStartUpServlet" failed to preload on startup in Web application: "fimconfig".
com.rsa.fim.exception.util.ConfigurationException: One or more instances could not be retrieved
at com.rsa.fim.config.factory.ConfigFactory.getFIMConfig(ConfigFactory.java:186)
at com.rsa.fim.config.factory.ConfigFactory.getFIMConfigReadOnly(ConfigFactory.java:152)
Delete and then recreate the FIM database. This proceedure assumes that a valid backup of the FIM configuration data can be obtained. If you cannot obtain a valid backup you will lose all your FIM configuration data and may have to start from the default.
- Run backupConfig.cmd to create a backup of your FIM configuration data
- Delete the derby database files. Remove the directory C:\bea\user_projects\domains\base_domain\rsa-fim-config\demoDB and any backup directories called demoDB[date]
- Run restoreConfig.cmd to restore your FIM configuration data.
- If the above steps do not work, use the last good backup to restore from to have the most recent available configuration data.
Related Articles
FIM error 'The name ID plug-in configuration for this format could not be retrieved' 12Number of Views FIM error message 'name ID plug-in configuration for this format could not be retrieved' 15Number of Views Authentication Manager LDAP Connection Fails with "One or More Directory Connections Is Incorrect" 1.99KNumber of Views Error: Principal does not possess one or more authenticators when using RSA SecurID Access Authenticate app tokencode with… 591Number of Views FIM configuration console does not load after deployment. 18Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide