The following error shows in the standard output of the FIM managed server.
(It may be also logged at C:\bea\user_projects\domains\base_domain\servers\FIM\log\FIM.out if the server is started from the WebLogic Administrative Console.)
SEVERE: Dispatch[/Dashboard] to method nvPreView returned an exception
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
....Caused by: java.lang.ExceptionInInitializerError
at com.rsa.fim.admin.target.EJBCommandTarget.execute(EJBCommandTarget.java:45)
at com.rsa.fim.admin.Command.execute(Command.java:242)
at com.rsa.fim.ui.handler.DashboardHandler.executeFetch(DashboardHandler.java:32)
at com.rsa.fim.ui.action.home.DashboardAction.nvPreView(DashboardAction.java:45)
... 53 more
Caused by: com.rsa.fim.exception.util.ServiceLocatorException: Cannot instantiate Service Locatornull
at com.rsa.fim.util.ServiceLocator.<clinit>(ServiceLocator.java:50)
... 57 more
This error will occur if the server listen address and listen port are not exactly the same as that defined in the fim.properties file. Refer to page 61 in the FIM installation guide:
To configure a non-default port number:
1. Open the file FIM-domain-directory/rsa-fim-config/properties/fim.properties in a text editor.
2. Find the following lines:
jndi.url=t3://localhost:7001
jndi.ssl.url=t3s://localhost:7002
3. Make the following changes:
? Replace 7001 with the number you specified for the listening port. To view the port numbers you assigned , click Environment > Servers in the WebLogic Administration Console.
? Replace 7002 with the number you specified for the SSL listening port.
Check to see what server name and port the JMX service is running on. Look in the weblogic log file for the following line:
<JMX Connector Server started at service:jmx:iiop://10.14.97.114:7001/jndi/weblogic.management.mbeanservers.runtime
Ensure that the server name and port match exactly to what is defined in your weblogic console for the listen port and server and what is defined for the JMX URL in the fim.properties file
Note that this error message may occur if any failure prevents the FIM server from communication over JMX. See the following related solutions:
NMSV0602E: Naming Service unavailable. A communications error occurred.NMSV0602E: Naming Service unavailable. A communications error occurred.
Unknown System Error in FIM consoleUnknown System Error in FIM console
FIM 4.0 clustered deployment throws ServiceLocatorExceptionFIM 4.0 clustered deployment throws ServiceLocatorException
FIM is unable to replicate the cache between multiple FIM instances in a clustered deployment.FIM is unable to replicate the cache between multiple FIM instances in a clustered deployment.
Related Articles
Edit a Web-Tier Deployment Configuration 54Number of Views FIM console will not load due to class loader error. 12Number of Views Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update 2.67KNumber of Views FIM fimconsole does not load. error 'One or more instances could not be retrieved' 24Number of Views Unable to login to RSA Authentication Manager Security Console as super admin 5.35KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide