Troubleshooting Primary or Replica Hostname resolution
Originally Published: 2001-10-11
Last Modified: 2023-10-06
Article Number
Applies To
UNIX (AIX, HP-UX, Solaris)
Issue
Error: "Primary can't connect to replica" in Primary log after installing RSA ACE/Server 5.0 Replica
Primary ACE/Server not connecting with new replica
Primary/Replica name resolution problems
Cause
Resolution
On both the primary and Replica, in ace/prog/, run "sdrepmgmt list"
Compare the output between the two.
Replica 0: (fully qualified or short name?)
Replica 1: (fully qualified or short name?)
Compare the "Replica Service Names:" and "Replica Service Port:"
Make sure the service names are in your /etc/services file correctly. If the "Service Port Number:" shows "0", then run ace/prog/sdrepmgmt modify, enter the service name, and it should resolve out of the services file to the correct port.
In ace/prog on the Replica run sdinfo and compare the format of the names for "Primary Server" and "This Server".
The Primary Name should also follow the same format as the "Replica 0:"
entry in sdrepmgmt (short name, or long name).
The "This Server:" entry should match the format in sdrepmgmt for each of
the appropriate servers. If not, see: Primary does not communicate with replica. Activity monitor does not show messages.
Once these issues are resolved, see: Database synchronization errors between Primary and Replica servers in RSA ACE/Server to create and copy a new Replica's database package and copy it to the Replica.
Related Articles
Quick Setup of a Replica Instance fails the attach to the Primary Instance 822Number of Views Change the Hostname of a Primary or Replica Instance in Azure 202Number of Views Primary or Replica Instance Network Settings Updates 153Number of Views Troubleshooting RSA MFA Agent for Microsoft Windows 4.45KNumber of Views Troubleshooting RSA Authentication Manager 8.1 native SecurID and RADIUS authentication issues 4.75KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?