RSA Access Manger error message 'This stream has been closed'.
Originally Published: 2013-11-12
Last Modified: 2023-09-25
Article Number
Issue
The following error message is logged in the aserver.log (or lserver.log) file:
sequence_number=5311,2013-10-25 14:10:36:215 EDT,messageID=-2,internal_error,description='This stream has been closed.',details='java.io.IOException: This stream has been closed.'
The following exception is generated in the aserver.out standard output:
java.io.IOException: This stream has been closed.
at sirrus.util.io.FlushingByteArrayOutputStream.checkForStreamClosure(FlushingByteArrayOutputStream.java:162)
at sirrus.util.io.FlushingByteArrayOutputStream.write(FlushingByteArrayOutputStream.java:92)
at java.io.DataOutputStream.writeByte(DataOutputStream.java:136)
at sirrus.util.io.rpc.fope.ObjectNode.writeTypeToStream(ObjectNode.java:76)
at sirrus.util.io.rpc.fope.Node.writeToStream(Node.java:49)
at sirrus.util.io.rpc.fope.NodeFactory.convertNodeToStream(NodeFactory.java:78)
at sirrus.util.io.rpc.RPCManager.invokeLocalProcedure(RPCManager.java:179)
at sirrus.authserver.MuxRequestThreadPool$MuxWorkerTask.call(MuxRequestThreadPool.java:386)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
Cause
cleartrust.aserver.muxworker.write.timeout = 10000
It indicates that the muxworker thread has abandoned the connection because it has been open too long, but the database still attempted to return a result.
Resolution
Investigate delays in the database response time.
Workaround
Notes
sequence_number=23519,remote_client=aserver1,2011-01-11 15:35:57:401 GMT,messageID=-2,internal_error,description='Unable to send data to receiver.',details='java.io.IOException: Unable to send data to receiver.'
The unable to send data to receiver message indicated the client had failed over. You will no longer see this message when the aserver is slow to respond.
Related Articles
RSA Identity Governance and Lifecycle fails to start after patching with error "Patching has failed" and "Closed Connection" 99Number of Views Export and Import Closed Requests 22Number of Views Error message "The underlying connection was closed: An unexpected error occurred on a send" when trying to run RSA Authen… 138Number of Views Cannot link the runtime identity source because no administrative identity sources reference this runtime source in RSA Au… 461Number of Views AAoP in websphere and DB2 deleting users could throw an error 'result set is closed. ERRORCODE=-4470' 23Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?