After restoring KCA (with nCipher) cannot issue a certificate.
Originally Published: 2001-11-19
Last Modified: 2023-10-06
Article Number
Applies To
nCipher Hardware Security Module
Issue
When issuing a certificate, the following error shows and the certificate is not issued: PROGRAM ERROR
req-authorize.xuda: Line 515: [XrcNOTFOUND] unable to locate requested member or object. Unable to sign certificate [unable to locate member or object].
Resolution
Make sure that the nCipher security world was restored properly and you can access all the keys protected by the appropriate nCipher's Operator Card Set. The nCipher commands "nfkminfo", "enquiry", and "slotinfo" can be used to enquire about the status of the security world and the Operator Card Set. When restoring nCipher's security world to a different box, please make sure that you use "initunit" command to initialize the nCipher HSM first, then copy the "kmdata" directory (containing security world data), and finally run the "sw-rest" command.
Consult the nCipher's documentation for detailed information on how to restore nCipher's security world.
Workaround
Related Articles
Cloud Access Service and Authenticators Historical Release Notes (March 2024 - January 2024) 36Number of Views Generate and Download a Certificate Bundle for Service Providers and Identity Providers for the SSO Agent 47Number of Views Roles stuck in Applied state in SecurID Governance & Lifecycle 384Number of Views How to generate a Certificate Signing Request (CSR) with the Subject Alternative Name (SAN) field using openssl on RSA Aut… 523Number of Views RSA Identity Governance and Lifecycle migration script insertMigrationReportDefinitions.sh fails with error ORA-01017: tab… 201Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Governance & Lifecycle Generic Database Collector Guide RSA Authentication Manager 8.7 SP2 Administrator's Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Authentication Manager 8.9 Setup and Configuration Guide
Don't see what you're looking for?