
BoleslawMynarsk (Customer) to rsaSFDCadmin (RSA): asked a question.
Cannot apply P04 to v7.5.2 P03
To be clear, I already have a case opened on this but I am curious if anyone
else ran into this issue:
"After the successful upgrade to v7.5.2 P03 from v7.2.1 P12, I tried to patch
it with P04. P04 patched ear file never deploys and fails with an error. See
attached P04 installation log file.
Following error at the end of the patching is revealing:
grep: /home/oracle/wildfly/domain/servers//log/server.log: No such file or directory
The 'grep' command points to non existing directory. It should be pointing to
**/home/oracle/wildfly/domain/servers/img-server-1/log/server.log** instead."
The installation script (patch.sh) exits with "Error deploying the ear file"
the last 50 lines from the installation log reveal following:
"Feb 10, 2023 9:02:13 AM java_util_logging_Logger$severe$1 call
SEVERE: Domain controller hostname or IP address is needed for the CLI connection
Feb 10, 2023 9:02:13 AM java_util_logging_Logger$severe$1 call
SEVERE: checkIfWildflyRunning - Server state can not be determined at this time; will try again.
Feb 10, 2023 9:02:13 AM java_util_logging_Logger$info$0 call
INFO: Terminate session
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$info$0 call
INFO: Connecting to check connection
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$severe$1 call
SEVERE: Domain controller hostname or IP address is needed for the CLI connection
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$severe$1 call
SEVERE: checkIfWildflyRunning - Server state can not be determined at this time; will try again.
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$info$0 call
INFO: Terminate session
Feb 10, 2023 9:02:15 AM java_util_logging_Logger$warning$3 call
WARNING: The CLI command was not successful: null
Wildfly is not running to re-deploy the ear. The application server must be running in order to deploy ear file.
An error occured in the customizeACM command : error code 4
Error deploying the ear file
Step failed! See /home/oracle/Aveksa_7.5.2_P04/logs/7.5.2_P04_2023-02-10-0845.log for more information."
By the way, the error above saying that 'wildfly' is not running is absolutely
wrong as it is and I can connect to the app front end (web). Of course, the
patch still shows P03. From my perspective, the install script is buggy.
The only thing I did not mention in the information above was that prior to
7.5.2, our wildfly was always running in a "standalone" server mode. After
the upgrade to 7.5.2, it automatically sets it to domain.
else ran into this issue:
"After the successful upgrade to v7.5.2 P03 from v7.2.1 P12, I tried to patch
it with P04. P04 patched ear file never deploys and fails with an error. See
attached P04 installation log file.
Following error at the end of the patching is revealing:
grep: /home/oracle/wildfly/domain/servers//log/server.log: No such file or directory
The 'grep' command points to non existing directory. It should be pointing to
**/home/oracle/wildfly/domain/servers/img-server-1/log/server.log** instead."
The installation script (patch.sh) exits with "Error deploying the ear file"
the last 50 lines from the installation log reveal following:
"Feb 10, 2023 9:02:13 AM java_util_logging_Logger$severe$1 call
SEVERE: Domain controller hostname or IP address is needed for the CLI connection
Feb 10, 2023 9:02:13 AM java_util_logging_Logger$severe$1 call
SEVERE: checkIfWildflyRunning - Server state can not be determined at this time; will try again.
Feb 10, 2023 9:02:13 AM java_util_logging_Logger$info$0 call
INFO: Terminate session
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$info$0 call
INFO: Connecting to check connection
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$severe$1 call
SEVERE: Domain controller hostname or IP address is needed for the CLI connection
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$severe$1 call
SEVERE: checkIfWildflyRunning - Server state can not be determined at this time; will try again.
Feb 10, 2023 9:02:14 AM java_util_logging_Logger$info$0 call
INFO: Terminate session
Feb 10, 2023 9:02:15 AM java_util_logging_Logger$warning$3 call
WARNING: The CLI command was not successful: null
Wildfly is not running to re-deploy the ear. The application server must be running in order to deploy ear file.
An error occured in the customizeACM command : error code 4
Error deploying the ear file
Step failed! See /home/oracle/Aveksa_7.5.2_P04/logs/7.5.2_P04_2023-02-10-0845.log for more information."
By the way, the error above saying that 'wildfly' is not running is absolutely
wrong as it is and I can connect to the app front end (web). Of course, the
patch still shows P03. From my perspective, the install script is buggy.
The only thing I did not mention in the information above was that prior to
7.5.2, our wildfly was always running in a "standalone" server mode. After
the upgrade to 7.5.2, it automatically sets it to domain.
environment variables although there was no indication why these were not set
correctly prior to the upgrade.