Article Number
000033498
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.0.0, 7.0.1
Issue
After upgrading to RSA Identity Governance and Lifecycle 7.0.0 or 7.0.1, all collectors fail.
The following errors are logged to the
aveksaServer.log file (
$AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log😞
05/24/2016 14:25:55.860 ERROR (Exec Task Consumer#0) [com.aveksa.server.xfw.TaskExecutor] Failed method=Execute ExecutionTask[TaskID=17529 RunID=15274 Source=1 Type=DataObjectProcessing Status=InProgress] com.aveksa.server.xfw.ExecutionException: com.aveksa.server.collector.DataProcessorException: com.aveksa.server.db.PersistenceException: java.sql.SQLIntegrityConstraintViolationException:
ORA-01400: cannot insert NULL into ("AVUSER"."GTT_DADC_CHILD_EDC_MAP"."CHILD_EDC_ID")
ORA-06512: at "AVUSER.COMMON_EXPLODER", line 1307
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 244
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 450
ORA-06512: at line 1
Please refer to RSA Knowledge Base Article
000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the
aveksaServer.log file for your specific deployment, if you are on a WildFly cluster or a non-WildFly platform. The
aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (
Admin >
System >
Server Nodes tab > under
Logs.)
Cause
This is a known issue reported in engineering ticket ACM-64739.
The ORA-01400 error occurs when NULL values are being inserted into GTT_DADC_CHILD_EDC_MAP.CHILD_EDC_ID. Starting in RSA Identity Governance & Lifecycle 7.0.0 there was an internal change to the GTT_DADC_CHILD_EDC_MAP table definition that no longer allows NULL values to be inserted into column CHILD_EDC_ID.
Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle versions and patch levels:
- RSA Identity Governance & Lifecycle 7.0.0 P05
- RSA Identity Governance & Lifecycle 7.0.1 P01
- RSA Identity Governance & Lifecycle 7.0.2
If you have encountered this issue prior to upgrading to one of the above versions or patch levels, please see the Workaround section for a resolution.
Workaround
To verify that you have this specific issue, please do the following:
- As avuser, execute the following SQL queries
SELECT * FROM t_maedc_process_history WHERE child_edc_id is NULL;
SELECT * FROM t_dadc_process_history WHERE child_edc_id is NULL;
SELECT * FROM t_av_data_access_edc_data WHERE child_edc_id is NULL;
SELECT * FROM t_av_parent_dadc_edc_data WHERE child_edc_id is NULL;
SELECT * FROM t_av_multi_app_edc_data WHERE child_edc_id is NULL;
- Open a case with RSA Identity Governance & Lifecycle Customer Support and attach the results of the above SQL queries to the case in CSV format.