Article Number
000032230
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 6.9.1, 7.0.0
Issue
When creating or editing a Workflow in RSA Identity Governance & Lifecycle 6.9.1 or 7.0.0 from an Internet Explorer 11 or Firefox web browser, the following error is displayed in the user interface and the create/edit of the Workflow fails (
Requests >
Workflows > {
Workflow-type tab} > {
Workflow name}):
ClassNotFoundException
com.workpoint.applet.ModelApplet
Cause
Java security updates can cause this issue.
Resolution
Upgrade to a supported version of RSA Identity Governance & Lifecycle. Supported versions use a new Workflow editor which does not have this issue.
Workaround
To workaround this issue in Internet Explorer, follow the steps below:
- Enable third-party cookies
- In the browser, click the Tools menu.
- Click Internet Options.
- Select the Privacy tab.
- Click Advanced under Settings.
- Select Always allow session cookies.
- Select the Accept button under Third-party Cookies and click OK.
- Remove certificates
- Select Start > Configure Java.
- Select the Security tab.
- Click Manage Certificates.
- In Certificate Type, from the drop-down menu, choose Trusted Certificates.
- Select all which have Workpoint LLC.
- Click Remove.
- Disable Verification
- Select Start > Configure Java.
- Click the Advanced tab.
- Under Mixed code (sandboxed vs. trusted) security verification, select Disable verification.
- Add the server URL (https://<IP_address_of_server>:port)
- Go to Start > Configure Java
- Click the Security tab.
- Click Edit Site List.
- Click Add.
- Enter the URL. Do NOT add /aveksa/main in the URL, only the IP address and port (port is optional).
- If all the above fail, try the following:
- Install a new or different version of Java. Even going from a 64-bit version to a 32 -bit can sometimes resolve the issue. Be sure to point the browser to the new version from Start > Configure Java > Java tab. Restart the browser to pick up the new Java version.
- Try reinstalling the browser and check the settings as outlined in steps 1 - 4 above.
- Try using a different browser such as Chrome or Edge. Sometimes one will work with a particular configuration whereas another browser will not.